4 Replies Latest reply: Mar 22, 2013 5:58 PM by Curmudgeon Boy
Curmudgeon Boy Level 1 Level 1 (0 points)

I use a Tascam US 1800 audio I/O with my Mac Pro, but I have to reset the System Preferences to the US 1800 every time I restart the computer. The computer defaults to Line In and Line Out.

 

I thought perhaps there was something wrong with the US 1800, so I tested it with my MacBook Pro and that computer retains the Sound preferences to the US 1800 when shut down and restarted. So it seems like the issue is with the Mac Pro.

 

Does anyone have an idea what may be causing this and how to remedy it?

 

Thanks!

 

dm


Mac Pro, Mac OS X (10.7.5)
  • 1. Re: Does not retain system sound preference settings
    Linc Davis Level 10 Level 10 (117,935 points)

    Triple-click the line below to select it:

    /Library/Preferences/Audio/com.apple.audio.SystemSettings.plist

    Right-click or control-click the highlighted line and select
       
    Services Show Info
      
    from the contextual menu. An Info dialog should open.
      
    Does the dialog show that "_coreaudiod" can read and write in the Sharing & Permissions section?
    In the General section, is the box labeled Locked checked?
    What is the Modified date?

  • 2. Re: Does not retain system sound preference settings
    Curmudgeon Boy Level 1 Level 1 (0 points)

    Thanks Linc.

     

    It looks like it's set to read & write, and it's not locked. But it appears to have not changed since December.

     

    Any ideas?

     

    Screen Shot 2013-03-22 at 8.01.31 PM.png

  • 3. Re: Does not retain system sound preference settings
    Linc Davis Level 10 Level 10 (117,935 points)

    The permissions are totally wrong. It looks like someone has intentionally changed them.

     

    First, since I don't know what other damage has been done, you should at the very least back up all data and then run Repair Permissions in Disk Utility. That action may fix some (not all) other files with wrong permissions, but it wont fix this one.

     

    If you have more than one user account, you must be logged in as an administrator to carry out these instructions.

     

    Triple-click anywhere in the line below to select it:

     

    sudo chown 202:202 /L*/P*/A*/*.audio.*.plist; sudo chmod -N $_

     

    Copy the selected text to the Clipboard (command-C).

     

     

    Launch the Terminal application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

     

    Paste into the Terminal window (command-V). You'll be prompted for your login password, which won't be displayed when you type it. If you don’t have a login password, you’ll need to set one before you can run the command. You may get a one-time warning not to screw up. Confirm. You don't need to post the warning. If you see a message that your username "is not in the sudoers file," then you're not logged in as an administrator.

     

    Quit Terminal and reboot.

  • 4. Re: Does not retain system sound preference settings
    Curmudgeon Boy Level 1 Level 1 (0 points)

    Linc --

     

    I'm not sure exactly what we did, but that fixed it! Hooray!

     

    Many thanks for your expertise and assistance!!!