1 2 Previous Next 21 Replies Latest reply: Apr 6, 2013 9:40 AM by léonie
John Dunnigan Level 1 Level 1 (50 points)

Hello All -

 

Each time I attempt to open my Aperture library I now get a window that says something like "Aperture quite while attempting to restore its windows. Do you want to attempt to restore it's windows?" I have two choices -- Don't Restore Windows or Restore Windows. No matter which one I choose I then get the window that says "Opening Aperture - name of my library" and the gear that continually spins. The spinning beach ball also appears. This goes on for about 30 minutes before it appears to quite trying and my computer monitor (ACD 23inch) goes black. Although the computer still appears to be running I have to manually reboot the system by shutting everything down and turning it back on. Once the computer is restarted, Aperture still tries to open. I am able to Force Quit. I have then attempted to open Aperture by holding down the Option key (so I could attempt to open my other library on an external drive or so that I could attempt to create a new library. I still get the window that asks whether I want to rebuild window or not. I have also attempted to open Aperture while holding down Option + Command. Still get the same thing -- Spinning beach ball, spinning gear while attempting to restore windows, then the crash and black screen.

 

Now let me explain how this all started -- I imported a new project (319 images). Everything appeared to go just fine, I was even able to backup the entire library (typically, once I import a new project my next step is to backup my library before doing anything else). All thumbnails were there, all previews seemed to have generated. However, some of the previews were scrambled at the bottom when first appearing on the screen, but in a second they would render normally. I attempte to regrenerate previews in an attempt to fix the scrambling. This did not work. I restarted my computer (sometimes this help to "refresh" everthing). When attempting to open Aperture I would then get a window that said "Apeture has detected inconsistencies in you library" with the option to restore. This happened several times, but each time the restoration process appeared to go fine since my library successfully opened. However, a new problem appeared. Now there were no thumbnails. However, I could still click on a thumbnail and see the image in the browser. Attempted to regenerate thumbnails. This did not work.

 

Since I still had all the images on my CF card I decided to start fresh by deleting the project and re-importing the images. Importing the project seemed to be going fine but suddenly stopped at 67% complete. I cancelled the import, deleted the images that had imported (they had no thumbnails), and was going to start the re-importing process again. And this has now brought me to the situation described in the first paragraph above -- No matter what I do, attempt to open normally, attempt to open by holding down Option key, attempt to open by holding down Option + Command key -- I just get the window that says "Opening Aperture - name of my library" with the spinning gear and spinning beach ball, followed by a crash and sudden black screen. Sometimes it still asks me if I want to attempt to restore windows, but I get the exact same result.

 

I am at a complete loss and have absolutely no idea what to do now. I do have a backup of my library and I still have the images of my last shoot on my CF card. If I delete the library from my pictures folder can I then create a new library and build it using my backup?

 

Please help. Desperate!

 

John


Mac Pro, Mac OS X (10.6.5), MacBook Pro, iPhone, iPad, AppleTV
  • 1. Re: Extreme Nightmare - Aperture Won't Open
    léonie Level 9 Level 9 (51,720 points)

    John, what is your Aperture version? And is the Mac OS X (!0.6.5) version in your profile signature still valid?

     

    I'd suggest to start trouble shooting by finding out if settings in your user account are faulty, your Aperture library contains a badly corrupted image or video, or your system has problems. Log into a different user account (create one from the System Preferences > Users & Groups panel for testing) and try if aperture is still starting up correctly. Try to create a new, empty Aperture library, add some image - not the ones from your card that are causing problems. Does that work?  If yes, move new, simple library to your external drive, so you can use for testing from your main account.

     

    Then sign back into your main account and double click the new test library. Can Aperture open that Library from your main account?

     

    Reagrds

    Léonie

  • 2. Re: Extreme Nightmare - Aperture Won't Open
    John Dunnigan Level 1 Level 1 (50 points)

    Thanks Leonie --

     

    I will try that in a little while if necessary. However, I found one more suggestion online that might help. I held the SHIFT key while opening my Aperture library. This time, so far, there has been no crash or black screen. My library has opened. It took about 30 minutes to get to this point, but my Aperture library is showing. I'm now getting the spinning beach ball. No images are showing on the screen yet, but I am seeing all of my projects in the the left side panel. I'm hoping that the spinning beach ball is telling me that Aperture is still working on correcting something. I'm going to let it to continue doing its thing for a while longer. If it looks, however, like it's just hanging I'll move onto your suggestion above.

     

    Seriously, thanks so much for responding,

     

    John

  • 3. Re: Extreme Nightmare - Aperture Won't Open
    John Dunnigan Level 1 Level 1 (50 points)

    Leonie -- I'm running Aperture 3.4.3 (I think -- Whatever the latest is) and am on Lion actually (also the latest). I am not on Mountain Lion. (Sorry I forgot to answer that in the first response).

     

    John

  • 4. Re: Extreme Nightmare - Aperture Won't Open
    John Dunnigan Level 1 Level 1 (50 points)

    Leonie --

     

    Beach ball finally stopped. Window came saying "An inconsistency in your database has been detected. The application will now quit, relaunch, and restore your database to a consistent state. This may take some time."  I now have a spinning beach ball again while, I'm guessing, the system is attempting to move onto the next stage. It hasn't yet quit.

     

    John

  • 5. Re: Extreme Nightmare - Aperture Won't Open
    John Dunnigan Level 1 Level 1 (50 points)

    Leonie --

     

    Library appears to have rebuilt itself successfully -- all of my former projects, versions, edits seem to be there. Now the big question -- do you know how I can get the images from yesterday onto my computer (without using Aperture) so that I can try and find the possible corrupted images(s)? If I do get those onto my computer how do I then find the corrupted image(s)? Should I create a new, test Aperture library and then if all looks okay export to desktop and then import that project into my main Aperture library? I really don't want to risk importing into my main library right away and then having to go thru this all over again.

     

    John

  • 6. Re: Extreme Nightmare - Aperture Won't Open
    léonie Level 9 Level 9 (51,720 points)

    That is very promising. Your test with the Shift-key showed, that you have one or more corrupted images. And probably a corrupted library structure as well, because of the crashes and force quitting. And the later has been repaired.

    Now the big question -- do you know how I can get the images from yesterday onto my computer (without using Aperture) so that I can try and find the possible corrupted images(s)?

     

    Where are your images from yesterday now? Have you removed them from the library? How many images are that?

    If they are already outside, you could import them into a new Aperture library for screening - I just wrote a User Tip on how to do this:

     

     

     

                     How to Screen an Aperture Library for Corrupted Image Files or Videos

     

     

    If your new Aperture Library is o.k. and you found and removed the corrupted media files, you can merge it into your main library by importing the library.

  • 7. Re: Extreme Nightmare - Aperture Won't Open
    John Dunnigan Level 1 Level 1 (50 points)

    leonieDF --

     

    Thanks so much for continuing to respond. Here's an update to what I did over the weekend. I was able to create a new library & import without incident the images that I thought were corrupted (All 319 images imported with thumbnails and previews. I can make versions no problem, export to Photoshop for editing & reimport into Aperture).

     

    However, the main library that I thought was fine now (I had all thumbnails after getting completely rid of the problem project) has now started to act strange. At least one of my former projects now suddenly has missing thumbnails. All previews are there -- If I click on the empty thumbnail the preview shows & I can edit. Sometimes when I create a duplicate version of an original in this project the version thumbnail will appear on the version, sometimes not.

     

    I have attempted to regenerate thumbnails with no success. I did perform a backup. It took some time, but I did get the black gear at the bottom next to my vault. Terrified at this point that I'll loose everything. Is there any way to reload Aperture cleanly without having my images lost? Or perhaps that's unnecessary?

     

    John

  • 8. Re: Extreme Nightmare - Aperture Won't Open
    léonie Level 9 Level 9 (51,720 points)

    I was able to create a new library & import without incident the images that I thought were corrupted (All 319 images imported with thumbnails and previews. I can make versions no problem, export to Photoshop for editing & reimport into Aperture).

     

    That is a good sign, John. It shows that iPhoto and your system are probably working well.

    I have attempted to regenerate thumbnails with no success. I did perform a backup. It took some time, but I did get the black gear at the bottom next to my vault. Terrified at this point that I'll loose everything. Is there any way to reload Aperture cleanly without having my images lost? Or perhaps that's unnecessary?

    Now that you have removed the suspect project, have you tried again to repair your Aperture Library with option-command held down? Maybe now it will succeed.

    before you do anything with your main library, check if your backup is up to date.

     

    How much disk space do you have? Can it be, that you are running out of disk space?

     

    Léonie

  • 9. Re: Extreme Nightmare - Aperture Won't Open
    John Dunnigan Level 1 Level 1 (50 points)

    Leonie --

     

    Will attempt a repair this evening. Thanks for the suggestion! (For some reason, I guess with everything that happened & all of the "repairs" that it already performed, I didn't think about trying that). I have about 500GB free space on my drive. Also, you mentioned iPhoto above, did you means Aperture?

     

    Thanks,

     

    John

  • 10. Re: Extreme Nightmare - Aperture Won't Open
    léonie Level 9 Level 9 (51,720 points)

    Also, you mentioned iPhoto above, did you means Aperture?

    Yes, sure, Aperture sorry for that - I just had been visiting the iPhoto forum, when I saw your post!

     

    Will attempt a repair this evening.

    Try all three repairs.

  • 11. Re: Extreme Nightmare - Aperture Won't Open
    John Dunnigan Level 1 Level 1 (50 points)

    Leonie --

     

    Performed all three repairs. None of them worked, thumbnails still missing. In fact, some of the thumbnails that were created yesterday when I made duplicate versions and/or after performing edits in Photoshop have now disappeared. I noticed that after Aperture opened in Project View after each repair there were several "recovered projects", each with two items in them. I did not attempt to open these. Perhaps there is a way to get rid of them? There is, however, nothing in Aperture trash. If you or anyone else has any other suggestions I'd be grateful.

     

    Depressed,

     

    John

  • 12. Re: Extreme Nightmare - Aperture Won't Open
    léonie Level 9 Level 9 (51,720 points)

    The "Recovered" projects will be created after a "Rebuild". They are a kind of "Lost&Found" project. Aperture will put orphaned original master files files there, that are not linked to any image version. It is perfectly safe to open them.

     

    I would not delete any image you see there, unless you have checked, if you have duplicates of these "Recovered" images somewhere. But open these projects and look into them. They either are images that you wanted to delete, but the deletion did not succeed and the original image files were left behind, or they may be recovered originals of images in your bad projects.

     

    And I really hope, someone will jump in with more ideas !  Have you checked, it the drive is o.k.  where your Aperture library is stored?

  • 13. Re: Extreme Nightmare - Aperture Won't Open
    John Dunnigan Level 1 Level 1 (50 points)

    Leonie --

     

    According to Disc Utility my drive seemed just fine. I ran a Repair Permissions just for good measure. I restarted my machine (sometimes that helps). I also performed again all three repairs on my Aperture library -- Repaired, Rebuilt and Restored. Still no love from Aperture -- Thumbnails still missing. I'm at a complete loss. Can't believe after all these years using Aperture that I'm now at the point where I just don't know whether I can trust it anymore.

     

    John

  • 14. Re: Extreme Nightmare - Aperture Won't Open
    léonie Level 9 Level 9 (51,720 points)

    Have you tried to import your Library into the new one, that is working?

     

     

     

    I do have a backup of my library and I still have the images of my last shoot on my CF card. If I delete the library from my pictures folder can I then create a new library and build it using my backup?

    How current is your backup?

     

    Do you have an external drive with enough free space to restore your backup there and to test if it is working? I would not delete the current library before you know, if the backup is any better.

1 2 Previous Next