Skip navigation

Mountain Lion no Wifi after wake from sleep

101395 Views 421 Replies Latest reply: Aug 18, 2013 8:29 AM by rgotty RSS
  • Sandman Level 4 Level 4 (3,270 points)
    Currently Being Moderated
    Mar 19, 2013 5:39 PM (in response to ilovecode)

    Remember, Apple may keep track of these forums.. but if you want them to know about a bug, you have to report it.. posting here does not notify Apple.

     

    To report a bug, go here:

     

    http://www.apple.com/feedback/macosx.html

     

    That said, I was wondering what type of Wifi security people are using and if that may be related to the slow wifi reconnect after sleep.

     

    I am using WAP2 and will mess around to see if this setting is the problem.

     

    This is what I see in logged in Console when I wake from sleep on my spanking new 27 inch iMac..

     

    3/19/13 4:16:02.000 PM kernel[0]: Wake reason: EHC1

    3/19/13 4:16:02.000 PM kernel[0]: wlEvent: en1 en1 Link DOWN virtIf = 0

    3/19/13 4:16:02.000 PM kernel[0]: AirPort: Link Down on en1. Reason 8 (Disassociated because station leaving).

    3/19/13 4:16:02.000 PM kernel[0]: en1: link down event, informing supplicant.

    3/19/13 4:16:02.000 PM kernel[0]: en1::IO80211Interface::postMessage bssid changed

    3/19/13 4:16:02.000 PM kernel[0]: en1: setting diversity to: -1

    3/19/13 4:16:02.000 PM kernel[0]: en1: Error configuring antenna diversity (index = -1).

    3/19/13 4:16:02.000 PM kernel[0]: en1: setting tx antenna: -1

    3/19/13 4:16:02.000 PM kernel[0]: en1: Error configuring transmit antenna (index = -1).

    3/19/13 4:16:02.000 PM kernel[0]: IO80211ScanManager::startScanMultiple: Scan request received from pid 5149 (2 SSIDs, 0 BSSIDs).

    3/19/13 4:16:02.000 PM kernel[0]: IO80211ScanManager::startScanMultiple: Initiating scan.

    3/19/13 4:16:03.000 PM kernel[0]: AirPort: RSN handshake complete on en1

     

    The log suggests there is a lot going on in the first 1-2 seconds.. but it takes at least 5 at best.. usually 10 seconds for it to connect to my network.... and I see this.. 10 seconds after the AirPort: RSN handshake log..

     

    3/19/13 4:16:13.113 PM airportd[5149]: _doAutoJoin: Already associated to “Hippocampus 5GHz”. Bailing on auto-join.

  • vallejogreg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 22, 2013 3:53 PM (in response to Sandman)

    "Remember, Apple may keep track of these forums.. but if you want them to know about a bug, you have to report it.. posting here does not notify Apple.

     

    To report a bug, go here:"

     

    http://www.apple.com/feedback/macosx.html

     

    Thanks Sandman.  Did just that. 

  • vallejogreg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 23, 2013 9:58 AM (in response to rvjacobs)

    Change Sleep to "Never" or at least 2 hours in Energy saver prefs.  Or, Uncheck "wake for network access" in net work prefs AND uncheck  ITunesFIle Sharing in Itunes sharing prefs.

     

    Problem is with Sleep when networked to devices over wifi.  You can also buy the latest Apple Extreme or Airport router if you want to pay to fix problem

  • Herbert Schulz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 23, 2013 10:11 AM (in response to vallejogreg)

    Howdy,

     

    Turning Sleep to ``Never'' is NOT a fix but rather a way to avoid running into the problem which should get fixed.

     

    Incidentally, I've unchecked ``wake for network access'' for about a week now and haven't had my Gen1 Time Capsule drop my Ethernet connection upon wake. But it'll take a while longer for me to start feeling comfortable. I'd just as soon not have to buy a Gen4 Time Capsule but...

     

    Good Luck,

    herbs2

  • vallejogreg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 23, 2013 10:50 AM (in response to leandro_br)

    Change Sleep to "Never" or at least 2 hours in Energy saver prefs.  Or, Uncheck "wake for network access" in net work prefs AND uncheck  ITunesFIle Sharing in Itunes sharing prefs.

     

    Problem is with Sleep when networked to devices over wifi.  You can also buy the latest Apple Extreme or Airport router if you want to pay to fix problem

  • vallejogreg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 23, 2013 10:54 AM (in response to Herbert Schulz)

    You can buy new stuff.  Ever since Snow Leopard, Apple added a wake on demand program called Bonjour Sleep Proxy - cause these problems unless your devices are really new.  If you're not networking a bunch of devices, you've found your solution with turning off wake for network access and never sleep - I just changed my sleep to just over two hours since I use my computer pretty often

  • WildBill Level 3 Level 3 (530 points)
    Currently Being Moderated
    Mar 23, 2013 11:12 AM (in response to vallejogreg)

    If you're correct in your assessment of this issue and it's solution, then perhaps someone should consider this issue solved? Do you think it covers everyone with this issue?

  • Herbert Schulz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 23, 2013 11:32 AM (in response to WildBill)

    Howdy,

     

    Quite frankly I don't consider any of these suggestions as fixes. They are all work-arounds. I happen to not need ``wake for network access'' but there are others that do need that feature active. Apple never says that I need a late generation Time Capsule (or Airport Extreme, etc.) to use that feature so, until Apple says so it should work.

     

    Good Luck,

    Herb Schulz

  • Marcelo NS Level 1 Level 1 (40 points)
    Currently Being Moderated
    Mar 23, 2013 11:58 AM (in response to Herbert Schulz)

    vallejogreg, howdy,

     

    Those works arownd unofortunately do not apply for the MBA that will sleep anyway when the lid is closed. If I open the lid the annoying bug shows up again (and no you cant keep the MBA all the time open, that makes the full concept of an ultraportable pointless).

    And regarding buying a new Airport is not realistic either. I use my devices with more than 10 wifi networks. I should ask most of Dutch goverment agencies, the train and the bus company to change their access points to an apple Airport Extreme, just because I had the stupid idea of buying a MBA lol .   

  • vallejogreg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 23, 2013 1:23 PM (in response to Herbert Schulz)

    Apple never says that I need a late generation Time Capsule (or Airport Extreme, etc.) to use that feature so ...

     

    Actually, they Do say that.  Just not very loudly.  They say you need the latest firmware and 802.11n router, which is saying you have to buy their router because there's not alot of routers out there that meet that spec.

  • vallejogreg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 23, 2013 1:27 PM (in response to Marcelo NS)

    Point well taken.  I think I read from apple that you can close the lid if you keep the machine plugged in and then you won't have this problem.  Apple really over reached on this issue of Wake on Demand for network Access

  • Herbert Schulz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 23, 2013 2:17 PM (in response to vallejogreg)

    Howdy,

     

    Well, the Gen1 Time CApsule certainly satisfies those conditions. It's at software version 7.6.3 which came out a bit earlier this year so that condition is met too. So why have I been having a problem with my WIRED connection to the router; at least until I turned off ``wake for network access'' and I'm still waiting...

     

    And most modern routers meet those specs as long as the user keeps the router software up to date.

     

    Good Luck,

    Herb Schulz

  • vallejogreg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 23, 2013 3:22 PM (in response to Herbert Schulz)

    I believe that if you even if you are wired, if the router isnt 802.11n and Bonjour Sleep Proxy capable, you will have this problem of unable to connect to internet on wake up.  MOst routers DO NOT meet those specs.  Apple put this out as open source code but that doesn't mean it will be adopted

  • Herbert Schulz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 23, 2013 3:35 PM (in response to vallejogreg)

    Howdy,

     

    Are the requirements now shifting on me? I have a Gen1 Time Capsule with the latest Apple Router Software installed, version 7.6.3. It's 802.11n. How do you tell if it's also, the newly stated requirement, ``Bonjour Sleep Proxy capable?''

     

    Good Luck,

    Herb Schulz

  • vallejogreg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 23, 2013 6:15 PM (in response to Herbert Schulz)

    OK you got me.  I don't know the various generations of TIme capsule - and  don't care. But I've read that dropping wifi is still possible. The problem people are complaining about is dropping WiFI then being unable to  log back on without shutting off router and turning back on.  The machine sees the network but can't log on.  Should only happen if asleep.  Maybe your issue is different.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (23)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.