1 Reply Latest reply: Mar 24, 2013 12:33 PM by dherb
dherb Level 1 Level 1 (0 points)

Is Safari 5.06 on OS 10.5.8 no longer supported? Autofill no longer works, flash player no longer works...etc. Is it time for a new macbook? silly question?