1 2 Previous Next 23 Replies Latest reply: Apr 23, 2013 10:56 AM by Clem
DanW98 Level 1 Level 1 (0 points)

I have Aperture updated and installed on my macbook pro and my iMac.  On vacation, I imported the photos to my MBP for review and editing.  I have done this many times in the past.  I can export the Projects or the Folder of my vacation pics to an Aperture library and can put it on the desktop of my iMac.  I cannot get Aperture to import this vacation library to add it to the main library on my iMac.

 

On my iMac, I selected "import library" (as I have done in the past) and it starts a process, calculating disk space and merging the libraries.  With about 3/4 of the progress bar filled, it fails and no images are brought over. 

 

I can "Switch libraries" on my iMac and can view all of the photos in the vacation library.  The photos are there and the edits are present.  I just can't bring them over to the iMac library successfully.

 

Both systems are the most current version of OSX and there are no new updates available for Aperture on either my MBP or my iMac. 

 

Anyone know how to get Aperture to import a library in the new version?  It looks like the new update of Aperture has a bug in it.


Aperture 3, Mac OS X (10.7.5)
  • 1. Re: Aperture won't import an Aperture library
    léonie Level 9 Level 9 (51,640 points)

    With about 3/4 of the progress bar filled, it fails and no images are brought over.

    What do you mean by "it fails"? Is there an error message or a crash log? Then post please the exact error message and the first 50 lines of the cras log.

    Both systems are the most current version of OSX and there are no new updates available for Aperture on either my MBP or my iMac

    Is your Aperture version 3.4.3? Sometimes updates are not show as available.

     

    Regards

    Léonie

  • 2. Re: Aperture won't import an Aperture library
    DanW98 Level 1 Level 1 (0 points)

    It's weird.  No error message.  The bar says "Merging Library" until it's about 5/6th full.  If I had dragged the vacation library to my Aperture library list, the partially transparent icon reappears where I let go of my mouse button in the Aperture window and flies back across the screen to where the vacation library icon is on my desktop.  The "Merging Library" continues for a bit more.  Then it just disappears and no photos are imported.

     

    The versions are 3.4.3 and 10.8.2.

     

    This has previously worked.  I used to do this after every vacation...  Shoot the photos, offload to my laptop, edit and delete, export the library, import the library to my iMac, done!

     

    DW

  • 3. Re: Aperture won't import an Aperture library
    léonie Level 9 Level 9 (51,640 points)
    This has previously worked.  I used to do this after every vacation...  Shoot the photos, offload to my laptop, edit and delete, export the library, import the library to my iMac, done!

     

    And that is how it is supposed to work.

    Have you done any trouble shooting? Repaired and rebuild the libraries in question?

    Aperture 3 User Manual: Repairing and Rebuilding Your Aperture Library

    If not, I'd start with the repair option, if necessary also rebuild the libraries.

     

    Before rebuilding check, if you have a current backup.

     

    What versions of MBP and iMac do you have? There has been at least one other thread with the similar problem on a MBP, and I wonder, if the problem only occurs on specific mac models.

    Aperture wont import other aperture library files - no error message?

     

    Regards

    Léonie

  • 4. Re: Aperture won't import an Aperture library
    DanW98 Level 1 Level 1 (0 points)

    Sorry it took so long.  I updated my vault, which took around 12 hours to my NAS and ran my Time Machine.  I ran the Aperture library repair and rebuild last night on my iMac.  It still won't import my photos.

     

    My iMac is a 27" Late 2009 Model 11,1.  It's a 2.66 Intel Core Intel Core i5 with 8GB 1067MHC DDR3.

     

    My MBP is older.  It's a 3,1 from 2007.  Intel Core 2 Duo with 4GB of memory.

     

    I rebooted my MBP and will run the library repair on it.  That will take overnight as well.  There aren't nearly as many photos there, but it's a lot slower.  I'm also going to try a trick.  I'll open the vacation library on my iMac by switching to it in Aperture.  Then I'll re-export it to my iMac desktop and try to reimport it.  Since I don't need to try this with all 800 of my vacation photos, I'll select one of my projects within the vacation folder to work with.  It's only 30 photos or so (they're all in RAW).

     

    I'll also check the other thread.

     

    DW

  • 5. Re: Aperture won't import an Aperture library
    DanW98 Level 1 Level 1 (0 points)

    OK.  I rebuilt permissions and did the library repair on both my MBP and my iMac.  I also rebooted both.   It didn't work.

     

    I also switched to a library ("Galapagos Day 1" from my MBP) from my vacation on my iMac.  I then exported that library to my iMac's desktop as a separate library, "Galapagos Day 1a".  I then attempted to import that library.  It didn't work.

     

    Any other thoughts?  This is really weird.  I'm going to end up having to export the versions as JPEGS (to contain the edits, crops, and color changes) and reimporting them as new photos rather than as an Aperture library with their non-destructive changes to the RAW files.

     

    DW

  • 6. Re: Aperture won't import an Aperture library
    DanW98 Level 1 Level 1 (0 points)

    I never get the "merge" option.  Whenever I import a library, it just starts the import and subsequently fails.

     

    DW

  • 7. Re: Aperture won't import an Aperture library
    léonie Level 9 Level 9 (51,640 points)

    Try to add a duplicate image, one that is already in your library on the iMac to your "Galapagos Day 1a" library, then import this modified library into the library on your iMac. The duplicate image shoud force Aperture to ask if it should "Add" or "Merge". Select "Add". You will have to remove the one duplicate afterwards, if the import should succeed this way. This just worked in another thread with a similar problem: Re: Aperture wont import other aperture library files - no error message?

     

    Regards

    Léonie

  • 8. Re: Aperture won't import an Aperture library
    DanW98 Level 1 Level 1 (0 points)

    So it seems to have worked.  Here's what I did:

    1. I switched to the Vacation library.
    2. I selected the first image in the library and exported just that one image as a separate library, called "Single Photo"
    3. I imported that "Single Photo" back into the Vacation library.  This will create a new project for just that photo.
    4. I moved it adjacent to the original photo in the first day's project.  Thus, two originals now exist side-by-side.
    5. I opened my Aperture library.
    6. I imported the Vacation library.  It now gives me the option of Adding or Merging the libraries. 
    7. Choose ADD.
    8. 25GB of copied RAW images takes a while.

     

    It's still churning away, but seems to be working.

     

    This is clearly an Aperture update issue.  How do I submit a request for an update issue?

     

    DW

  • 9. Re: Aperture won't import an Aperture library
    léonie Level 9 Level 9 (51,640 points)

    Great, I am glad that the "Duplicate" trick worked for you.

     

    To submit a request for update and to file a bug-report use the feedback form in the Aperture menu:

     

    Apple - Aperture - Feedback

     

    Regards

    Léonie

  • 10. Re: Aperture won't import an Aperture library
    antwerpenR Level 1 Level 1 (0 points)

    I have exactly the same problem and it has been like this for months.  It is really bad that a professional product like Aperture should have bugs like this with no acknowledgement from Apple and no view on when there might be a fix.

  • 11. Re: Aperture won't import an Aperture library
    coxorange Level 1 Level 1 (40 points)

    Hi Dan & Leonie!

     

    Now I have the same problem - I want to add a project of another Mac's Aperture library to my Mac.

     

    DanW98 wrote:

     

    So it seems to have worked.  Here's what I did:

    1. I switched to the Vacation library.
    2. I selected the first image in the library and exported just that one image as a separate library, called "Single Photo"

     

    I tried this (selected the first image in the one project), but can't export this - I get the message: "Invalid Selection - Please select a folder, project, subfolder, or album for export."

    What am I doing wrong?

    Thanks.

  • 12. Re: Aperture won't import an Aperture library
    léonie Level 9 Level 9 (51,640 points)

    "Invalid Selection - Please select a folder, project, subfolder, or album for export."

    What am I doing wrong?

    What is your Aperture version? In Aperture 3.4.3 it should suffice to select one image or some images and to use "File > Export > xxx as new library". If you have an older version, use "File > New > Album" first and create a new album with the selected images. Then proceed to export the new album as a new library.

     

    Regards

    Léonie

  • 13. Re: Aperture won't import an Aperture library
    coxorange Level 1 Level 1 (40 points)

    Thanks!

     

    My Aperture version is 3.4.3, but it's really not possible to use 1 image or 2 for export as new library. I only get that message.

     

    I will try it via Album. Till then...

  • 14. Re: Aperture won't import an Aperture library
    léonie Level 9 Level 9 (51,640 points)

    My Aperture version is 3.4.3, but it's really not possible to use 1 image or 2 for export as new library. I only get that message.

    I tried again, and now I also get surprising results - that definitely worked differently when I posted this in December, before the upgrade to MacOS X 10.8.3.  When I select one image in a project, only the option "Export project as Library" is available, and this will export all images in the project, not only the selected one. But creating an album only one image and exporting the album will work - at least it does for me.

1 2 Previous Next