6 Replies Latest reply: Jun 19, 2013 10:34 AM by Eagle Owl
Incaitunes Level 1 Level 1 (0 points)

Hello i just upgrate to mountain lion 10.8.2 when i use airplay to apple tv only stream video but no audio any ideas?


Mac mini, OS X Mountain Lion (10.8.2)
  • 1. Re: Mirroring no audio
    Radiation Mac Level 5 Level 5 (4,635 points)

    Do you meet the following Requirements for Airplay Mirroring?:

     

     

    Requirements for AirPlay Mirroring in OS X Mountain Lion

    An Apple TV


    Supported Macs: 
    AirPlay Mirroring in OS X Mountain Lion takes advantage of the hardware video encoding capabilities of 2nd and 3rd Generation Intel Core processors. Hardware video encoding allows AirPlay Mirroring to efficiently deliver high frame rates while maintaining optimal system performance. The following Mac models have processors that support AirPlay Mirroring:

    • iMac (Mid 2011 or newer)
    • Mac mini (Mid 2011 or newer)
    • MacBook Air (Mid 2011 or newer)
    • MacBook Pro (Early 2011 or newer)
  • 2. Re: Mirroring no audio
    SilverLiningSkipper Level 1 Level 1 (0 points)

    I meet all the requirements and have the same problem.  Latest updates to Apple TV and the my Macbook Pro. 

  • 3. Re: Mirroring no audio
    Incaitunes Level 1 Level 1 (0 points)

    Thanks for the advice, I solved the problem.

     

    Here is what I did:

     

    System preferences

    Sound

    Output

    And selected apple tv3

     

    Try that. It worked for me.

     

    Thanks

  • 4. Re: Mirroring no audio
    SilverLiningSkipper Level 1 Level 1 (0 points)

    Worked for me too! Thanks for posting.

  • 5. Re: Mirroring no audio
    huffcw Level 1 Level 1 (0 points)

    It is frustrating that going into system preferences is required when it should automatically switch the audio to the Apple TV without this additional step -- seems to be a bug in Airplay mirroring functionality.

     

    I have found that a reboot gets it working correctly as well. After a fresh reboot, the audio automatically switches to Apple TV when enabling Airplay mirroring.  Of course, this extra step shouldn't be needed (just like it shouldn't require going into system preferences).

  • 6. Re: Mirroring no audio
    Eagle Owl Level 1 Level 1 (35 points)

    Slightly easier than opening system preferences/Sound is to hold the "option" key whilst clicking the volume control on the menu bar. This will bring up a menu to select the output devices. (If you don't have the volume control on the menu bar you can enable it in system preferences/Sound.)