Skip navigation

iTunes audio/video drifts out-of-sync

111390 Views 76 Replies Latest reply: Apr 6, 2014 9:38 PM by Fuzzmunky RSS
  • very_sunny Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 12, 2012 10:07 PM (in response to Mr Me)

    Hi there Mr Me and co!

     

    Ive struggled to find an answer so maybe here it would be appropriate. (I sadly couldnt work the presets on premier pro that we recommended to take care of the iTunes issue)

     

    My problem is a bit of a peculiar one. I'm exporting an H.264 video preset for iPod/iPhone, sound I have tried varied 44.1khz or 48 khz with different bit rates and qualities, all this using Premier Pro, now when I play this exported file say using Quicktime on my mac, there are no issues, everything works fine, when I import it into iTunes, the video starts to lag behind a bit and then finally when I sync it to my iPhone 4s its painfully noticeable. Now my original raw file was 25 frames and the iPod preset is 29.97, so if it is the frame rate wouldn't it be the same problem on all those different players??

    Has anyone else had this issue? Is there a certain audio preset that anyone knows of that will allow even a compromised playback sync that is acceptable?

    Any pointers, any help or suggestion would be unreal! (same result on my iPhone 3G)

     

    Many thanks,

     

    From a confused and frustrated editor ;-)

  • Mr Me Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 18, 2012 3:03 AM (in response to very_sunny)

    Hey there! Unfortunately I have no experience using Premier Pro so I probably can't help much with this issue, however at first glance it seems unlikely that it's a framerate sync issue (if this were the case the video would drift more and more out of sync with the video and by the end of any footage the audio would continue against a black screen) as like you said, it should be the same with all players, and would represent a problem with the mastering of the file (perhaps check a Premier Pro forum for mention of such an issue?)

     

    The problems discussed on this thread are pretty much exclusive to Windows as iTunes for Mac is significantly better, and Apple's restrictions on system audio settings make it virtually impossible to screw things up, so I doubt any of the solutions posted here would be of any help, especially considering the problem is also on you iPhone. Considering this, your problem is particularly perplexing! iTunes doesn't normally allow the upload of videos on to an iDevice that is unable to play the file properly, which would suggest a mastering problem, however, Quicktime playback contradicts this! The problem you have thus probably has something to do with the finer details of Premier Pro and it's video exporting system which I'm afraid I have no knowledge of. Premier Pro forums are probably your best bet.

     

    Sorry couldn't be more helpful, hopefully that has pointed you in the right direction!

  • sjr69 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 10, 2012 9:31 PM (in response to Mr Me)

    Hello, i would just like to thank you so much.  i recently got this Acer and iv had this problem for months, i have searched many online places but your instructions are the only thing that fixed it, thank you so much, i usualy watch movies (via itunes) almost every night and day and this problem was so anoying.  i just wanted to thank you and let you know how appreciative i am.

  • Ivanman43 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 22, 2012 11:54 AM (in response to Mr Me)

    Thanks this worked for me as well!!

  • drcornish Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 2, 2013 2:57 PM (in response to Sean Knudsen)

    If anyone is still experiencing problems try following

     

    iTunes>Prefrences>Playback>Prefered Video Playback> (change to what you downloaded usually Standard definition corrects it as itunes is optimised for HD these days!)

  • maripaz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 13, 2013 12:51 AM (in response to drcornish)

    Drcornish!

     

    Thank goodness. Your post is a blessing to me and my family. No one here knows a thing of what to do.

     

    I cannot tell you how happy I was to see your post. I had not time to even research and I have no money to have it diagnosed! Internet time for me is limited.

     

    Thank goodness for your post. You solved my situation and relieved the stress from my children.

  • amrcom Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 1, 2013 2:48 PM (in response to Sean Knudsen)

    thanks , this solved my problem

  • LeelanTinkerbell Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 13, 2013 3:57 PM (in response to drcornish)

    Thank you so much Dr. Cornish, my video is finally playing after looking for a solution everywhere I found it thanks to you!!!

  • Toffee_Rapper Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 14, 2013 5:58 AM (in response to drcornish)

    Nope.  This is about the forth 'fix' I have tried.  I have 900+ mp4 movies and they ALL lag on iTunes. They play fine on all the other players I have tried. 

     

    Perhaps ALL the other players in the world can play mp4 videos, but not iTunes?

     

    Is it possible to run a stripped down iTunes that does not load my movies, just the music?  Then I can use iTunes to play my music with my iPod, but find another video player, that plays mp4 videos straight out of the box... without any messing about with the default settings.. and then I can forget the nightmare of the last few months.

     

    Regards,

     

    RouX

  • SnakePliskin111 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 24, 2013 6:37 PM (in response to Mr Me)

    This was the fix!

    Thank you  - that was driving me slowly batty

  • My head hurts Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 24, 2013 11:32 AM (in response to Sean Knudsen)

    I just changed the audio preference in itunes to match what my computer was already set to (studio quality 24 bit 44100hz). My sound is the Realtek HD and I am running an i7 with 6gb ddr3 though, and perhaps if your system isn't up to snuff you may need to turn it down to the cd quality. I was experiencing the same problems with out of sync plus an audible clipping that drove me nuts. I believe the problem mainly lies in syncing the audio quality output settings of your pc with that of itunes, your choice of quality should be determined once again by your system's ability.

  • Vibradiant Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 24, 2013 9:39 PM (in response to Sean Knudsen)

    Thanking Mr. Me, and those who contributed information about altering the Realtek settings.  Put everything down to the most basic levels and it seems to finally work without the infuriating disconnect betwen lips and words.

     

    Itunes can eat me for not clarifying this basic fix to begin with when buying tv shows from their store.

  • TonySollazzo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 14, 2013 3:10 AM (in response to Sean Knudsen)

    This was on the right track but specifically for me the trick was to change itunes playback from directsound to windows audio session (and co-incidentally bit depth and sample were already same). p.s. I have sound going out my onboard hdmi connection from win 8 x64 and itunes 11.02.26.

  • TonySollazzo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 14, 2013 3:43 AM (in response to TonySollazzo)

    scratch that previous comment, it woked fine for a sd show but was soon out of sync on 1080p, so now wondering if it is cpu related?

  • kazvye Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 14, 2013 7:19 AM (in response to TonySollazzo)

    Same here.  And none of the other remedies worked for me - or they worked for a few minutes.  Beginning to tear my hair out because Quicktime itself has stopped playing my iTunes TV programmes (which I had resorted to due to the sync issues) without me logging into iTunes (even though I'm already logged in/authorised); all I get is blank screen and no sound but the time is running so the video must be playing. 

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.