7 Replies Latest reply: Mar 25, 2013 7:45 AM by Lawrence Finch
DavidA226 Level 1 Level 1 (0 points)

The problem: I changed computers and moved all my iTunes music to the new computer. All good there. However, my iPhone / iPad are still trying to wirelessly sync to the old computer. I'm pulling out what little hair I have left trying to find out how the heck to change the host it's wirelessly syncing to to the new computer. Not that I've ever found wireless sync that reliable, but now it's completely FUBAR.

 

Also moved PC -> Mac if that makes a difference. All software latest versions.

 

Help!?!


iPhone 4S, iOS 6.1.1
  • 1. Re: How do I change iTunes wireless sync host?
    wjosten Level 10 Level 10 (93,295 points)

    Deselect sync via wifi for your iPhone sync preferences with iTunes on your previous computer. Join the wifi network with your new computer and with your iPhone followed by reselecting sync via wifi.

  • 2. Re: How do I change iTunes wireless sync host?
    DavidA226 Level 1 Level 1 (0 points)

    Ah ... the previous computer died. Is there a way to change it without the old computer?

     

    Thanks.

  • 3. Re: How do I change iTunes wireless sync host?
    wjosten Level 10 Level 10 (93,295 points)

    Settings>General>Reset>Reset All Settings. Connect your phone by USB cable to your Mac & reselect sync by WiFi. This will also reset stuff like WiFi passwords, etc.

  • 4. Re: How do I change iTunes wireless sync host?
    DavidA226 Level 1 Level 1 (0 points)

    OK. Sorry to take so long to reply again, but life intruded and this is a desirable, though unimportant problem to fix.

     

    Thanks for the previous replies, They are greatly appreciated.

     

    I did the reset and now my iPhone has no host that it is Syncing with. Problem is, try though I might, it won't add the new computer as a computer to sync with. There is simply no computer there. I've done:

     

         UnCheck wi-fi sync in iTunes

              sync phone

              power off/on phone

         Check wi-fi sync in iTunes

              sync with phone

              power off/on phone

     

    Nothing. I've tried all the combinations of this I can think of. Obviously something is not right, but I can't figure out what.

     

    Still no host that I can sync with. It just gives the "to enable wi-fi syncing with iTunes" message when I go to

         settings>general>iTunes Wi-Fi Sync

     

    Any other ideas would be appreciated, and thanks.

  • 5. Re: How do I change iTunes wireless sync host?
    Lawrence Finch Level 7 Level 7 (25,980 points)

    This can happen if the Bonjour service on your computer is not working, or is blocked by your firewall or antivirus.

  • 6. Re: How do I change iTunes wireless sync host?
    DavidA226 Level 1 Level 1 (0 points)

    Maybe I'm wrong, but your reply seems directed at Windows. New computer is a Macbook Pro. OSX up to date.

     

    If OSX -- How can I tell if Bonjour is working? ****, I can't even find it! I'm new to Macs so forgive my naivette on the subject. Windows no problem, but I'm still learning OSX.

  • 7. Re: How do I change iTunes wireless sync host?
    Lawrence Finch Level 7 Level 7 (25,980 points)

    I wasn't being OS specific, but I see your point as most users of Macs don't have AV installed. It's unlikely that there is a problem with Bonjour on the computer, but your router may be blocking it. In the router settings make sure that ports 1900, 5350, 5351, 5353 are not blocked.

     

    Your diagnostic steps are sound. If you connect the phone by USB cable to the computer and check Sync with this iPhone over WiFi, then sync via cable it should work. If it is already checked and not working uncheck it, sync, then check it and sync again.

     

    One thing that you didn't mention - restart both the computer and phone and try again. To restart the phone hold HOME and SLEEP until an Apple logo appears (about 10 seconds).

     

    If it still doesn't sync over WiFi take the computer and phone to an Apple store and let them sort it out. Make an appointment first.