Skip navigation

Iphoto not importing photostream

849 Views 5 Replies Latest reply: Feb 11, 2014 9:57 AM by anglofyle RSS
danhenrie Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 14, 2012 9:31 PM

My iphoto is not automatically importing photos from photostream.

I can see photos in the photostream folder, however not in the events or photos folder.

iPhoto preferences are set to automatically import photos from iCloud.

Is anyone else having this issue?

Any solutions?

  • David Albracht Calculating status...
    Currently Being Moderated
    Sep 16, 2012 8:44 PM (in response to danhenrie)

    I am having the exact same issue.

  • Uhyesthatsme Calculating status...
    Currently Being Moderated
    Mar 25, 2013 11:17 PM (in response to danhenrie)

    same problem here.  At first when I right clicked on Photo Stream it had the option to import photos and after I clicked on that absolutely nothing happened and it no longer gives that option. I tried dragging a photo from photo stream to Photos and it asked me if I wanted to save a duplicate because it was already imported even though it is nowhere to be found.

  • LarryHN Level 9 Level 9 (54,870 points)
    Currently Being Moderated
    Mar 26, 2013 6:43 AM (in response to danhenrie)

    Where are you expecting them to be? PS imports are in a single event for each month so the event may be quiet a ways down in the library if you have taken a lot of photos

     

    LN

  • Old Toad Level 10 Level 10 (113,175 points)
    Currently Being Moderated
    Mar 26, 2013 2:38 PM (in response to danhenrie)

    Disable Photo Stream in the System/iCloud preference pane

     

    Preview002.jpg

     

    and in iPhoto's Photo Share preference pane.

     

    Preview001.jpg

     

    Reboot and reenable both respectively. See if that will start the import into the library. 

     

    OT

  • anglofyle Calculating status...
    Currently Being Moderated
    Feb 11, 2014 9:57 AM (in response to danhenrie)

    I don't know if you still need help with this issue, but for anyone else, this is how I fixed it: in photostream, I clicked on one of the photos I couldn't find, and then clicked Info and copied the IMG #. Then I went to  Photos in the left-hand menu bar and searched for the IMG #. I found the photo in an earlier Event, along with the other imports I had been missing. I selected them all and created a new event (Create Event from the Events menu).

     

    The trick seems to be to always create a new event when you import instead of renaming an import.

     

    Also, I keep the events in Photos minimized for easier scrolling, but this prevents the Show in Library feature from working. If you maximize them, you will be able to right click on a photostream image and select Show in Library, and the image will come up.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.