Skip navigation

Double Message Alerts with iPhone 4s.

127000 Views 206 Replies Latest reply: Apr 1, 2014 8:45 PM by Rhode Island greening RSS
  • kikay1030 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 4, 2012 7:53 PM (in response to chgsantos)

    @chgsantos: have you tried the hard restart? Press the power button and home button altogether until your phone restarts. Do not release until the apple image appears (meAning it is restarting). It worked for me.. Been free from the irritating double message tone for almost 6 months now :-)

  • chgsantos Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 4, 2012 8:07 PM (in response to kikay1030)

    @kikay1030, it always comes back!

     

    There's 2 ways to stop it:

    1. turn vibrate off
    2. notifications > messages: select none or alerts (aka disable banners)

     

    I wish it had a more direct way to send feedback to Apple, or a bug tracker.

     

     

    And it does not happen only with messages, but with all notifications, and specifically with banners.

  • chgsantos Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 4, 2012 8:17 PM (in response to chgsantos)

    I sent a feedback at http://www.apple.com/feedback/iphone.html

     

     

    My text:

    There's a bug in iOS that duplicates the sound of banner notifications.

    Happens with all kind of notifications, not iMessages only.

     

    As you can see on Apple Discussions, it's an old bug:

    https://discussions.apple.com/message/19476931#19476931

     

    It's not repeat alert feature, it duplicates the sound, overlaping one to another, like receiving 2 messages notification sound at the same time.

     

    It's known some ways to solve this bug, but it always comes back:

    - Hard reset

    - Reboot

    - Format iPhone and use a fresh install (backup gets bug back)

    - Turning off vibrate

    - Disabling banner (aka choosing none or alert)

     

    I already tested with iOS 5 and 6, and both of them has this issue.

  • gonzabriones Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 11, 2012 9:35 AM (in response to chgsantos)

    I hope Apple can fix the bug in the next iOS update.

    Reboot is working out for now.

  • Jroberts71321 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 5, 2013 3:18 PM (in response to dannyfromconverse)

    You are all so stupid, but i suppose if you get a new phone then thumbs up,

     

    Well for starters i guarantee that the double message tone happens once while the phone is locked, and as soon as u unlock it hey presto! It happens again???

     

    If yes then you silly people need to go to settings, then notifications, then to messages, once there go straight to the bottom and if "view in lock screen" is turned off, turn it on and your problem is solved.

     

    if this doesnt solve your problems then i cannot help you :)

  • b0st0wn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 5, 2013 5:47 PM (in response to Jroberts71321)

    I guess you're the one thats ignorant! We are not talking about getting the tone twice. The problem I get is when a text comes in the tone goes off. Then another tone that interupts the first tone goes off. Making the tone skip at first then complete a second time. So why dont you read all 13 pages before posting your rude comment.

     

    B0st0wn

  • chgsantos Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 5, 2013 7:07 PM (in response to Jroberts71321)

    Hey man, as you can see below on the print screen, it's a known bug and Apple is treating it:

    http://cl.ly/image/2e3J0i363K35

     

    Please do as our friend said and read all the content before posting this kind of response.

  • Jroberts71321 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 5, 2013 7:20 PM (in response to chgsantos)

    Ok so i didnt read 13 pages, shoot me now! Nah jokin sorry about you getting a dodgy phone guys, may the force be with you next time

  • zYxMa Level 1 Level 1 (20 points)
    Currently Being Moderated
    Jan 5, 2013 11:45 PM (in response to Jroberts71321)

    Someone give me a gun ill shoot you because you're talking s*it you moron!

  • n122vu Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 6, 2013 5:32 AM (in response to dannyfromconverse)

    I can confirm this is still an issue on the iPhone 4S.  It wasn't fixed in the latest iOS update, not for me at least.  I've tried all the suggestions in this thread, but nothing has worked.  It's not just iMessage that is doing this for me.  It's everything on the phone.  GMail, Facebook, iMessage/SMS, Exchange email, Voicemail Notifications.  Everything notifies me twice, and not everything has the repeat notification option in Settings>Notifications.  It seems to mostly occur when the phone has gone into the period where it requires a passcode to unlock (required for connection to our Exchange/ActiveSync - I have mine set to 1 hour).  It does occur at other times, but not as frequently it seems. 

     

    More an annoyance than anything, but still hope they are able to resolve this one soon.

  • KiwiCarpenter Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 18, 2013 12:21 AM (in response to dannyfromconverse)

    You turn it off under settings, Notifications, Messages and go down to repeat alert and put it on Never, if that hasn't worked I've found in the past that if you change the sound you have choosen for the alert to another it can fix the glitch, just switch them all around, restart the phone and then you can put it back to the ones you like.

  • chgsantos Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 20, 2013 6:39 PM (in response to KiwiCarpenter)

    This bug does not happen when you disable vibrate.

    I'm still testing, but apparently it disappears when you change message vibration too.

    I changed from Staccato to Pulse and appears to be fine now.

  • Woore Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 26, 2013 2:32 PM (in response to chgsantos)

    I turned vibrate on ring and silent off and on and it seems to have fixed it, still good after 24 hours.

  • gummie01 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 14, 2013 12:58 PM (in response to Woore)

    If I switch off the vibrate on ring or that I can see the notification on lockscreen, the double alert disappears. But after restart etc. and switching it on, it returns. :-(

  • zYxMa Level 1 Level 1 (20 points)
    Currently Being Moderated
    Apr 14, 2013 1:00 PM (in response to dannyfromconverse)

    I'm not sure if anybody encountered this problem on their iPhone 5, but I did....

Actions

More Like This

  • Retrieving data ...

Bookmarked By (7)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.