Skip navigation

Solution for Apple TV 2, Xfinity router, Ethernet connection and Home Sharing

29200 Views 56 Replies Latest reply: Aug 10, 2013 12:44 PM by Legal1 RSS
  • DrewCox Calculating status...

    My issues all went away with the iOS and iTunes updates accompanying iOS 6. I no longer have to restart iTunes constantly.  Good luck.

  • Gordogreatbelly Calculating status...

    H spma3i,

     

    I've been trying to implement the fix as you describe it, and I'm on the verge of giving up - I've followed all the steps you describe (I have the same router) but have had no success.  As soon as I revert both the MacBook I'm using as a server and the Apple TV, to a wifi connection, home sharing works perfectly.  On Ethernet, no joy :-(

     

    I've rechecked all the settings, and from what I can see, I've set up everything just as you describe.  The only difference between your set up and mine is that I'm using a third-gen Apple TV.  Could this be causing an additional problem?

     

    I'm about sick of messing around with what should be such a simple set up process (just like so many others it would seem).  If you or anyone else are able to offer any additional suggestions, I'd be really grateful.

  • Gordogreatbelly Level 1 Level 1 (0 points)

    Hi spma3,

     

    I've been trying to implement the fix as you describe it, and I'm on the verge of giving up - I've followed all the steps you describe (I have the same router) but have had no success.  As soon as I revert both the MacBook I'm using as a server and the Apple TV, to a wifi connection, home sharing works perfectly.  On Ethernet, no joy :-(

     

    I've rechecked all the settings, and from what I can see, I've set up everything just as you describe.  The only difference between your set up and mine is that I'm using a third-gen Apple TV.  Could this be causing an additional problem?

     

    I'm about sick of messing around with what should be such a simple set up process (just like so many others it would seem).  If you or anyone else are able to offer any additional suggestions, I'd be really grateful.

     

    PS sorry if this post appears twice, I replied to the original post at first..........

  • SANDO890 Calculating status...

    On Windows 7 / Windows 8 (I suspect Vista too, but I haven't confirmed this) I have documented the issue I had (symptoms of music & video taking AGES to load from Apple TV when playing from iTunes on my PC - if left it would get there in about 15 mins). I could however play from iTunes on my PC to the Apple TV ok.

     

    The issue I had was that my network card was set to a Public Network location. The Bonjour service runs by default on a Private Network location. To check the location your network card is using go to Control Panel, Network and Sharing Centre. It is explained here

     

    To change your network location then follow the steps in this article http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/662e5a c6-b0c2-48e6-8a86-a00eaa9c4ba1

     

    The relevant post is pasted below.

     

    You could just change the Bonjour service to run on the Public location in your firewall settings, but I would suggest fixing up your network settings.  I don't know if I had a different problem to others that reset and unplugged and replugged in, but I would suspect I did and the unplugging and replugging in just set up a different location on the network card and happened to be Private so all was well.

     

    Anyway, this solved my problem and I hope it stops someone else from going quite as crazy as I was.

     

    ================================================================================ =

    Post from  http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/662e5a c6-b0c2-48e6-8a86-a00eaa9c4ba1

     

    You can't change the unidentified network to private because that is prevented by a default security setting.

     

        You can change the security setting so that the network is not made public in the first place.

     

       Here is what you need to do from a previous discussion on this.

     

    To do this on your local server , follow these steps: 

    1. Start --> run --> MMC --> press enter

    2. In MMC console , from menu file select Add/Remove Snap-in

    3. Select Group Policy Object editor --> Press Add --> select Local computer --> press OK -->press OK

    4. Open Computer configration -->Windows Settings -->Security Settings -->select Network list manager policies
    on the right Side you will see options for :

    double click -->Unidentified networks

      Then you can select the option to consider the Unidentified networks as private and if user can change the
    location.

    I hope that is will help you and is clear .

     

    --------------------------------------------------------------------------------
    Hikmat Kanaan Amman-Jordan MCSE

     


     

      Bill

  • scott.hitchman Calculating status...

    THANK YOU, THANK YOU, THANK YOU!

     

    Well, after countless hours of f***in' about with Windows firewall, Bonjour service, static IP addresses, IPv6 etc. etc. etc. it seems that this port forwarding has resolved the dropouts I was getting.

     

    I have Apple TV 3, latest itunes running on Windows 7 (32bit) connected on my Sky SR101 (Fibre broadband) router.

    After one song play or playing one film I had the Home Sharing disconnect. I then had to restart iTunes on the PC. I had no issues with Airplay or mirroring from my iPad mini/iPhone4S.

     

    In case anyone else with this setup I've added a couple of screenshots from my router admin page to assist.

     

    For the record here's what got my Home Sharing working...

     

    • Disable IPv6
    • Static IP addresses all round
    • remove all instances of Bonjour from Windows Firewall and then re-add only one
    • remove all instance of iTunes from Windows Firewall and then re-add only one
    • Carry out the port forwarding as per spma3 on my Sky router (see below)

     

    Sky Broadband Router  Services - Google Chrome_2013-05-11_11-58-18.png

    Sky Broadband Router  Firewall Rules - Google Chrome_2013-05-11_11-59-00.png

     

    So finally (fingers crossed), this seems to have sorted out the Home Sharing issue - oh yeah 3689 is TCP per a later post from spma3.

    It's still early days only 5 hours in, but the AT3 has been to sleep and working normally after wake up (with the Remote app for iPhone).

     

    So a MASSIVE thank you to spma3 for not only finding this info out but sharing with all of us.

     

     

    Dont get the hump but I'm going to paste links to my reply and this thread wherever I can.

  • Legal1 Calculating status...

    After scouring for hours, the only thing I needed to do was to adjust the incoming rule for all instances of Bonjour in Windows Firewall Settings. Click on the incoming rule for Bonjour  ---click on the advanced tab and check the box for all profiles: Domain, Private and Public. Apply the rule...and at least for me Voila'. I believe Scott already mentioned this simple fix his prior post, but with so much other information in it, I think for us simpletons, that gets overlooked.

     

    I am not tech savy and couldnt go through all of the router settings mentioned above or setup static ip's or anythign else. In fact, my Arris router has different wording for everything it seems and I couldnt figure anything out with port forwarding either. So that part is too complicated for me.

     

    My home share would drop out after 1 or 2 songs and I would have to reboot itunes...now its running and accessing fine for days. I am using Win 7 64 bit and my computer is etherneted to the router...but what ever the solution is for everyone, after seeing these problems for 2 years on these boards, I cant beleive there is neither an Apple update to address this, nor at  a quick fix article  saving everyone countless frustrating hours.

     

    legal1

  • StuartG48 Calculating status...

    Hello, I've been having similar problems to those described above.

     

    I have a fast PC running Windows 7 (64 bit) containing my iTunes library which is fully updated, a MacBook Pro running Mountain Lion which also has a copy of my iTunes library,  ATV3 also fully up to date and a BT Home Hub 3.

     

    I have NEVER been able to successfully watch anything on my ATV 3 without it losing the connection to my PC either by Airplay or by accessing the library directly.  after a while it stops working and my ATV says there are no computers connected and wants me to turn on home sharing (even though it is already turned on).  The ATV still picks up iTunes Store and iCloud perfectly along with Netflix, YouTube etc., but just won't stay connected to my PC. I seem to be able to watch the movie directly from the iTunes Store through iCloud (though to be fair I've never watched a movie all the way through this way so I'm not sure if I would get the same problem) but this eats into my bandwidth usage so I don't do it.

     

    I tried switching off the PC. And using the MacBook as my home sharing computer but same result - both Airplay and direct access to the library drops out after a bit.

     

    Most of the previous posts refer to an Xfinity router. My son (who works in the industry) says he thinks the BT router doesn't play nicely with Apple products.  He had problems with all his Apple kit until he switched to Netgear and urges me to do the same but it appears that from what you all say it doesn't matter what router you use although he may be right as my iPhone 5 and iPad 2 also drop the WiFi connection fairly frequently whereas my BlackBerry and an ancient Dell laptop are rock solid!

     

    I'm going to try the port forwarding solution proposed by spma3 and will post again to let you know what happens.  In the meantime I wonder if anyone else with the same setup (BT router, etc.) all bang up to date- has the same problem.

     

    I'm also pretty ****** that (having switched to Apple after years of PCdom on the basis that "it just works") the first posts about this topic appears over a year ago and they're still going on without a single input from anybody official at Apple!!!

     

    Many thanks.

  • Legal1 Level 1 Level 1 (0 points)

    Try my previous post relating the Bonjour setting on ur Win 7 home network setting.

  • StuartG48 Level 1 Level 1 (0 points)

    Many thanks Legal1, I'll try this first, see what happens.

  • Neurotech Calculating status...

    Thanks spma3. I got half way there. My Iphone can connect after using your settings but my IPad is still a no go...which makes absolutely no sense. Seriously had enough of Apple. I'm this close || to selling all my Apple stuff and going back to just PC. I mean, should we all really have to waste hours of our time searching forums just to use our gear ???.

  • PeterJRM Calculating status...

    Legal1, THANK YOU for your post. I did exactly what you recommended--changed the incoming rule for all instances of Bonjour to domain, public, and private. After restarting my PC, home sharing worked perfectly, and now both my Apple TVs have been working flawlessly for over twelve hours.

     

    I'm using Windows 8 with a Linksys router, so I recommend that anyone who's having problems with home sharing try this simple but incredibly effective solution. Thanks again, Legal1--you put an end to hours of frustration for me.

  • Legal1 Level 1 Level 1 (0 points)

    Your welcome and I am glad it helped. This has worked going on over 2 months since I posted on it.

     

    It is frustrating as **** that their isnt a clear and concise post from Apple helping to resolve this or that we all need to scour through thousands of posts to tweak settings that should already be properly set up. Or, at the least, that should otherwise be explained from the beginning of setup.

     

    Best, Legal1

1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.