Skip navigation

How do I recover photos lost by iPhoto. I tried using Time Machine but I get an error message saying that I don't have permission.

297 Views 3 Replies Latest reply: Mar 27, 2013 3:35 PM by Eric Ross RSS
the red flash Calculating status...
Currently Being Moderated
Mar 27, 2013 10:43 AM

IPhoto quit in the midst of importing some photos to the library.  When I reopened it, it had some events, that were imported a few days earlier, which had no photos.  They were missing.  I tried Time Machine to restore the iPhoto Library to a version made a couple of hours earlier.  But I got an error message saying that I did not have permission.  I tried restarting iPhoto while holding down the Option key and tried to access the Time Machine iPhoto Library, but that only got me a portion of the library and not the portion that was missing earlier.  When I restarted iPhoto this time, even more of my photos were missing.

iMac Intel Core 2 Duo, 2.16 GHz and 2.66 GHz

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.