1 Reply Latest reply: Mar 27, 2013 9:11 PM by Niel
skibuns1 Level 1 Level 1 (0 points)

I want to update my mac, I have snow leapord mac os x version 10.5.8

I just got the I phone 5, and now I cannot download my music from Itunes as I need the new Itunes but my older version Mac will not let me download the new Itunes. What do I do to resolve this.


iPhone 5, Mac OS X (10.5.8)