8 Replies Latest reply: Apr 3, 2013 11:02 PM by Terencio
Jesus3476 Level 1 Level 1 (0 points)

Hi All.

I couldn´t believe at the beginning but it's real. Keynote hyperlinks have a bug. Went to an Apple Store in Spain and confirmed it with their technical support.

 

If you try to hyperlink a Keynote presentation from another one you may discover that Keynote exits from play mode and returns to design mode. ***!!

Try this:

     Create a Keynote file, 1 slide (or more if you wanna loose time). (Lets call it P1)

     Create a second Keynote file, 1 slide. (idem) (Lets call it P2)

     Create a hyperlink on whichever slide of P1 to open P2.

     Close P2.

     Launch P1 - enter play mode.

     Click on the hyperlink (it should launch P2)

     It shows first slide of P2 for half a second and..... ¡ ¡ Keynote exists from play mode and gets back to design mode ! !

 

Is this really what Apple wanted the hyperlink to another keynote file work? Don´t think so.

 

You may find that if you relaunch P1 and reclic on the hyperlink..... it works! ! ! ! That´s because P2 is already opened. Close P2 and try again..... E R R O R !

 

Please, take notice of this bug and give it a solution. It`s not a good business to set things on the applications that don´t work. What would Steve (R.I.P) think about this?

 

Hope for a soon update of the application for solving this.

Thanks

  • 1. Re: Hyperlink BUG. Confirmed at Apple Store in Spain
    Gary Scotland Level 6 Level 6 (8,225 points)

    The readers of this forum are Keynote users and not  Apple employees, we have no influence at all in  Apple  decisions.

     

    Hyperlinks work as they should on my systems and most other users, I have never heard of this issue but I know how such things are very annoying. There are  a few teething issues with the latest version of Keynote running on Mountain Lion, as you may have read from the other posts.

     

    The following routine maintenance procedure sorts out many of these problems so it is well worth spending 10 minutes going through the following:

     

    1

    Uninstall all of iWork if you have this, otherwise uninstall Keynote if other iWork applications are not installed.

    Use the free application Appcleaner to do this as it will remove the applications properly. It can be downloaded here:   Appcleaner Download

     

    2

    empty the trash

     

    3

    Reinstall Keynote or iWork  using the original method on purchase using the installer file or installed from the App Store

     

    4

    shutdown the Mac and restart holding down the shift key until the apple logo appears

    let the Mac complete the start up procedure completely, it will take longer to start as it is repairing  software on the hard drive

     

    5

    go to Applications >  Utilities > Disc Utility > First Aid > Repair Disc Permissions

    when this is completed restart the Mac normally

     

    Report back  on how you got on.

  • 2. Re: Hyperlink BUG. Confirmed at Apple Store in Spain
    Jesus3476 Level 1 Level 1 (0 points)

    Thanks in advance for your soon answer.

    I tried the solution you described, step by step, but unfortunately it didn´t solve the problem.

    The problem I describe, doesn´t happens to you?

     

    Thanks again for your help.

  • 3. Re: Hyperlink BUG. Confirmed at Apple Store in Spain
    Gary Scotland Level 6 Level 6 (8,225 points)

    Keynote hyperlinks have always worked exactly as intended for me and all of my clients. Most issues in the past have been due to users inexperience.

     

    I prefer not to use links to other presentations, I can design most of what I need in a single file. It is not a perfect procedure, there can be delays when opening subsequent files but never had problems dropping out of play mode.

     

    A refinment to try is to set the following

     

    Inspector > Document:

     

    Automatically play on open

    Presentation set to Hyperlinks only

     

     

    In preferences:   deselect the option;   Exit presentation after last slide

  • 4. Re: Hyperlink BUG. Confirmed at Apple Store in Spain
    Jesus3476 Level 1 Level 1 (0 points)

    No way Gary. Tried you solution but no result, it exits play mode.

     

    I really encourage you to create 2 presentations of 1 slide with an hyperlink on the first one to the second (take care of closing the second keynote file) an see what happens. It will only take you 2 minutes.

     

    I've been using hyperlinks for so long, so inexperience is not the problem. Hyperlinking to another keynote file is a matter of needs only. If it's needed and keynote supports it, why shouldn`t it be used?

     

    I really began thinking as a bug when Apple iWork's expert in the Apple Store wasn´t able to solve it neither on my computer nor in any of the Apple Store. By now, I haven´t found no one that simulates the problem and has made it work.

     

    Thanks for your help.

  • 5. Re: Hyperlink BUG. Confirmed at Apple Store in Spain
    Gary Scotland Level 6 Level 6 (8,225 points)

    I managed to track down a 2 week old 21"  new iMac last night with Mountain Lion and Keynote preinstalled.

     

    I created 5 Keynote files with a link from presentation 1 to each of the other 4 keynotes and a link back to presentation 1. It worked properly.

     

    I cant think why your having this issue,  other than a clean install of the OS and redownloading iWork from Apple App Store, I am out of suggestions.

  • 6. Re: Hyperlink BUG. Confirmed at Apple Store in Spain
    Jesus3476 Level 1 Level 1 (0 points)

    Hi Gary,

    Did you close the 4 keynotes referenced?

    As I told you, If I leave the keynotes referenced open everything works fine. The problem appears when the keynote referenced is closed.

     

    Thanks

  • 7. Re: Hyperlink BUG. Confirmed at Apple Store in Spain
    Gary Scotland Level 6 Level 6 (8,225 points)

    Makes no difference if the Keynote files are closed, open in edit mode, or open in play mode, they play and link correctly.

  • 8. Re: Hyperlink BUG. Confirmed at Apple Store in Spain
    Terencio Level 1 Level 1 (0 points)

    I've had this same problem too, and I'm a fairly experienced Keynote user. The only thing that seems to work is to have the files already open. It's infuriating.