Skip navigation

Error: mdworker lsboxd deny mach-lookup

16909 Views 19 Replies Latest reply: Apr 22, 2013 8:37 AM by cypressdrive RSS
  • d_adama Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 27, 2012 10:18 AM (in response to jacooper11)

    Try this:

     

    1. Restart your computer in safe mode (read that link for more info about what it will do.) This is done by restarting as normal from the Apple menu, then holding down shift after you hear the Apple noise on startup. Note, you must wait to hold down shift until after the Apple noise has started. As proof that you're loading into safe mode, you'll see a little progress bar beneath the Apple and you'll have to wait a while.
    2. Once the wait is over, you can log into OSX, but since you're still in safe mode you'll want to restart again, this time without holding shift.
    3. Log in again, check your Console -- if this worked, the error should be gone.

    See: http://www.princeton.edu/~jcjb/docs/osx_error_fix/

     

    A simple solution that worked for me.

     

    Cheers

  • Colm Calculating status...
    Currently Being Moderated
    Jan 24, 2013 4:44 PM (in response to jacooper11)

    I also had these issues with my 10.8.2 iMac

    However, safe boot would not work for me, when i rebooted to go into safe mode it would start the progress bar, but stubbornly stop at about 20-25% of the way through.

    I left it like this for 2 days, but still it would not progress.

     

    So, to resolve this, i downloaded mountain lion onto a fresh USB stick ( instructions elsewhere ) and then did a full clean install.

    I reformatted the primary hard drive.

    Did a clean install of mountain lion.

    and then did a full time machine restore ( as part of the mountain lion install )

     

    After all that, i was able to safe boot cleanly in normal time, which i did once or twice.

     

    At this point the system is fully recovered, no lsboxd errors, and overall it seems snappier, as it looks like spotlight in particular is working in a cleaner environment.

     

    Prior to this i had done the upgrade ( i.e. not a clean install ) for both lion and subsequently mountain lion.

     

    Hope this helps.

     

    Colm

  • joekljk Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 14, 2013 10:18 AM (in response to Colm)

    You can modify the /System/Library/Sandbox/Profiles/system.sb file to allow lsboxd and coresymbolicationd to get rid of errors. Make a backup of system.sb first, then add this to end of system.sb file and reboot your system:

     

    ;;; MDWorker Fix

      (allow mach-lookup

             (global-name "com.apple.ls.boxd")

             (local-name "com.apple.ls.boxd")

             (global-name "com.apple.coresymbolicationd")

             (local-name "com.apple.coresymbolicationd"))

  • Peter Rosen Calculating status...
    Currently Being Moderated
    Mar 29, 2013 1:54 PM (in response to jacooper11)

    Yup, SAFE START AND THEN REBOOT Worked for me too! Thanks!!! Safari is snappy now!@!

  • cypressdrive Level 1 Level 1 (5 points)
    Currently Being Moderated
    Apr 22, 2013 8:37 AM (in response to joekljk)

    I'm going to try this and report back.  The safe boot doesn't work for me.  Can someone explain what the safe mode trick does to fix this problem?

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.