Skip navigation

Error while partitioning in boot camp

24265 Views 13 Replies Latest reply: Jan 13, 2014 11:59 AM by JediMasterCooper RSS Branched to a new discussion.
Hernicane Level 1 Level 1 (0 points)
Currently Being Moderated
Mar 28, 2013 8:40 AM

So I am trying to install windows to my MacBook Pro. I have a windows 7 disk and I go through the steps in boot camp, but once I get to choosing the partition and to actually installing, it goes a quarter way through and days it couldn't partition because an error occurred. Nothing else. Just that. Some assistance would be greatly appreciated gents.

MacBook Pro, OS X Mountain Lion (10.8.3)
  • Allan Eckert Level 8 Level 8 (39,385 points)
    Currently Being Moderated
    Mar 28, 2013 8:41 AM (in response to Hernicane)

    Please provide the error.

     

    Allan

  • livbem Level 1 Level 1 (15 points)
    Currently Being Moderated
    Mar 28, 2013 1:37 PM (in response to Hernicane)

    I'm getting the same error. Mid 2010 MBP running 10.8.3 trying to install Windows 7:

    "Your disk could not be partitioned", "An error occurred while partitioning the disk".

     

    I'm installing on the internal HDD that came with my computer. My Windows install disk is one that I burned on this computer using an image I purchased from my University.

     

    I also see this (possibly unrelated) error in system log in Console.app: "Boot Camp Assistant[418]: NSAlert is being used from a background thread, which is not safe.  This is probably going to crash sometimes. Break on void _NSAlertWarnUnsafeBackgroundThreadUsage() to debug.  This will be logged only once.  This may break in the future."

     

    I'm assuming that's only related to showing me the alert, not the partitioning itsself.

  • publicusername24 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 29, 2013 10:59 AM (in response to Hernicane)

    Same problem here.  No error message given. 

    There is no discernable error, even in the console output, other than "sandbox" and "mdworker" messages,

    e.g.

     

    mdworker: Unable to talk to lsboxd

    and

    sandboxd: ([64299]) mdworker(64299) deny mach-lookup com.apple.ls.boxd

     

     

     

    My disk is fully repaired, it's journaled.   Still I get this worthless "An error occurred...."      Not even an error number, really?

  • livbem Level 1 Level 1 (15 points)
    Currently Being Moderated
    Mar 29, 2013 11:33 AM (in response to Hernicane)

    I finally got Windows 7 installed (I had to do it twice actually, but that's unrelated to this issue).

     

    The problem for me was corruption on my disk. I had orphaned inodes, extra file pointers (hard links), incorrectly reported free space, and one or two other things.

     

    How I fixed it: Restart your computer, and hold down Command-R as it boots to boot into the recovery disk (I'm using Mointain Lion. I think Lion is the same, but on earlier OSes, you'd need to boot from the disk that came with your computer).

     

    When prompted, open Disk Utility. Select your HDD and run "Repair Disk" which can take a while. Mine fixed the issues above. When it's done, reboot normally and try using Boot Camp Assistant again. Note that while it hopefully won't error anymore, the partitioning can take a long time. Mine took 1.5 hours to make a 40GB partition for Windows.

     

    If you Repair Disk from Disk Utility running in OS X, it might work, but I'd recommend running it from the recovery partition, as Repair Disk is limited when running on the boot drive.

  • Calleh Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 29, 2013 2:20 PM (in response to livbem)

    HI. I have problem to partion my hdd to one partion, can some one help me to proceed?

  • livbem Level 1 Level 1 (15 points)
    Currently Being Moderated
    Mar 31, 2013 1:19 PM (in response to Calleh)

    Can you give us more details about what you're trying to do?

     

    If you currently have a Boot Camp Partition and want to get rid of it (making only 1 partition with OS X on it), you can use Boot Camp Assistant to get rid of the Windows part (keep in mind all data on it will be gone forever).

     

    If you're trying to reformat the HDD to a new scheme, for instance HSF+, you likely can't do so without deleting the current partition and adding a new one. This will delete all data.

  • livbem Level 1 Level 1 (15 points)
    Currently Being Moderated
    Mar 31, 2013 1:20 PM (in response to Hernicane)

    You're very welcome! If you change the status of my above post to "This Solved My Question" it will be easier for others to find this and fix it, too.

  • naran123 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 14, 2013 4:01 PM (in response to Hernicane)

    How exactly u solved this issue, I am having the exact problem and I tried 'livbeam' suggestion of repairing the disk and tried again. No luck, the exact same problem. I have mountain lion. Any suggestions will be helpful

  • Turkey_Machine Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 12, 2013 1:19 AM (in response to livbem)

    Thanks! This was really frustrating me. This solution fixed my problem on a MacBook Air! Cheers

  • JediMasterCooper Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 13, 2014 11:59 AM (in response to Hernicane)

    I have this same problem and then tried the recovery repair disk thing and then this popped up.

    PLZ Help

    photo (1).JPG

    Sorry it is sideways i dont know how to fix it

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.