1 2 3 4 Previous Next 46 Replies Latest reply: Jun 17, 2014 2:18 PM by MattW214 Go to original post
  • 30. Re: "Reply All" re-sends to me! So annoying!
    polky78 Level 1 Level 1 (0 points)

    I had a completely different solution to the problem of "reply to all" including me.  After months of perturbance, trying all the things I could find on message boards, it turned out to be quite simple.  All I had to do was:

     

    1. Open the Contacts Application.

    2. Find the card that represented myself and confirm that my email was correct.

    3. With my card selected, go to the drop down menu and choose "Card" --> "Make this My Card".

     

    That's it.  It solved the annoying "reply to all" problem as well as other issues, including the fact that no one ever received my responses to calendar events.  For me, I think this was rooted in a complicated migration from my old Mac.

  • 31. Re: "Reply All" re-sends to me! So annoying!
    Andy Guss Level 1 Level 1 (0 points)

    Nope. "My Card" has been set since day one (with the affected email address). Still experiencing the problem.

  • 32. Re: "Reply All" re-sends to me! So annoying!
    CyclingMac Level 1 Level 1 (0 points)

    I have been experiencing the same issue. It is absolutely repeatable and I have been unable to cure it with any of the suggestions I've found in this or any other thread/discussion. Here is what I've found thus far:

     

    1. My bug is not Exchange related. I do not use Outlook, interface with an Exchange server, or work in a corporate environment. This is just me, my MacBook Retina, Apple Mail and OS 10.8.3 in a home environment.

     

    2. The problem does NOT occur when I Reply All to an email that is in an IMAP hosted mailbox, be it my inbox, the Trash hosted on the server, or any folder stored in "the cloud" (iCloud or a different IMAP account I have at a different hosting site).

     

    3. The problem DOES occur (and only seems to occur) when I Reply All to an email that has been moved (manually or by a rule) to an On My Mac local mailbox ( and thus has been removed from the IMAP servers).

     

    I can replicate this reliably with an individual email. Place the email in an iCloud folder and Reply All works as expected. Place the same email in an On My Mac folder and Reply All includes me in the reply. Move the email back to an iCloud folder and all is well again with Reply All - no copy to me.

     

    I've also replicated this behavior using my iCloud email account on a separate Mac Mini I use as a home server. It has minimal additional login or launch daemon items and uses no mail plug-ins or bundles. Lastly, I've replicated this behavior on my wife's Macbook Retina running 10.8.3 using her iCloud email account. As I mentioned, I've also replicated it using Apple Mail on my laptop to access a 3rd party non iCloud IMAP account.

     

    Rick

  • 33. Re: "Reply All" re-sends to me! So annoying!
    Mike Jasinski Level 1 Level 1 (5 points)

    I have the same issue as "CyclingMac". While it is on the server (imap inbox) it replys correctly - without my name in the CC. Once i move it to one of the "ON MY MAC" folders, it CC's me. very bad. nothing extra is installed. 10.8.3

  • 34. Re: "Reply All" re-sends to me! So annoying!
    crowfeather Level 1 Level 1 (0 points)

    I have my username exactly the same as my email address, on Mountain Lion Mail.app and it's still including me in the reply to all. Very frustrating.

  • 35. Re: "Reply All" re-sends to me! So annoying!
    Dukat Level 1 Level 1 (0 points)

    Thanks CyclingMac; this is the only part of this discussion that seems to apply to me.  If I reply to an email that is still on an IMAP server everything works.  If it's been moved to somewhere "On My Mac" I get included in the reply.  I used to use Outlook 2011 at a previous job and never had the issue.  My email addresses all match in my Mail Accounts settings, and my card is set to "me" in Contacts.

  • 36. Re: "Reply All" re-sends to me! So annoying!
    CyclingMac Level 1 Level 1 (0 points)

    I sent my observations to Apple via their feedback website, but it's anyone's guess whether that will make any difference or not.

  • 37. Re: "Reply All" re-sends to me! So annoying!
    fronesis Level 1 Level 1 (10 points)

    Dukat wrote:

     

    Thanks CyclingMac; this is the only part of this discussion that seems to apply to me.  If I reply to an email that is still on an IMAP server everything works.  If it's been moved to somewhere "On My Mac" I get included in the reply.  I used to use Outlook 2011 at a previous job and never had the issue.  My email addresses all match in my Mail Accounts settings, and my card is set to "me" in Contacts.

     

    I can confirm exactly the same as Dukat writes above. I'm using Mail on ML, all address match, and my contact card is correct; the problem occurs when I reply to a message that is not on the original account's IMAP server.

     

    In my case it's a big problem because I have all my mail forwarded to icloud (for push), but I want to reply to messages sent to my non-icloud account using that same (non-icloud) account. Every time I do it replies to me.

  • 38. Re: "Reply All" re-sends to me! So annoying!
    honeybadger99 Level 1 Level 1 (0 points)

    I had the cc to myself even though I had the cc myself button turned off on my iPhone 5.  I have a gmail, yahoo and exchange account.  It only did it on the exchange account.  I have an iPad also, but it only occured on my iPhone.  I deleted my exchange account on my iPhone and re-entered it and the problem went away.  Not sure if it work for you on your device but it is a pretty easy fix.

  • 39. Re: "Reply All" re-sends to me! So annoying!
    robertfromadelphi Level 1 Level 1 (0 points)

    This was also exactly my problem and your suggestion fixed it. Thank you!

  • 40. Re: "Reply All" re-sends to me! So annoying!
    Holmbaeck Level 1 Level 1 (0 points)

    I had this problem beacuse my company have two domains (two companies merged into one), and they switched the exchange server to use the new one, and since mail was configured with the old, it could not recognize is as my email and added it in the reply-all.

     

    So if anyone have email forwarding (or otherreasons the account email does not match the 'your email' in recipients), that might be why.

     

    Swicting to the new email address in accounts fixed it.

  • 41. Re: "Reply All" re-sends to me! So annoying!
    KailasR Level 1 Level 1 (0 points)

    Thanks. It worked for me.

  • 42. Re: "Reply All" re-sends to me! So annoying!
    Nick Johnson7 Level 1 Level 1 (5 points)

    This worked for me

  • 43. Re: "Reply All" re-sends to me! So annoying!
    jfsadder Level 1 Level 1 (0 points)

    relativitydrive,

     

    Thank you for solving the question posted by pieceolease.

     

    My problem was that I droped the ".com" out of the email address field in: Mail/Preferences/Accounts/AccountType.

     

    Funny how such a small thing can drive me up a wall.

  • 44. Re: "Reply All" re-sends to me! So annoying!
    Dam0 Level 1 Level 1 (0 points)

    I had the same issue on Outlook 2011 and I resolved it by updating to the email address field in the account prefrences.

     

    People were sending to my@email1.com address and outlook was configured with my@email2.com aliis address. If these do not match the "reply to all" will include you as there is no match.

     

    Ensure that the email address configured in this prefrence field is the same as what people are you emailing you with. Might seem obvious but if you have one account with mutiple aliases this is likely to happen