Skip navigation

Can't access my own web site from only my laptop

281 Views 3 Replies Latest reply: Mar 29, 2013 6:31 PM by Linc Davis RSS
mastersuntzuca Level 1 Level 1 (0 points)
Currently Being Moderated
Mar 29, 2013 8:22 AM

Inmotion hosting (my site's host) switched me to a "new and improved" shared server. I have several website hosted there. One (www.askthedogguy.com), I cannot access, front end or wordpress back end. When I type either url I am forwarded to http://ecbiz111.inmotionhosting.com/unavailable.html which contains a website unavailable message. My site was hosted on server was secure111.inmotionhosting.com. I have tried on several browsers (Safarie, Firefox and Chrome), cleared caches and cleared the dns cache using terminal all under the tutelage of Inmotion tech support's help.  I can access my site on my ipad and iphone and on my sons' PC.

 

Inmotion says they've exhausted their fix ideas and suggested I contact Apple as the problem is isolated to my laptop only.

 

Any ideas?

 

-John

MacBook Pro, Mac OS X (10.7.2)
  • SwankPeRFection Level 4 Level 4 (1,435 points)

    Maybe try changing your DNSs to 4.2.2.1 and 4.2.2.2 and try again.  Make sure you don't have any Proxies enabled.

  • pennbank Level 4 Level 4 (1,515 points)

    Reset your router

    delete your router setting on your mac and reset them

  • Linc Davis Level 10 Level 10 (107,530 points)

    You probably hacked the system during the development of the website. The file modified is /etc/hosts.
          
    The easiest way to fix the hosts file is to restore it from a backup that predates the modification, or to copy the unmodified file from another Mac. If you can't do that, then do as below. Please read this whole message before doing anything.

     

    Back up all data. This is a simple procedure, but if you don't follow the instructions exactly, you could be left with an unbootable system. In that case, you'll have to restore from a backup or reinstall OS X.

     

     

    If you have more than one user account, you must be logged in as an administrator.

         

     

    Triple-click anywhere in the line below to select it:

      

    open -a TextEdit /etc/hosts

      

    Copy the selected text to the Clipboard (command-C).

      

    Launch the Terminal application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

     

     

    Paste into the Terminal window (command-V). A TextEdit window should open. At the top of the window, you should see this:

     

    ##

    # Host Database

    #

    # localhost is used to configure the loopback interface

    # when the system is booting.  Do not change this entry.

    ##

    127.0.0.1                              localhost

    255.255.255.255          broadcasthost

    ::1                                        localhost

    fe80::1%lo0                    localhost

     

    Below that, you'll see some other lines. There should be nothing above the first line "##". If you have any doubt about that, STOP and ask for guidance. Make sure you scroll all the way to the bottom of the document. Scroll bars are hidden by default until you actually start scrolling, so you may not realize that you’re not seeing the whole document.

     

    If the contents of the TextEdit window are as described, close it, then enter the following command in the Terminal window in the same way as before (by copy and paste):

     

    sudo sed -i~ '11,$d' /etc/hosts

      

    This time, you'll be prompted for your login password, which won't be displayed when you type it. If you don’t have a login password, you’ll need to set one before you can run the command. You may get a one-time warning to be careful. Confirm. If you see a message that your username "is not in the sudoers file," then you're not logged in as an administrator. Quit Terminal.

     

    That will fix the hosts file. There is now a copy of the old hosts file with the name "hosts~" in the same folder as "hosts". You can delete the copy if you wish. Don't delete the file named "hosts".

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.