Skip navigation

nik collection plug-ins are causing aperture to crash. Please help!

2068 Views 37 Replies Latest reply: Apr 3, 2013 5:40 AM by léonie RSS
1 2 3 Previous Next
subseasniper Calculating status...
Currently Being Moderated
Mar 29, 2013 10:28 AM

Hi everyone, I am running Aperture 3.4.3 and a while back bought Nik Silver Effex 2.0.


A couple of days ago Google emailed me offering the complete Nik Collection for free.


I upgraded but since then everything has been messed up. The plug-ins all appear in aperture but when I try to load them they either fail to load or cause aperture to crash.


I have contacted Nik/Google but all of their suggestions so far have been to no avail.


Please help as I use silver effex professionally and have a job coming up soon that needs black and white edits!


I am desperate here so any help is appreciated.

  • léonie Level 8 Level 8 (46,465 points)

    I upgraded but since then everything has been messed up. The plug-ins all appear in aperture but when I try to load them they either fail to load or cause aperture to crash.

    What is your MacOS X version?


    I have contacted Nik/Google but all of their suggestions so far have been to no avail.

    You need to check the compatibility of the plug-ins you installed. Are they the most recent releases? What did Nik say?

    Aperture 3.4 and later: Some third-party plug-ins are no longer compatible


    Do you have any other Non-Apple software installed besides the Nik-plug-ins? Maybe drivers for external drives you are using or something?




  • léonie Level 8 Level 8 (46,465 points)

    With 10.7.5 and Aperture 3.4 you may have the sandboxing problem (Aperture 3.4 and later: Some third-party plug-ins are no longer compatible), if your plugins are not the latest version. What did Nik say, when you contacted them? Are your versions supposed to be compatible?


    If Nik says, the versions are o.k. with 10.7.5, then post the latest crash report for your Viveza 2.0 crash, so we can check, what frameworks are called by the plug-in.

  • léonie Level 8 Level 8 (46,465 points)

    Your crashlog shows, that Aperture is indeed crashing, when using Viveza2, directly when the plug-in is activated from the menu, before any editing is started. It is crashing in a library called "nikHostInterface::getWorkingProfile() " - perhaps this code has been changed by your recent "Google" install. I do not see any other third-party software that is called.


    I'd suggest to check if the problem is system wide or only occurs for your user account and is caused by settings in your account. Other posters here are reporting that Viveza is working well for them.

    • First check, if your Aperture library may be causing that: Launch Aperture on a new, empty Aperture library (File > Switch to Library > Other/new) and try to use Viveza. Does it work?
    • If not, check, if Aperture and Viveza are working from adifferent user account. You may create a new account for testing using the "Users&Groups" Sysstem Preferences pane.



  • léonie Level 8 Level 8 (46,465 points)

    I tried creating a new library but viveza still causes aperture to crash.

    O.K. now we know it is not a corruption of your Aperture Library.


    Could you explain how i create another account but still have the ability to access all of the files and applications in my current user account?

    I'd enable the new user account as an administrator account - set the flag "Allow user to administer this computer". This way you can access all files by authentificating as admin, if prompted.

    But to check, if Aperture can use the plug-in you do not need to access files in your regular user account. Just make a note of Aperture's licence number - you can see it in the About-panel (Aperture > About Aperture). Have you installed the plug-in only for your regular account? If it is installed in the System Library and not your User Library you should be able to use it.

    Then test on a new, empty Aperture Library in the new account.

  • léonie Level 8 Level 8 (46,465 points)

    I am getting lost now, is there a way to check if the plug-in is installed in the system library?

    Open your Macintosh HD (your System Drive) in a Finder window:

    Screen Shot 2013-03-30 at 16.52.12.PNG

    Then open the folder "Library", then "Application Support" > "Aperture" > "Plug-Ins" > "Edit"


    If Viveza is installed for all users, it should be to be found in this Plug-Ins folder, probably as "Edit" plug-in, maybe also as "Export" Plug-in.


    I set up a new administrator account and found that the plug-ins do indeed work on that account.

    That is an interesting result. There must be something installed, that is only used from your account.


    From your regular user account launch the System Preferences, "Users&Groups" panel and select your current account in the left panel. Then have a look at the "Login items" - these helpers will be launched, when you log in. Are there any applications listed, that are not present in your new account?


    However, I can't seem to find all my files on the newly created account.

    That is as it is supposed to be on a unix based system like MacOS X. Each user has an own "Home" folder, and you need to have special priveleges to be able to see the files.


    To access the files in another account, open again your MacintoshHD in the Finder and open the folder "Users". You will see a folder with the "House" icon - the home folder for the account you are currently using, and other folders for the other accounts. Some of the subfolders will be locked and you will only be able to view them, if you enter your password.

    To share files between accounts, it it useful to move them to the "Shared" folder. This way all can access the files.

    Screen Shot 2013-03-30 at 17.04.20.PNG

  • léonie Level 8 Level 8 (46,465 points)

    I'd try next to remove your Aperture User Preferences from your User Library:


    Quit Aperture, if it is running and log off and on again.


    The user library is hidden.  To reveal it, use the Finder's "Go" menu.


    • Click somewhere on your empty Desktop to bring the Finder forward, then you'll see "Go" in the Finder's main menu bar.
    • Then hold down the options key ⌥ until "library" appears in the drop down menu. Click Library to open.  Remove the file

    your Home Folder/Library/Preferences/


    drag it to the Desktop. 


    Try again.


    If this should not suffice, remove your presets to the Desktop:


    Move the user created presets, keyword lists, and so on...

    1. Quit Aperture.
    2. In the Finder choose Go to folder from the Go menu.
    3. Type ~/Library/Application Support/Aperture in the "Go to the folder" field. Press the Go button.
    4. Move the contents of this folder to your Desktop
    5. Start Aperture and see if the issue is resolved. Note: Permanently removing these files will delete presets, metadata sets, keyword sets, and so on. If moving these files to the Desktop does not resolve the issue, move them back to their original location to restore the presets, adjustment chain presets, and metadata sets. In no case will removing these files affect metadata, keywords, or adjustments already applied to images.
  • léonie Level 8 Level 8 (46,465 points)

    any other ideas?

    That difficult for me to guess; I have no idea which tools and helpers you have used in your regular user account, that have not been active in the other account.


    But you could check, if Aperture has created duplicates of the Preferences in the sandbox:


    Quit Aperture and open again your User Library as described above.

    • Remove again the file

    your Home Folder/Library/Preferences/

    • and in addition everything in

    your Home Folder/Library/Containers/


    The "Containers" folder is used as a sandbox to communicate with other applications - if it exists, it may contain broken files that are passed to Viveza.

1 2 3 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.