Skip navigation

Safari slow and freezes when loading pages

86636 Views 88 Replies Latest reply: Nov 22, 2013 9:40 AM by G.Madigan RSS
  • Gontran Bolduc Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 10, 2013 8:43 PM (in response to Saxman)

    You should have this screen. On the right, next to proxys there is "Materiel" on your screen that may be materials or hardware. I hope that helps.

     

    I do not recall writing about DNS. 

     

     

     

    mtu.jpg

  • Saxman Level 2 Level 2 (175 points)
    Currently Being Moderated
    Mar 10, 2013 10:27 PM (in response to Gontran Bolduc)

    Gontran, sorry, it doesn't, after Proxies it says "Ethernet". And the DNS response was to someone else's post, which the message header noted. You must have a different OS than mine and the other person who also had no such heading as Hardware or Materiel.... In fact the entire layout is different.  If I click on Ethernet, it then shows MTU & the number, but I connect via WiFi, so how would changing the setting under Ethernet affect anything?

  • Gontran Bolduc Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 11, 2013 5:13 AM (in response to Saxman)

    The OS version I am using is 10.8.2. I included the WI-FI screen of mine and matrial is there. I understand yours indicated "Ethernet", in the WI-FI submenu.

     

    "Ethernet" is a communication protocol. Your computer need this protocol on no mater if it is on WI-Fi or wire connected to the router. So I sugest you try the "Ethernet" and continue up to MTU.

     

    For DNS, if you do not have the address of the DNS server, try the same address of your router.

     

     

     

     

     

    wi-fi.jpg

  • jarjart Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 31, 2013 7:02 AM (in response to A.R.K.)

    Yep definately better, not all great but better

  • atmanamaste Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 3, 2013 6:23 AM (in response to excelcius)

    Same problem here. One workaround that helped every time so far is to log on as guest, start safari as guest, then log in to your own account again and reload the page. It will then work.

     

    Is a bit of a pain like this, so i'll be using another browser.

  • shadowcast Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 4, 2013 8:14 AM (in response to Hal in Maine)

    Thanks to Hal.  Updating the DNS was the fix that I needed.  SOOOO much better!

  • hwoodlive Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 22, 2013 5:57 PM (in response to excelcius)

    Hal's solution worked for me too, after achingly long months of slow Safari.  I was actually surfing using Chrome when I came across his suggestion, since "surfing" on Safari had become more like walking on a glacier.  The MTU fixes others had success with didn't work for me.  I'm ethernet-wired and don't use iCloud, so those suggestions weren't in my box of tricks either.  Thanks, Hal.  Whew!

  • wakamac Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 13, 2013 2:57 AM (in response to excelcius)

    just to let you know the Hal from Maine solution seems to have worked for me - speed is now amazing! just bought the macbook pro retina 2 weeks ago and was dismayed the browser kept freezing!

  • hwoodlive Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 21, 2013 10:18 AM (in response to excelcius)

    And quickly on the heels of my August 22nd 'success email'... my Safari is now again dead slow.  Well, it was nice while it lasted.  :-(

  • wakamac Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 21, 2013 10:36 AM (in response to excelcius)

    mine didnt last either but i still have the apple support on the phone so this is what they had me do and it has seemed to work for me if you want to try it:

     

    in Finder on the top bar click Go

    utilities

    disk utilities

    cursor on the Macantosh HD

    click on Repair Disk Permissions

     

    let it run

     

    then i logged out and logged back on.

     

    hope that helps.

  • Richie_jp Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 22, 2013 3:40 AM (in response to excelcius)

    Hi,

     

    Been suffering the same problem Running Mavericks macbook pro 2011; hanging pages etc.  All very random.

     

    Enabled the Develop tab (Safari preferences - Advanced - click option at bottom of box).  Under that menu found User Agent. This was set to Default (Automatically Chosen).  Set User Agent to Safari 7.0.

     

    All pages now load faster and so far no hanging.

     

    However going back into the User Agent it shows Default again.  Hovering over the other options also displays a yellow box with the actual code being used.  Takes a couple of seconds to show up though.  Doesn't work with the Default option so I've no idea what the Default actually is.

     

    So long as that fixes the problem I don't care about the logic of not displaying what User Agent is actually chosen.

     

    Hope this helps

  • G.Madigan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 22, 2013 6:43 AM (in response to Richie_jp)

    ~ How to change your Safari’s User Agent permanently. ~

     

    I cannot confirm the overall effectiveness of using a different user agent, but it does appear to effect how some websites react to your browser, such as being a mobile device, using Windows-only effects, etc.

     

    Note that some websites may refuse to load altogether if it thinks you’re something else.

     

    • First, you need to be comfortable with using Terminal.

     

    In Terminal, enter…

     

    defaults write com.apple.Safari CustomUserAgent "\" your new user agent string \""

    • You may copy & paste this.

    • Replacing only the underlined portion. You will need all of the appropriate slashes, quotes and spaces.

     

    Example…

    defaults write com.apple.Safari CustomUserAgent "\" Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_0) AppleWebKit/537.71 (KHTML, like Gecko) Version/7.0 Safari/537.71 \””

     

    To know what to enter as your Custom User Agent string…

    1. From the list in Safari, select the user agent you prefer to make as the default.

    2. Allow the current website to reload.

    3. Go back to the User Agent list and click on “Other…”

    4. You may copy and paste this string into your Terminal command.

     

    Restart Safari after entering the change in Terminal.

    To reverse it back to being automatically chosen by Safari, use the UNIX command…

    defaults delete com.apple.Safari CustomUserAgent

     

    As always, use great care when messing with the UNIX commands in Terminal.

  • Richie_jp Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 22, 2013 7:07 AM (in response to G.Madigan)

    Hi,

     

    Thank you for this. Do you happen to know if there's a file with the Default user agent string in it?

     

    Thanks

  • G.Madigan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 22, 2013 9:40 AM (in response to Richie_jp)

    I don't know of such a file.

     

    Unless instructed otherwise by the prefs file or the Developer menu, it could be a dynamicly created line of text from within Safari; adapting to each website to help insure greater compatibility. For example, if the site isn't responding to "...Safari/536" or it obviously has Microsoft functions, it could try using Microsoft's agent "...Trident/6.0".

     

    But, that is pure conjecture on my part.

1 2 3 4 5 6 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.