7 Replies Latest reply: Apr 1, 2013 2:55 AM by The hatter
Boan Rubalcava Level 1 Level 1 (0 points)

I'm sitting there workign and all of a sudden everything goes dark and is followed by the gray screen of the computer restarting.

 

At one point it gives me the message that the computer crashed and to push any key. 

 

The ONLY think that I can think is different from normal operation is that I unchecked the "Put hard disks to sleep when possible". I did this because I have a drobo that won't mount after the computer goes to sleep and they told me to try that.  I don't know if that is even related at all but I thought I throw that out there. 

 

In the console log (which is mostly gibrish to me) I did see a reference to a "com.CalDigit.driver.CalDigitUSB...." something or other.  I did install a USB3 card manufactured by Cal Digit but I have no idea if that has any relevance.  Its a PCI express card on the mac pro.

 

This has happened to me 2-3 times now.  I'd sure appreaciate any help any one can render.

 

This is what the Console Panic report says:

 

Fri Dec 21 11:37:05 2012

panic(cpu 6 caller 0xffffff801e0b7bd5): Kernel trap at 0xffffff7f9f7336d3, type 14=page fault, registers:

CR0: 0x000000008001003b, CR2: 0xffffff81b7ed700c, CR3: 0x00000000206d1000, CR4: 0x0000000000000660

RAX: 0xffffff81b7ed7000, RBX: 0xffffff8040d0f780, RCX: 0x0000000000000000, RDX: 0x0000000000000000

RSP: 0xffffff81b7b83df8, RBP: 0xffffff81b7b83e00, RSI: 0xffffff8040d0f780, RDI: 0xffffff81b7f15a90

R8:  0x0000000000001000, R9:  0x000000000000fc00, R10: 0xffffff803d2e4a80, R11: 0x00000000ffffff80

R12: 0xffffff81b7ed6000, R13: 0x0000000000000000, R14: 0xffffff81b7ed6ff0, R15: 0x000000000000000d

RFL: 0x0000000000010287, RIP: 0xffffff7f9f7336d3, CS:  0x0000000000000008, SS:  0x0000000000000010

Fault CR2: 0xffffff81b7ed700c, Error code: 0x0000000000000000, Fault CPU: 0x6

 

 

Backtrace (CPU 6), Frame : Return Address

0xffffff81b7b83a90 : 0xffffff801e01d626

0xffffff81b7b83b00 : 0xffffff801e0b7bd5

0xffffff81b7b83cd0 : 0xffffff801e0ce4ed

0xffffff81b7b83cf0 : 0xffffff7f9f7336d3

0xffffff81b7b83e00 : 0xffffff7f9f72eab7

0xffffff81b7b83eb0 : 0xffffff7f9f72f048

0xffffff81b7b83ef0 : 0xffffff801e4472a8

0xffffff81b7b83f30 : 0xffffff801e445daa

0xffffff81b7b83f80 : 0xffffff801e445ed9

0xffffff81b7b83fb0 : 0xffffff801e0b26b7

      Kernel Extensions in backtrace:

         com.CalDigit.driver.CalDigitUSBxHCI(1.3.8a2)[F4AA3EBC-9193-31D6-89AF-D7D1AF1192 BF]@0xffffff7f9f721000->0xffffff7f9f73dfff

            dependency: com.apple.iokit.IOUSBFamily(5.4.0)[C3094550-7F58-3933-A4F7-CD33AE83F8B9]@0xffff ff7f9ee99000

            dependency: com.apple.iokit.IOPCIFamily(2.7.2)[B1B77B26-7984-302F-BA8E-544DD3D75E73]@0xffff ff7f9e679000

 

 

BSD process name corresponding to current thread: kernel_task

 

 

Mac OS version:

12C60

 

 

Kernel version:

Darwin Kernel Version 12.2.0: Sat Aug 25 00:48:52 PDT 2012; root:xnu-2050.18.24~1/RELEASE_X86_64

Kernel UUID: 69A5853F-375A-3EF4-9247-478FD0247333

Kernel slide:     0x000000001de00000

Kernel text base: 0xffffff801e000000

System model name: MacPro4,1 (Mac-F221BEC8)

 

 

System uptime in nanoseconds: 6963074368897

last loaded kext at 343194669040: com.apple.filesystems.smbfs          1.8 (addr 0xffffff7fa0030000, size 229376)

last unloaded kext at 252588740961: com.apple.driver.AppleUSBXHCI          1.4.0 (addr 0xffffff7f9efb0000, size 98304)

loaded kexts:

com.TrustedData.driver.VendorSpecificType00          1.5.0

com.attotech.driver.ATTOiSCSI          3.4.1b1

com.AmbrosiaSW.AudioSupport          4.1.2

com.CalDigit.driver.CalDigitUSBxHCI          1.3.8a2

com.apple.filesystems.smbfs          1.8

com.apple.driver.AppleHWSensor          1.9.5d0

com.apple.driver.AppleBluetoothMultitouch          75.15

com.apple.driver.AudioAUUC          1.60

com.apple.iokit.IOBluetoothSerialManager          4.0.9f33

com.apple.driver.AppleTyMCEDriver          1.0.2d2

com.apple.driver.AGPM          100.12.69

com.apple.driver.AppleUpstreamUserClient          3.5.10

com.apple.driver.AppleUSBDisplays          353

com.apple.driver.AppleMikeyHIDDriver          122

com.apple.filesystems.autofs          3.0

com.apple.driver.AppleMCCSControl          1.0.33

com.apple.driver.AppleHDA          2.3.1f2

com.apple.iokit.IOUserEthernet          1.0.0d1

com.apple.Dont_Steal_Mac_OS_X          7.0.0

com.apple.GeForce          8.0.0

com.apple.driver.AppleMikeyDriver          2.3.1f2

com.apple.iokit.BroadcomBluetoothHCIControllerUSBTransport          4.0.9f33

com.apple.driver.ApplePolicyControl          3.2.11

com.apple.driver.Apple_iSight          4.0.1

com.apple.driver.AppleLPC          1.6.0

com.apple.driver.ACPI_SMC_PlatformPlugin          1.0.0

com.apple.driver.MaxTranserSizeOverrideDriver          3.1.0

com.apple.driver.XsanFilter          404

com.apple.iokit.IOAHCIBlockStorage          2.2.2

com.apple.iokit.SCSITaskUserClient          3.5.1

com.apple.AppleFSCompression.AppleFSCompressionTypeDataless          1.0.0d1

com.apple.driver.AppleUSBHub          5.2.5

com.apple.AppleFSCompression.AppleFSCompressionTypeZlib          1.0.0d1

com.apple.driver.AppleFWOHCI          4.9.6

com.apple.BootCache          34

com.apple.driver.Intel82574L          2.3.0b4

com.apple.driver.AppleAHCIPort          2.4.1

com.apple.driver.AppleUSBEHCI          5.4.0

com.apple.driver.AppleUSBUHCI          5.2.5

com.apple.driver.AppleEFINVRAM          1.6.1

com.apple.driver.AppleRTC          1.5

com.apple.driver.AppleHPET          1.7

com.apple.driver.AppleACPIButtons          1.6

com.apple.driver.AppleSMBIOS          1.9

com.apple.driver.AppleACPIEC          1.6

com.apple.driver.AppleAPIC          1.6

com.apple.driver.AppleIntelCPUPowerManagementClient          196.0.0

com.apple.nke.applicationfirewall          4.0.39

com.apple.security.quarantine          2

com.apple.driver.AppleIntelCPUPowerManagement          196.0.0

com.apple.driver.IOBluetoothHIDDriver          4.0.9f33

com.apple.driver.AppleMultitouchDriver          235.28

com.apple.iokit.IOSerialFamily          10.0.6

com.apple.driver.AppleUSBAudio          2.9.0f6

com.apple.kext.triggers          1.0

com.apple.driver.DspFuncLib          2.3.1f2

com.apple.iokit.IOSurface          86.0.3

com.apple.iokit.IOBluetoothFamily          4.0.9f33

com.apple.driver.AppleHDAController          2.3.1f2

com.apple.iokit.IOHDAFamily          2.3.1f2

com.apple.iokit.IOAudioFamily          1.8.9fc10

com.apple.kext.OSvKernDSPLib          1.6

com.apple.iokit.AppleBluetoothHCIControllerUSBTransport          4.0.9f33

com.apple.driver.AppleSMBusController          1.0.10d0

com.apple.iokit.IOFireWireIP          2.2.5

com.apple.driver.AppleGraphicsControl          3.2.11

com.apple.nvidia.nv50hal          8.0.0

com.apple.NVDAResman          8.0.0

com.apple.iokit.IONDRVSupport          2.3.5

com.apple.iokit.IOGraphicsFamily          2.3.5

com.apple.driver.AppleSMBusPCI          1.0.10d0

com.apple.driver.AppleSMC          3.1.4d2

com.apple.driver.IOPlatformPluginLegacy          1.0.0

com.apple.driver.IOPlatformPluginFamily          5.2.0d16

com.apple.iokit.IOSCSIBlockCommandsDevice          3.5.1

com.apple.iokit.IOUSBMassStorageClass          3.5.0

com.apple.driver.AppleUSBHIDKeyboard          165.5

com.apple.driver.AppleHIDKeyboard          165.5

com.apple.iokit.IOUSBHIDDriver          5.2.5

com.apple.driver.AppleUSBMergeNub          5.2.5

com.apple.driver.AppleUSBComposite          5.2.5

com.apple.iokit.IOSCSIMultimediaCommandsDevice          3.5.1

com.apple.iokit.IOBDStorageFamily          1.7

com.apple.iokit.IODVDStorageFamily          1.7.1

com.apple.iokit.IOCDStorageFamily          1.7.1

com.apple.iokit.IOAHCISerialATAPI          2.5.0

com.apple.iokit.IOSCSIArchitectureModelFamily          3.5.1

com.apple.iokit.IOFireWireFamily          4.5.5

com.apple.iokit.IOUSBUserClient          5.2.5

com.apple.iokit.IONetworkingFamily          3.0

com.apple.iokit.IOAHCIFamily          2.2.1

com.apple.iokit.IOUSBFamily          5.4.0

com.apple.driver.AppleEFIRuntime          1.6.1

com.apple.iokit.IOHIDFamily          1.8.0

com.apple.iokit.IOSMBusFamily          1.1

com.apple.security.sandbox          220

com.apple.kext.AppleMatch          1.0.0d1

com.apple.security.TMSafetyNet          7

com.apple.driver.DiskImages          344

com.apple.iokit.IOStorageFamily          1.8

com.apple.driver.AppleKeyStore          28.21

com.apple.driver.AppleACPIPlatform          1.6

com.apple.iokit.IOPCIFamily          2.7.2

com.apple.iokit.IOACPIFamily          1.4

com.apple.kec.corecrypto          1.0


Mac Pro, OS X Mountain Lion (10.8.2), 14 GB RAM Dual Xeon Quad Core
  • 1. Re: Computer Inexplicably crashes (restarts)
    mende1 Level 10 Level 10 (89,570 points)

    Boan Rubalcava wrote:

     

    com.CalDigit.driver.CalDigitUSBxHCI          1.3.8a2

     

    This is the problem. Install the latest version or delete the extension

  • 2. Re: Computer Inexplicably crashes (restarts)
    hagrant Level 1 Level 1 (10 points)

    Unfortunately 1.3.8a2 seems to be the latest version.

    I'm seeing the same random panics - about 1 every 48hours, even after I disconnected all USB3 devices and removed all other cards (and their drivers) from the machine.

    It seems to be slightly worse under 10.8.3 than 10.8.2...

     

    I'm using an early 2009 Mac Pro, same as the original poster.

    CalDigit haven't release an update in a long time, and a quick web search doesn't seem to indicate this is a very widepsread problem, which isn't much comfort to those of us experiencing it!

     

    For now, I am going to remove the CalDigit card as I'm primarily using it to speed up transfers off of CompactFlash and SDXC cards, and it's not worth the hassle of the random reboots.

     

    @Boan - my advice right now is to make sure you log a bug with CalDigit - the more they hear about this the more likely they are to fix it.

     

    In the meantime, I will keep looking for a fix.

     

    Cheers

  • 3. Re: Computer Inexplicably crashes (restarts)
    The hatter Level 9 Level 9 (58,880 points)

    Did 10.8.3 help anyone with this issue?

     

    Use to be folks would also log reports to one site and that helped to be a clearing house of bug reports and help for other readers.

     

    http://www.xlr8yourmac.com/

  • 4. Re: Computer Inexplicably crashes (restarts)
    Boan Rubalcava Level 1 Level 1 (0 points)

    I took out the CallDigit card a long time ago but my problems haven't gone away. 

     

    The machine hasn't unexpectedly rebooted itself for a long time but it does become unresponsive after being asleep for a while. 

     

    The only thing I've not tried is replacing the graphics card,  I honestly don't know what else I could try.  I've rebuilt it a million times.

  • 5. Re: Computer Inexplicably crashes (restarts)
    The hatter Level 9 Level 9 (58,880 points)

    I was going to suggest getting CallDigit to replace the card, if you still had it, as they have changed chipset and could have made changes and improvements. There was a spell when they were having trouble with their cards and drivers, and any USB3.

     

    And yours 'was' the USB3 only, and not the combo w/ SATA 3 also?

     

    Rebuilt as in clean install now of 10.8 and update to 10.8.3 alone? obviously hard to work but for testing at least might help focus on hardware wtih bare OS.

     

    I wish there was a utility that would just scan extensions for known culprits - to be run before any update or to diagnose a system.

  • 6. Re: Computer Inexplicably crashes (restarts)
    hagrant Level 1 Level 1 (10 points)

    Good point about xlr8yourmac, I'll send them a note today.

     

    I didn't realise they had changed the chips on the CalDigit USB3 cards - I've got the combo USB3/SATA3 card, so it's probably the newer chipset already, worse luck... still it's something to ask the support people. I'm pretty sure it's going to be a driver issue though, as it happens even if nothing is plugged in to the card, so there may be some sort of leak/corruption in the background.

     

    Sigh... I tried booting off a clean install on a separate drive... nothing installed except 10.8.3 combo update and CalDigit drivers. Got a kernel panic and reboot at 4am

  • 7. Re: Computer Inexplicably crashes (restarts)
    The hatter Level 9 Level 9 (58,880 points)

    I would have tried 10.8.3 but w/o any drivers.

     

    There was a period - late 2011? when they stopped shipping for short spell.

     

    I think they should want to have the card to check it out in their own lab.