1 2 Previous Next 20 Replies Latest reply: Mar 31, 2013 9:52 AM by mjkrueger Go to original post
  • 15. Re: iPhoto crashes when NAS is connected
    Linc Davis Level 10 Level 10 (117,700 points)

    Please read this whole message before doing anything.
      
    This procedure is a diagnostic test. It won’t solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.
       
    Third-party system modifications are a common cause of usability problems. By a “system modification,” I mean software that affects the operation of other software — potentially for the worse. The following procedure will help identify which such modifications you've installed. Don’t be alarmed by the complexity of these instructions — they’re easy to carry out and won’t change anything on your Mac.

     

    These steps are to be taken while booted in “normal” mode, not in safe mode. If you’re now running in safe mode, reboot as usual before continuing.

     

    Below are instructions to enter some UNIX shell commands. The commands are harmless, but they must be entered exactly as given in order to work. If you have doubts about the safety of the procedure suggested here, search this site for other discussions in which it’s been followed without any report of ill effects.

     

    Some of the commands will line-wrap or scroll in your browser, but each one is really just a single line, all of which must be selected. You can accomplish this easily by triple-clicking anywhere in the line. The whole line will highlight, and you can then copy it. The headings “Step 1” and so on are not part of the commands.

     

    Note: If you have more than one user account, Step 2 must be taken as an administrator. Ordinarily that would be the user created automatically when you booted the system for the first time. The other steps should be taken as the user who has the problem, if different. Most personal Macs have only one user, and in that case this paragraph doesn’t apply.

     

    Launch the Terminal application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

     

    When you launch Terminal, a text window will open with a line already in it, ending either in a dollar sign (“$”) or a percent sign (“%”). If you get the percent sign, enter “sh” and press return. You should then get a new line ending in a dollar sign.

     

    Step 1

     

    Triple-click the line of text below to select it:
    kextstat -kl | awk '!/com\.apple/{printf "%s %s\n", $6, $7}'
     
    Copy the selected text to the Clipboard by pressing the key combination command-C. Then click anywhere in the Terminal window and paste (command-V). Post the lines of output (if any) that appear below what you just entered. You can do that by copying and pasting as well. Omit the final line ending in “$”. No typing is involved in this step.
        
    Step 2

     

    Repeat with this line:
    sudo launchctl list | sed 1d | awk '!/0x|com\.(apple|openssh|vix)|edu\.mit|org\.(amavis|apache|cups|isc|ntp|postfix|x)/{print $3}'
     
    This time you'll be prompted for your login password, which you do have to type. It won't be displayed when you type it. Type it carefully and then press return. You may get a one-time warning to be careful. Heed that warning, but don't post it. If you see a message that your username "is not in the sudoers file," then you're not logged in as an administrator.

     

    Note: If you don’t have a login password, you’ll need to set one before taking this step. If that’s not possible, skip to the next step.

     

    Step 3
    launchctl list | sed 1d | awk '!/0x|com\.apple|edu\.mit|org\.(x|openbsd)/{print $3}'
     
    Step 4
    ls -1A /e*/mach* {,/}L*/{Ad,Compon,Ex,Fram,In,Keyb,La,Mail/Bu,P*P,Priv,Qu,Scripti,Servi,Spo,Sta}* L*/Fonts 2> /dev/null
      
    Important: If you formerly synchronized with a MobileMe account, your me.com email address may appear in the output of the above command. If so, anonymize it before posting.

     

    Step 5
    osascript -e 'tell application "System Events" to get name of every login item' 2> /dev/null
     
    Remember, steps 1-5 are all copy-and-paste — no typing, except your password. Also remember to post the output.

     

    You can then quit Terminal.

  • 16. Re: iPhoto crashes when NAS is connected
    mjkrueger Level 1 Level 1 (0 points)

    That are the outputs of the different steps:

     

    Step 1

     

    There was no output.

     

    Step 2

     

    • org.macosforge.xquartz.privileged_startx
    1. com.microsoft.office.licensing.helper
    2. com.adobe.fpsaud

     

    Step 3

     

    • org.macosforge.xquartz.startx
    1. com.google.keystone.user.agent

     

     

    Step 4

     

    /Library/Extensions:

     

    /Library/Frameworks:

    1. AEProfiling.framework
    2. AERegistration.framework
    3. AudioMixEngine.framework
    4. NyxAudioAnalysis.framework
    5. PluginManager.framework
    6. iTunesLibrary.framework

     

    /Library/Input Methods:

     

    /Library/Internet Plug-Ins:

    Flash Player.plugin

    Google Earth Web Plug-in.plugin

    1. JavaAppletPlugin.plugin

    Quartz Composer.webplugin

    QuickTime Plugin.plugin

    1. SharePointBrowserPlugin.plugin
    2. SharePointWebKitPlugin.webplugin
    3. flashplayer.xpt

    googleearth-mac-plugin-intel.dmg

    1. nsIQTScriptablePlugin.xpt

     

    /Library/Keyboard Layouts:

     

    /Library/LaunchAgents:

    • org.macosforge.xquartz.startx.plist

     

    /Library/LaunchDaemons:

    1. com.adobe.fpsaud.plist
    2. com.microsoft.office.licensing.helper.plist
    • org.macosforge.xquartz.privileged_startx.plist

     

    /Library/PreferencePanes:

    Flash Player.prefPane

     

    /Library/PrivilegedHelperTools:

    1. com.microsoft.office.licensing.helper

     

    /Library/QuickLook:

    1. iBooksAuthor.qlgenerator
    2. iWork.qlgenerator

     

    /Library/QuickTime:

    1. AppleIntermediateCodec.component

    AppleMPEG2Codec.component

     

    /Library/ScriptingAdditions:

     

    /Library/Spotlight:

    Microsoft Office.mdimporter

    1. iBooksAuthor.mdimporter
    2. iWork.mdimporter

     

    /Library/StartupItems:

     

    /etc/mach_init.d:

     

    /etc/mach_init_per_login_session.d:

     

    /etc/mach_init_per_user.d:

     

    Library/Address Book Plug-Ins:

     

    Library/Fonts:

     

    Library/Input Methods:

    .localized

     

    Library/Internet Plug-Ins:

    Google Earth Web Plug-in.plugin

    1. Picasa.plugin

     

    Library/Keyboard Layouts:

     

    Library/LaunchAgents:

    1. com.apple.AddressBook.ScheduledSync.PHXCardDAVSource.F16FE67F-2655-4329-AADE-BDA 2BC3C678E.plist
    2. com.apple.FolderActions.enabled.plist
    3. com.apple.FolderActions.folders.plist
    4. com.google.keystone.agent.plist

     

    Library/PreferencePanes:

     

     

    Step 5

     

    iTunesHelper, Gemeinsame Bilder, ClamXavSentry, music, Time Machine, home

  • 17. Re: iPhoto crashes when NAS is connected
    Linc Davis Level 10 Level 10 (117,700 points)

    Is the folder "Gemeinsame Bilder" stored on the NAS? Did you import any images from the NAS into iPhoto? If you did, is the box marked Copy items to the iPhoto Library checked in iPhoto's Advanced preferences?

  • 18. Re: iPhoto crashes when NAS is connected
    mjkrueger Level 1 Level 1 (0 points)

    Yes, the folder "Gemeinsame Bilder" is stored on the NAS. And yes, I imported pictures from there. And I marked the box Copy items to the iPhoto Library.

     

    Actually, I tried to import pictures from my HD as well, in a "clean" new library. But the same problem occured when I started or t created a new slide show.

  • 19. Re: iPhoto crashes when NAS is connected
    Linc Davis Level 10 Level 10 (117,700 points)

    The only theory that makes sense to me is that the library contains a reference to something on the NAS that is causing iPhoto to crash. I suggest you follow the instructions on the page linked below:

     

    iPhoto 6 and later: Rebuilding the iPhoto library

     

    If that doesn't help, you may need to do a more thorough rebuild using this third-party software:

     

    Fat Cat Software – iPhoto Library Manager

  • 20. Re: iPhoto crashes when NAS is connected
    mjkrueger Level 1 Level 1 (0 points)

    So, I installed the little app iPhotoBuddy...and it works!!!

     

    Don't ask me why but when I start iPhoto over the Buddy, I can play the slide shows even when the NAS is connected.

     

    Problem solved...kind of!

     

    Anyway, thank you very much for your help.

1 2 Previous Next