1 Reply Latest reply: Apr 1, 2013 11:57 AM by Niel
vickybee08 Level 1 Level 1 (0 points)

My iTunes will not update because its not supported by my software.  How do I get the program to update.


iMac
  • 1. Re: My programs will not update because of the current software?
    Niel Level 10 Level 10 (242,105 points)

    iTunes 10 through 10.6.3 require at least Mac OS X 10.5, which requires a G4 or better Mac. Mac OS X 10.5 DVDs might be obtainable by phoning Apple and are available on sites such as Amazon or eBay.

    iTunes 10.7 and newer requires Mac OS X 10.6 or newer, which requires an Intel Mac with at least 1GB of RAM. It's available on the online Apple Store.

     

    (79891)