12 Replies Latest reply: Aug 29, 2013 5:09 AM by jeff303
milanprokop Level 1 Level 1 (0 points)

Hi, I recently asked about why is my iMac going to Safe Sleep over night. I found why (http://support.apple.com/kb/HT1757) and I thought I had found a solution. I read pmset manual page but I think there are few thing missing + few things are not working for me.

I have standby, autopoweroff and hibernatemode set to 0 but still the computer went to Safe Sleep over night. I noticed (and tested) that standbydelay is time after mac goes from regular sleep to safe sleep, so I changed it to 57600 (16 hours) but still, in the morning computer was waking up from safe sleep.

Does anyone have similar problems? Or does anyone know why the iMac is going to safe sleep when thats supposed to be banned by hibernatemode set to 0?

 

Thanks in Advance

 

Best Regards

Milan


iMac, OS X Mountain Lion (10.8.3)
  • 1. Re: pmset and Safe Sleep, can't disable it
    n748 Level 1 Level 1 (25 points)

    Take a look at the discussion here. There are a couple of posts (like this) explaining the procedure:

    Go to Terminal and enter: sudo pmset -a autopoweroff 0

    To undo type: sudo pmset -a autopoweroff 1

     

    Hope this helps...

  • 2. Re: pmset and Safe Sleep, can't disable it
    milanprokop Level 1 Level 1 (0 points)

    Thanks for the links, i'll check them tomorrow. Unfortunaly, as I said, I already had autopoweroff set to zero, but the issue still occurs.

  • 3. Re: pmset and Safe Sleep, can't disable it
    milanprokop Level 1 Level 1 (0 points)

    This is how my pmset -g looks like:

    Screen Shot 2013-04-02 at 7.20.49.png

  • 4. Re: pmset and Safe Sleep, can't disable it
    milanprokop Level 1 Level 1 (0 points)

    Now i have this in pmset -g "sleep          0 (sleep prevented by 265)" What does "sleep prevented by 256" mean? I tried to google it but found nothing.

  • 5. Re: pmset and Safe Sleep, can't disable it
    n748 Level 1 Level 1 (25 points)

    It's a Process ID (PID). 10.8 has a different sleep management compared to previous OS X. Programms have to actively block sleep now. You can check PIDs for example in activity monitor.

  • 6. Re: pmset and Safe Sleep, can't disable it
    milanprokop Level 1 Level 1 (0 points)

    autopoweroff, standby, autopoweroffdelay nor standbydelay didn't make a difference for me, the computer always goes to Safe Sleep over night. I'm kinda frustrated form it cause whatever I try it's always the same

    Furthermore they say "standby only works if hibernation is turned on to hibernatemode 3 or 25." and "standby causes kernel power management to automatically hibernate a machine after it has slept for a specified time period." So how come that my iMac hibernates when I have hibernate mode set to 0 and the "specified time period" is set to 24 hours???

  • 7. Re: pmset and Safe Sleep, can't disable it
    Delta Mac Level 1 Level 1 (0 points)

    I have the same issue. I have reset the autopoweroff and hibernatemode to 0. I still get the **** safe sleep. Strange thing is it only happens when it is plugged in. It noticed this started to happen after I updated the OS (forgot which version). If anyone have a solution, please share.

  • 8. Re: pmset and Safe Sleep, can't disable it
    milanprokop Level 1 Level 1 (0 points)

    according to this i guess its a new "feature"

    http://support.apple.com/kb/HT1757?viewlocale=en_US&locale=en_US

     

    but i still dont understand why its happening when hibernatemode is set to 0.

  • 9. Re: pmset and Safe Sleep, can't disable it
    Delta Mac Level 1 Level 1 (0 points)

    I think this solution makes perfect sense. Just sharing...

     

    https://discussions.apple.com/message/21325631#21325631

  • 10. Re: pmset and Safe Sleep, can't disable it
    kanavel Level 1 Level 1 (0 points)

    This thread may be a little stale, but it fits my issue perfectly. 

     

    Has anyone discovered a usable workaround to prevent iMac's from going into Safe Sleep yet? 

     

    The recommendations in this thread haven't produced any results for me.

     

    One of the major benefits (at the time) that caused me to switch to Apple workstations was their ability to recover from sleep almost instantly.  This is a significant  problem for me.

  • 11. Re: pmset and Safe Sleep, can't disable it
    jeff303 Level 1 Level 1 (0 points)

    I have a late 2012 Mac Mini base model (refurbished, running OS X 10.8.4), that I added 16GB of RAM and a 256GB Samsung 840 Pro SSD to (in the primary drive slot, moving the stock HDD to the secondary slot).  I had trouble getting wake on lan to work (through my DD-WRT router), when the machine was in "deep sleep" (where the light was completely off), which I later came to learn is called "safe sleep."  When it was in normal sleep (light slowly oscillating) then WOL worked fine.

     

    In my case, I had already set hibernatemode=0 and autopoweroff=0 via pmset, but it was still happening.  Finally I set standby=0 and that did the trick (stopped going into safe sleep).  This is in spite of the fact that according to the man page, this should not be needed; standby is supposed to be ignored if hibernatemode=0, which was definitely not the behavior I observe on my machine.

     

    Anyway, I'm just posting this in case it helps anyone else in a similar situation.  Set standby=0 via pmset and see if that lets you disable safe sleep.

  • 12. Re: pmset and Safe Sleep, can't disable it
    jeff303 Level 1 Level 1 (0 points)

    Correction to the above, WOL still does not work.    The light doesn't go completely off, but even still, after a certain period of time, the wake on lan packet no longer wakes the machine up.  It still works if the machine has "just" gone to sleep.  Very frustrating, guess I have to simply disable sleep when going out of town.