Skip navigation

Time machine backup is not recognized in Setup Assistant

1819 Views 22 Replies Latest reply: Apr 9, 2013 7:33 PM by Pondini RSS
1 2 Previous Next
orppaha@gmail.com Calculating status...
Currently Being Moderated
Mar 26, 2013 9:58 AM

Hi, I went through lots of discussion but could not find answers to my case.

 

My Macbook pro crashed the other day and replaced HDD.

I had Time Machine Backup several days ago and was trying to restore.

I started with install CD and used utility to restore from backup.

It recoginzed the volume of Time Machine Backup and next step, it does not show any backups that I can choose.

 

I installed Mac OSX and tried "transfer from a Time Machine Backup" but it does not recognize my the backup.

I checked hard drive on other computers and can see backups and no issues with hard drive.

 

Can anyone help?

 

Mac OS X 10.6.3 (Snow Leopard)

Macbook pro 2.53 GHz Intel Core duo

 

Thanks.

Macbook Pro, Mac OS X (10.6.2), iMac
  • baltwo Level 9 Level 9 (59,235 points)

    See Pondini's TM FAQs, for starters.

    27" i7 iMac SL, Lion, OS X Mountain Lion (10.8.3), G4 450 MP w/Leopard, 9.2.2
  • baltwo Level 9 Level 9 (59,235 points)

    I can't help further, since I don't use TM. If the FAQs and troubleshooting sections don't discuss your issue, you'll have to wait for a TM maven to pop in.

    27" i7 iMac SL, Lion, OS X Mountain Lion (10.8.3), G4 450 MP w/Leopard, 9.2.2
  • Pondini Level 8 Level 8 (38,710 points)

    orppaha@gmail.com wrote:

    . . .

    I restarted the computer with install disk and went to restore mode, and only thing I can see from TM was the new one (3/27 backup).

     

    Is there any way to access 3/6 backup and restore those?

    Probably.  When you erased your disk and reinstalled OSX, even though it has the same name as before, the erased disk is treated as a different one.

     

    When you start from the install disc, and get to this window:

     

    14d Select a Backup.jpg

     

    See if the Restore From system and disk name at the top is actually a "pop-up" menu.  If so, you'll see the same thing twice (since the names are the same). Try selecting the other one.

  • Pondini Level 8 Level 8 (38,710 points)

    Hi,

     

    Sorry to be so long responding . . . I didn't get a notice that you'd posted back -- the e-mail notification system seems to be broken (again). 

     

    The other possibility is, the "missing" backups didn't include OSX.  You can exclude System folders via TM Preferences > Options;  that sets an indicator in the preferences file.   We have seen a few cases where that indicator got set in some other way -- some sort of corruption, apparently.  Obviously, if TM doesn't back up OSX, you can't do a full system restore.

     

    The way to tell is, "drill down" in one of the "missing" backups.  Inside the date-stamped backup folder should be one folder for each drive/partition that was backed-up;  inside that is the same folder structure as the drive.

     

    At the top level of the OSX drive should be the Applications, Library, System, and User folders (and perhaps a couple of others).  Look in the System folder -- see if it has contents -- there should be a single Library folder inside it, with a whole bunch of folders, sub-folders, etc.  

     

    See what you'e got there (and I'll check back periodically this time).

  • Pondini Level 8 Level 8 (38,710 points)

    No, there's no System folder at the top level of the drive (second column of your screenprint).  No Library or private folder there, either, oddly, and the Application folder should be Applications.

     

    (The Library folder you selected is different -- it's in one of your user home folders;  it contains all sorts of things for that individual user account.)

     

    Here's what I mean:

     

    Screen Shot 2013-04-05 at 1.00.08 PM.png

     

    So a lot of things were not backed-up, for whatever reason. 

     

    When you tried Setup Assistant (per "I installed Mac OSX and tried "transfer from a Time Machine Backup" but it does not recognize my the backup" in your first post), do you recall exactly what you saw on the Select the Source window?  The reason I ask is, an external HD will show the disk and system name that were backed-up, not the name of the drive the backups are on.  Sometimes folks think it's their internal HD, not an external HD.  The drive should have a yellow or green icon, though, not they gray one from the backups.  It's a little hard to see in the photo, but the first item here:

     

    shapeimage_2.png

     

     

    However, that always uses the most recent completed backup, so you'd have to delete the April 3 backups first, to make the March 27 backup the most recent.  But if that works, it would transfer whatever was backed-up from your home folders.  (You'd have to erase the HD and reinstall OSX again to get back there.)

     

     

    Your other option is to do it "piecemeal" -- copy what you need from the backups.  That's very tedious and error-prone, of course, but can be done.

  • Pondini Level 8 Level 8 (38,710 points)

    orppaha@gmail.com wrote:

    . . .

    You are right...all the backups before 3/6 does not have System and Library folder at the root and Library under users exist. So, I guess I am out of luck. I never touched exclude option in Time Machine. I don't know why it didn't back up the system.

    That's quite odd.  We've seen a very few cases of that happening on Mountain Lion, but I don't recall it on Snow Leopard (but I don't read all the TM-related threads here anymore, so may have missed it).

     

     

    One last questions, then, would I be able to restore Apple Mail contents and setup? I also tried this by following on your instruction at your TM website but it only copies mailboxes with empty contents. When I checked mailbox size, it certainly has big contents. But when it was 1. copies into the library/mail/  or 2. restore from Time Machine  3. import mailbox...all resulted the same empty boxes.... Is this also out of luch because of system folder was not backed up?

    First, you need the mail setup.  That's in the ~/Library/Preferences/com.apple.mail.plist file.  That has all the account and mailbox names, server names, etc. Copy or restore that first.

     

    Then delete the ~/Library/Mail folder and copy or restore it from the backup.  Then select the mailbox in question via Mail, and from the Mail menubar, select Mailbox > Rebuild.  to rebuild the index(es).  You'll have to do each mailbox separately.

  • Pondini Level 8 Level 8 (38,710 points)

    orppaha@gmail.com wrote:

    . . .

    Thanks again. Somehow, I don't have "com.apple.mail.plist" in "~/zzang/library/preference". I foundt it under "~/zzang/library/containers/com.apple.mail/Data/Library/Preferences/".

    Then you're not running Snow Leopard, but either Lion or Mountain Lion.  Snow Leopard does not have a Containers folder in ~/Library.  That's for "sandboxed" apps, which started with Lion.

     

     

    I found the .exclusions.plist file at the 3/6 backup and it has the bunch of exclusions list...I guess this was the reason. But I really didn't set this up.

    All of those are the things Time Machine excludes automatically -- system work files, most caches and logs, trash, etc.  And the ones shown don't explain all the other exclusions.

     

    Some of the ones in the list are from Lion -- files that don't even exist on Snow Leopard.

     

     

    So, what version of OSX are you really running?  It does make a difference!

     

    And, has that changed since you did the backups in question?

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.