Skip navigation

Thunderbolt port failure on Late 2011 Macbook Pro?

939 Views 4 Replies Latest reply: Apr 15, 2013 7:08 AM by Zathrak RSS
Zathrak Level 1 Level 1 (0 points)
Currently Being Moderated
Apr 4, 2013 6:16 AM

On a daily basis, I use a 1TB Seagate GoFlex external HDD that was originally a USB 3.0 interface until I bought the Thunderbolt sled (replacing the USB 3.0 interface) for things like Time Machine backups, photo management in Aperture and the like. Last night, I was on my Late 2011 15in Macbook Pro running a Time Machine backup and working in Aperture via Thunderbolt while charging the laptop when suddenly the drive was improperly ejected and the LED on the Seagate shut off as if no connection was made. I unplugged the Thunderbolt connections and tried again and the Seagate LED remained off and no drives showed up in Disk Utility. So I tried taking that Seagate and Thunderbolt cable and used it on another Mac, everything worked properly and as expected. So to further drive home the theory that maybe the Thunderbolt port on the laptop was bad, I tried using another Thunderbolt drive/cable on the Macbook Pro and sure enough, nothing happened. To me, this sounds like a bad port.


The reason for this post is that I've not yet seen anything on the interwebz regarding Thunderbolt port failures aside from a few estranged "display issues" via Thunderbolt. Has anyone else heard of this kind of thing happening? I find it a bit odd that with modern technology that tends to prevent overheating issues, this was able to happen. It almost seems like maybe a piece of solder broke off or something? Any thoughts?

  • Shootist007 Level 6 Level 6 (16,640 points)
    Currently Being Moderated
    Apr 4, 2013 6:21 AM (in response to Zathrak)

    Have you rebooted the system? Have you tried a SMC and PRAM reset?


    If not do all three of those things.


    If you still have a problem hopefully you have Applecare as if you don't the fix will be expensive. You will need to have the logic board changed to fix a bad, broken, TB port.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.