Skip navigation

HT5655: Adobe Flash Player updates available for OS X on February 4, 2014

Learn about Adobe Flash Player updates available for OS X on February 4, 2014

HT5655 Flash still doesn't work with Safari.

11139 Views 22 Replies Latest reply: Jan 31, 2014 10:00 AM by Waspsting RSS
1 2 Previous Next
leaudulac Calculating status...
Currently Being Moderated
Mar 2, 2013 5:30 AM

I've done this repeatedly. Flash still doesn't work with Safari. It does work with Firefox and Chrome.

 

I deleted the Flash plugin from Library>Internet Plugins. That didn't solve the problem either.

 

What can I try next? Thanks.

MacBook Pro (Retina, Mid 2012), OS X Mountain Lion (10.8.2)
  • VikingOSX Level 5 Level 5 (4,660 points)
    Currently Being Moderated
    Mar 2, 2013 5:50 AM (in response to leaudulac)

    Flash version 11.6.602.171 (current) works just fine on my Mountain Lion implementation, and in Safari and Firefox. Chrome rolls its own built-in Flash content.

     

    If you downloaded and installed Flash from Adobe's official Flash download site, it will work.

     

    If you have the Flash Player Preference panel under System Preferences Other, then you can have it go fetch the latest flash installer. Under the (Flash panel) Advanced tab, select Check Now. Once it starts downloading the Flash Installer, exit all browsers and System Preferences. Empty your browser's cache before installing Flash. If you try to install Flash with System Preferences, or a browser open, it will fail.

     

    If you have several Safari plug-ins and extensions installed, one or more of these may not be compatible with Flash Player. If you have Click-to-Flash installed, it would block your Flash content.

  • jiminey Calculating status...
    Currently Being Moderated
    Mar 2, 2013 10:21 PM (in response to leaudulac)

    i have same problem -blocked plugin error msg for every video and website  flash 10 is installed but obviously not functioning  should i delete and install flash 11? also have "flashplayer.abt" appearing?

  • nicki_a Calculating status...
    Currently Being Moderated
    Mar 20, 2013 10:04 AM (in response to jiminey)

    I also have the same problem. Installed Flash 11 from the official site, and neither radio or YouTube plays any more. It says I must install Flash, which I have. I've tried uninstalling and reinstalling the older version, but Safari seems to have been mucked up by the newer version having been installed. I am running Safari 5.1.8. I can't find a way of uninstalling it or a download to reinstall. Chrome works OK with the new version of Flash, but I prefer Safari and would like to carry on using it.

  • jiminey Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 31, 2013 7:02 PM (in response to leaudulac)

    I've been traveling and regfregt not fololowing up sooner.  I have succeeded in finding the version of flash which is recommended for my particular configuragion in archived files (my mac pro is 2008 vintage with some sort of pc processor?).  accordingly 10.1etc is my maximum upgrade. But aqpple won't allow the download because it is neither purchased from the apple store, nor from a site recognized.  In other words the built in security won't let me upgrade flash player.  what and how do I disable protections to allow the installation?

     


  • VikingOSX Level 5 Level 5 (4,660 points)
    Currently Being Moderated
    Apr 1, 2013 3:18 PM (in response to leaudulac)

    For those of you running out of date plug-Ins (e.g. Flash 10), Safari will now block these and require an update from Adobe.

  • silvergc Level 3 Level 3 (750 points)
    Currently Being Moderated
    Apr 4, 2013 2:20 PM (in response to jiminey)

    jiminey,

     

    Go into "System Preferences" and select "Security & Privacy".  Go to the "General" tab.  You will have to unlock the page to make any changes, but you can select to download and install applications from "Anywhere" here.  I suggest that you set this back to one of the other two choices after installing Flash.

  • thomas_r. Level 7 Level 7 (26,920 points)
    Currently Being Moderated
    Apr 4, 2013 3:35 PM (in response to jiminey)

    my mac pro is 2008 vintage with some sort of pc processor

     

    If you have a Mac with a PowerPC processor (check About This Mac in the Apple menu), then there isn't a secure version of Flash available to you. But, then, you wouldn't be able to be running Mountain Lion. You would be able to run Snow Leopard (Mac OS X 10.6.x) at most. If you are running Snow Leopard, it will not allow you to run a known vulnerable version of Flash, but there isn't a safe version of Flash for your hardware... thus the dilemma.

     

    There really isn't a decent solution for you. Honestly, you would be taking great risks running an outdated version of Flash at this point anyway. There are known exploits out there that can and will take advantage of that to install malware on your machine.

     

    Note that silvergc's recommendation will not help you. Those directions involve disabling a feature of Mountain Lion, not any previous system, and that feature does not block a legit Adobe Flash Player installer anyway.

     

    I'd recommend moving further discussion of this particular issue to a new topic, as this topic is in the Mountain Lion forum, and thus is not the best place for finding answers relating to Snow Leopard on a PowerPC Mac.

  • thomas_r. Level 7 Level 7 (26,920 points)
    Currently Being Moderated
    Apr 4, 2013 3:43 PM (in response to leaudulac)

    Flash still doesn't work with Safari. It does work with Firefox and Chrome.

     

    Chrome includes its own copy of Flash, and is thus independent of whatever version of Flash you have installed.

     

    As for Firefox, though, it should be using the same Flash plugin as Safari. If Flash is working in Firefox, but not Safari, that indicates that you have a problem with Safari. Try going to the Safari menu and choose Reset Safari. Leave all options checked and click the Reset button. If that doesn't work, look in the Extensions pane of Safari's preferences... what's in there? Also, triple-click (to select) and copy the following command, then paste it into the Terminal (search for it with Spotlight if you can't find it) and press return:

     

    ls -al ~/Library/Internet\ Plug-Ins; ls -al /Library/Internet\ Plug-Ins

     

    What is displayed in the Terminal window after you do that?

  • thomas_r. Level 7 Level 7 (26,920 points)
    Currently Being Moderated
    Apr 4, 2013 6:54 PM (in response to leaudulac)

    Wow! You've got a LOT of internet plug-ins installed! That could very well be the source of the problem... there may be some conflicts going on there.

     

    I don't have Flash or Java installed, or any other third-party internet plug-ins. Here's what my results are:

     

    total 0
    drwx------+  2 thomas  staff    68 Jan  8 10:48 .
    drwx------+ 55 thomas  staff  1870 Apr  4 18:48 ..
    total 8
    drwxr-xr-x   6 root  wheel   204 Jan  8 10:40 .
    drwxr-xr-x+ 61 root  wheel  2074 Feb  2 09:15 ..
    lrwxr-xr-x   1 root  wheel    79 Jan  8 10:40 JavaAppletPlugin.plugin -> /System/Library/Java/Support/CoreDeploy.bundle/Contents/JavaAppletPlugin.plugin
    drwxr-xr-x   3 root  wheel   102 Jun 20  2012 Quartz Composer.webplugin
    drwxr-xr-x   3 root  wheel   102 Jun 20  2012 QuickTime Plugin.plugin
    -rw-r--r--   1 root  wheel  2394 Jan  8 10:34 nsIQTScriptablePlugin.xpt

     

    So, I have nothing in the Internet Plug-Ins folder in my user folder, and only four items in the one in the root level Library folder.

     

    I would suggest that you remove all but those, then reinstall Flash and see what happens. (Be sure to quit and restart Safari after doing that.) If that works, you can then reinstall any of the other plugins that you can't live without, one at a time from an up-to-date installer, testing for a while afterward to make sure everything continues working.

  • smsgator Calculating status...
    Currently Being Moderated
    Jul 5, 2013 5:57 PM (in response to leaudulac)

    I had this problem - turned out it was my preferences in Safari

     

    MENU:

    > Choose Safari

    > Preferences

    > Security

    > Check "Enable Plug-Ins"

    Then reinstall

     

    Hope this fixes the problem!

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.