Skip navigation

External hard drive "improper eject" after shutdown or sleeping

340 Views 3 Replies Latest reply: Apr 4, 2013 5:21 PM by rkaufmann87 RSS
DaytonaDave Calculating status...
Currently Being Moderated
Apr 4, 2013 9:14 AM

I have a 27", late 2012 iMac running OS X 10.8.3. I just changed my Time Machine external disk from a LaCie D2 (Lightning to Firewire 800 adaptor) to a larger Fantom GForce/3 (USB 3 directly into iMac. Not a hub.) No problems with the LaCie, it was just too small.  The Fantom drive is working fine as my Time Machine, BUT...every time the iMac sleeps or is shut down, when restarted it show the incorrectly ejected warning and the drive is gone from my desktop and disk utility app.  The drive is still on, but I have to turn it off and back on to have it reappear.  If I eject the drive before it sleeps or is shut down, it reappers on startup as it should. I see on some forums that users have been having this problem with some drives since at least 2009. I find it hard to believe that Apple and the hard drive suppliers haven't solved this problem.  I don't think I did anything wrong in reformatting the drive. There was no new driver or software with this drive. I did notice that the format is listed in the drive info as "Mac OS Extended (Case Sensitive, Journaled)". I never noticed the "Case Sensitive" before this. Is this a problem? Ejecting the drive before the machine sleeps is a pain, hard to remember and shouldn't be neccessary. I sure could use some help.

  • rkaufmann87 Level 8 Level 8 (40,500 points)

    First try doing a SMC reset. Instructions are found at https://discussions.apple.com/docs/DOC-3603 if that does not handle it then also do a PRAM reset. You shoudl probably do both at least 3x (they can be stubborn) and if they do not work please post back.

  • rkaufmann87 Level 8 Level 8 (40,500 points)

    The next thing I would Suggest trying is a Safe Restart. This will clear some caches, it is possible one or more is corrupt. To restart in Safe Mode hold down the Shift key when you hear the startup tone until you see a progress bar appear. Let the machine fully boot then restart normally and test.

     

    If that does not do it there are more things to try. Next would be creating another user account (call it TEST) and log into that acct. if the problem disappears the. You know it's a software issue related to your user account.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.