Skip navigation

QuickTime not recording sound

9355 Views 11 Replies Latest reply: Mar 7, 2014 5:02 AM by chillspike RSS
RonL Level 1 Level 1 (45 points)
Currently Being Moderated
Sep 22, 2012 8:57 AM

I'm running OS X 10.8.2 with QuickTime 10.2 and can't get the screen recordings to record audio.

 

I've tried all of the settings in System Preferences > Sound for both Output and Input and even have Soundlflower installed and have chosen those as options also, but I can't get the audio to record. Or that is... no matter what settings I use for Input... it ONLY records from my 27" iMac's internal microphone.

 

So... while recording the video that's playing on screen if I talk (to test it) the audio recording of my talking is fine... but no setting will allow me to record what the audio on the video is.

 

This didn't just begin in 10.8.2... I'm just finally getting around to posting about it because I'd like to occasionally record videos on the screen.

 

The videos record without a problem.

 

EDIT:  If I select Soundflower (16c) for the Input then the Sound preference pane displays the sound on the video is being recognized by the system (i.e. the Input level shows the bar changing from the audio in the video). But when I play the QT file back... no sound.

 

Any advice?

iMac, OS X Mountain Lion, 27" iMac, 32" secondary monitor
  • Kato419 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 13, 2012 6:06 PM (in response to RonL)

    RonL:  If I understand your question correctly, the pathetic comment is a bit harsh.  I have recorded both audio and video from a streaming webinar source.  Launch QuickTime Player. (I'm using 10.2) Under the File menu select "New Screen Recording"  A black rectangle will appear with a small inverted triangle on the right side.  You can't miss the black box.  Toggle the white inverted triangle and select to use the Built-in Microphone.  Worked for me.  You'll need to highlight the area of the screen you wish to capture, etc but here on in it's fairly self evident.  Hope this helps.

  • downeyt Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 19, 2013 5:28 PM (in response to Kato419)

    I agree with Kato419. Clicking the inverted rectangle brings up the sound options. I did not need an external program, QuickTime allowed me to record audio with my screen recording.

  • danallenhouston Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 4, 2013 6:06 PM (in response to Kato419)

    Hi, I am not sure if I understand the details of your instructions and the results you are getting. 

     

    When I record audio/video coming through my browser (example link) using the built-in microphone, the sound gets recorded, but if I talk, or the phone rings, or someone else talks during the recording, then the recording includes the sounds they are making.

     

    I don't see a way to get the sound into the recording except via sound waves between speakers and microphone.  I am thinking there should be a way for the sound get recorded without allowing input through the microphone.

     

    Any assistance would be extremely much appreciated.

     

    Thanks.

  • empofant Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 19, 2013 1:17 PM (in response to RonL)
  • Matt Tomlinson Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 13, 2013 9:37 AM (in response to RonL)

    All - I was able to replicate this issue in OS X 10.9 with Quicktime 10.3.

    The solution I found was to un-mute my speakers.  After that the screen recording with sound worked just fine.

  • chillspike Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 7, 2014 5:02 AM (in response to RonL)

    Try this: click on the apple in the far upper left of your screen. Choose "system preferences", then "sound", then "output". Look what selections are available there. For instance, I have Sound Flower on my Mac so both the 2ch and 16ch options are listed under "Output". I selected one (doesn't matter which one) in Output and then select the same one from the triangle drop down menu in quick time. I was having the same problem as you until I did this and it worked. I think it should work for you. Note: while recording you won't hear any sound from your speakers or headphones and you have to manually switch it back to speakers or headphones in "system preferences", "sound", "output" in order to hear the audio on playback. Good luck!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.