Skip navigation

No Network access: NSPOSIXErrorDomain:1

45155 Views 62 Replies Latest reply: Feb 4, 2014 7:57 AM by haroldp72 RSS
  • BDAqua Level 10 Level 10 (114,705 points)
    Currently Being Moderated
    Apr 14, 2012 7:11 PM (in response to Krithin)

    Hello, if it's different feel free to start a new question here & enumerate your problem.

  • MrSands Calculating status...
    Currently Being Moderated
    Aug 29, 2012 12:11 PM (in response to jbksm)

    For me it was a Norton Firewall. For some reason it had unilaterally decided to block all that was useful and necessary, which seems counter productive. I went to the Norton Firewall menu and enabled useful things that had been disabled and this did the trick. Most irritating as it took me a while to figure out.

  • TXbaby Calculating status...
    Currently Being Moderated
    Sep 1, 2012 8:46 PM (in response to jbksm)

    I had the same problem on my MacBook Pro while I was traveling.  I googled the problem on my mom's iPad and found this forum. I tried a lot of the previously mentioned troubleshooting, and nothing was working.  Now, I've just uninstalled Norton using the Symantec Uninstaller and am back online.  So, you may wanna try that first.

  • larryfromms Calculating status...
    Currently Being Moderated
    Sep 28, 2012 6:32 PM (in response to David Lee)

    Thanks for the valuable information regarding NSPOSIXErrorDomain:1. This helped clean-up an uninstallled app for me as well. Unfortunately, I spent much time with Apple Tech Support and doing re-downloads of Mountain Lion before finding your post.

  • Matthew T R Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 6, 2012 8:31 PM (in response to David Lee)

    This solved my issue exactly, thank you very much! I was going crazy, about buy a new wifi card  until I saw this!.

  • patrick61 Calculating status...
    Currently Being Moderated
    Oct 22, 2012 11:34 AM (in response to David Lee)

    This worked for me after a restart.

  • mlcpro Calculating status...
    Currently Being Moderated
    Dec 26, 2012 2:29 PM (in response to rodneyfrompueblo)

    This work for me Turn off a few things in Nortonand back on line!!!!

  • earlyusertoday Calculating status...
    Currently Being Moderated
    Jan 5, 2013 12:50 PM (in response to g san francisco)

    Thanks a lot for hint. Once you it right it works... :-)

  • Fringewood Calculating status...
    Currently Being Moderated
    Feb 7, 2013 4:26 PM (in response to earlyusertoday)

    The source of the problem is that a firewall is blocking net access to a small system application named  In Lion, it resides in (computer name)/(boot drive name)/System/Library/Staged Frameworks/Safari/WebKit2.framework/ .  If this app is blocked by any firewall, this NSPOSIX error will strike native Mac internet apps on whatever port or IP to which it is denied access by the firewall.  You only need to insure that it has free access to stop the error.  You don't need to take out your entire firewall's protection to cure your woes.

  • demisjohn Calculating status...
    Currently Being Moderated
    Feb 21, 2013 8:20 PM (in response to jbksm)

    Just in case anyone has this issue for specific sites, I was getting the same error in Safari (NSPOSIXErrorDomain:1) and in Chrome (Error 10: (net::ERR_ACCESS_DENIED): Unknown Error), which went away when I disabled X3Watch Pro (parental controls for internet access).  Again, for the the error only occurred on a specific website - all other websites worked fine. Also, the next day (no restart or anything, just sleep/wake overnight) the website worked fine with no problems, even with X3Watch enabled.  Go figure.


    I notified them of the issue.  I will keep it enabled unless I need to use this specific site.


    Thanks for all the replies - it helped me realize that parental controls were the issue.


    Message was edited by: demisjohn  (added specific Chrome error)

  • MACximize Calculating status...
    Currently Being Moderated
    Mar 18, 2013 8:57 PM (in response to jbksm)

    For me, the solution was to run the Intego Mac Premium Bundle 2013 and just uninstall Family Protector. That immediately solved the issue, no restart necessary. I then ran the installer again to install back Family Protector, all still worked.


    I don't know what caused this, put uninstalling fixed it!

  • lena54 Calculating status...
    Currently Being Moderated
    Mar 19, 2013 6:43 AM (in response to Fringewood)

    New Macbook running 10.8.2 and Safari 6.0.1

    Not yet installed any antivirus or firewall.

    Using Apple air network, internet connection on this and other machines is working (using a sat system that does have a firewall)

    I can't even see any system files in Finder anywhere, unlike my older Imac

    This is maddening. I may take it back to the store and keep my money.

  • demisjohn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 19, 2013 4:31 PM (in response to lena54)

    this does not solve your problem, but to aid you in your troubleshooting, you can see all the system files in their expected locations by using Finder's "Go..." > "Go To Folder..." menu item, and typing in



    /Library, /System/Library, /bin  etc.etc.


    These are also all visible using (if you know how to use that).

  • Don0555 Calculating status...
    Currently Being Moderated
    Apr 5, 2013 5:36 AM (in response to Fringewood)

    Hi, could you elaborate on how to deal with this please... 

  • pjfuller Calculating status...
    Currently Being Moderated
    Jun 20, 2013 11:51 AM (in response to jbksm)

    I fixed this, finally.  Took two minutes to fix....unfortunately, I spent many hours searching for the two minute fix.


    Essentially, Intego boobytraps their software if it is not uninstalled using their uninstaller, which is not easily found.


    So, if you've started deleting intego files already, re-install the software - best to do the bundle as a trial ( and then restart your computer.  If you cannot connect via your laptop (you will not be able to download this if you're accessing the web via recovery mode) download it onto a thumb drive from a different computer, and transfer the .dmg file to your affected computer and install it.


    Your connectivity is now fixed.


    Then, uninstall the file using the following file ( and you should be good to go.


More Like This

  • Retrieving data ...

Bookmarked By (2)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.