1 2 Previous Next 21 Replies Latest reply: Apr 6, 2013 9:40 AM by léonie Go to original post
  • 15. Re: Extreme Nightmare - Aperture Won't Open
    John Dunnigan Level 1 Level 1 (50 points)

    Hi again Leonie --

     

    Finally had the time tonight to get back to my Aperture nightmare. I was going to attempt what you suggested above. Here's what happened. I attempted to do a fresh backup of the Aperture library that had been giving me the original problems (had no issues over the last week backing it up. I'm not refering to the new library I set up as a test). The backup stalled and after just sitting there for about a half-hour my system crashed. I restarted just fine, Aperture detect a problem and seemed to Rebuild successfully. I then remembered an old trick about removing the com.apple.Aperture.plist. After doing that & restarting I got the window where it asks if I want to add my iPhoto library. That screen scared me so I shut down Aperture, moved the plist back to where it was and opened Aperture. Of course I got the same window, but this time I chose "create a new library". Everything opened fine and I could switch to my libraries without issue.

     

    THEN I noticed something interesting -- The thumbnail pane was on the bottom in a single row and all of the thumbnails were visible! However, when I switched to multiple rows many of the thumbnails disappeared. Also, when switching the thumnail window so that it showed along the side of the screen (how I normally like to work) I got the same result -- Thumbnails in single column were all visible. However, if I switched to multiple columns many would again disappear.

     

    I figured I could deal with having thumbnails in a single column and decided to attempt a backup again. Again Aperture stalled and my system eventually crashed. Restarted everything and this time created a new backup. Again Aperture stalled and my system crashed. Problem now is that I can't even make a backup of my Aperture library. Now I'm really stuck!!!!

     

    Any ideas?

     

    Sincerely,

     

    John

  • 16. Re: Extreme Nightmare - Aperture Won't Open
    firstlaunch Level 3 Level 3 (610 points)

    If your thumbnails are not appearing, did you try selecting them and then selecting generate thumbnails from the Photos menu. I suggest doing a repair of the library as well.

     

    If backup up keeps crashing, maybe you can try another drive to back up to. Are you low on disk space on your main machine?

  • 17. Re: Extreme Nightmare - Aperture Won't Open
    léonie Level 9 Level 9 (51,710 points)

    What type of Mac are you working on? You never answered my original question about details of your system. Your profile signature lists "Mac Pro, Mac OS X (10.6.5), MacBook Pro, iPhone, iPad, AppleTV"

     

    Are you working on your MacPro or MBP? How large is the system drive you are using? And your MacOS X version is 10.8.2? This is starting to look like system trouble and not a question of a broken library, so it would be good to be able to look for similar cases on similar systems.

  • 18. Re: Extreme Nightmare - Aperture Won't Open
    John Dunnigan Level 1 Level 1 (50 points)

    Leonie --

     

    Sorry, I'm on a Mac Pro 1,1 (origianl Intel Mac Pro) running 10.7.5 (I cannot upgrade to Mountain Lion on this system). Hard drive is 2 TB with about 503 GB free space, 8 GB RAM. The inabilitiy to perform backup or create a new vault and successfully back that up is a new problem.

     

    firstlaund --

     

    Yes, I've attempted all of that -- Attempted to generate thumbnails individually as well as entire Project at one time. Performed Repair, Rebuild and Restore several times with no luck.

     

    John

  • 19. Re: Extreme Nightmare - Aperture Won't Open
    John Dunnigan Level 1 Level 1 (50 points)

    Leonie --

     

    Okay, attempted another backup just for the heck of it (quit all applications except Aperture. Then just for the heck of it I quit Aperture and reopened just Aperture). Backed up successfully in literally about 2 minutes -- Didn't hang like it did last night for some reason). I think that if a new Mac Pro comes out sometime this year (sooner than later, hopefully) I'll be getting one and performing a clean install of everything (As you've probably noted, my system is pretty old). Don't know how to perform a clean install but I'll research that when the time comes. I've thought about getting a fully loaded iMac, but the overheating issues I've read about make me nervous. Still, I'm wondering if in the meantime perhaps I should install a larger internal hard drive and perhaps beef up my RAM to 12 or even 16 GB.

     

    John

  • 20. Re: Extreme Nightmare - Aperture Won't Open
    léonie Level 9 Level 9 (51,710 points)

    Backed up successfully in literally about 2 minutes -- Didn't hang like it did last night for some reason)

    Good, so you have a backup again.

     

    Ask about the clean install when you are about to get your new mac. Keep to backups of everything, best a bootable clone. Take a note of all serial numbers you might need, and make sure you have installers for all applications.

     

    I just notice, I forgot to comment on that part from your earlier post:

     

     

    I restarted just fine, Aperture detect a problem and seemed to Rebuild successfully. I then remembered an old trick about removing the com.apple.Aperture.plist. After doing that & restarting I got the window where it asks if I want to add my iPhoto library.

    Removing the plist file will erase Aperture's memory of the settings and recent items. It does no longer know the location of the Aperture library. That is why you saw the question which library to use.

    If your library is not in the Pictures folder and simply names Aperture Library, Aperture will create a new library by default. After erasing the plist it is best to launch Aperture by clicking the library.

  • 21. Re: Extreme Nightmare - Aperture Won't Open
    léonie Level 9 Level 9 (51,710 points)

    Still, I'm wondering if in the meantime perhaps I should install a larger internal hard drive and perhaps beef up my RAM to 12 or even 16 GB.

    If your drive is already 2 TB I would not put in a larger drive right now. Mt. Lion seems to have problems with larger system drives. More RAM might be useful, but you can test if you have a problem with too few RAM by launching the utility "Activity Monitor". It will show you the memory usage of the running applications and by clicking the column headers you can sort the applications by memory demand.

1 2 Previous Next