Skip navigation

Cannot connect to AirPlay any more (AirPort Express)

30014 Views 42 Replies Latest reply: Mar 23, 2014 11:05 PM by skidemn RSS
  • alkie4life Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 22, 2012 8:31 AM (in response to pkmusic)

    It's definately a problem with iTunes and not the Airports.  I have this exact same issue that I just found last night when I was trying to stream from iTunes.  I can stream from my iPad and iPhone directly to the Airports without issue.

  • robot_dan Level 1 Level 1 (5 points)

    I too was having trouble getting iTunes to connect to my old Airport Express 802.11g - it would sit there saying "Connecting..." for a few minutes and then give up without any error messages. I tried restarting my computer, my Airport, my router, iTunes, etc., but nothing seemed to work.

     

    The frustrating thing was that Airplay was working fine from my iPad and iPhone.

     

    The final thing that seemed to fix it was to go to the terminal and type in:

    networksetup -setv6off Wi-Fi

     

    Once I did this, then iTunes connected almost immediately to my Express!

     

    I was also able to go back into the Network Settings and turn IPv6 back on to 'Automatic', and everything is still working.

    MacBook Pro (15-inch 2.4/2.2 GHz), OS X Mountain Lion (10.8.2)
  • GJM Ohio Level 1 Level 1 (0 points)

    I found this: http://mactips.dwhoard.com/mactips/other-applications/fix-airplay

     

    Apple, really, it just "works"......

  • Ewout2211 Level 1 Level 1 (0 points)

    Thanks, it works!

    I had the same problem: connect to airport/atv from ipad/iphone was no problem, but from itunes on my MBP seems not to work anymore...

    turning off ipv6, restart itunes and atv/airport, and it works...

  • DenisV Level 1 Level 1 (0 points)

    I had the same problem and the method in this link seems to have sorted it, although I had to twice force quit iTunes adn restart the mac mini after doing the Terminal commands, as iTunes went completely unresponsive.

     

    Thanks a lot!

     

    Where is Apple input to this?

  • FreshLemongrass Level 1 Level 1 (0 points)

    GJM Ohio wrote:

     

    I found this: http://mactips.dwhoard.com/mactips/other-applications/fix-airplay

     

    Apple, really, it just "works"......

     

     

    Thank youuuuuu!!!!!!!

     

    After so many months of trying to get it to work - and giving up upon it - and now investing another hour of research - it finally works!!!!!!!! in just a couple of minutes!!!!!

     

    Even though I was a little scared about changing something with a terminal window, which I have never done before and didn't know what kind of damage I was going to do, it was so easy!

     

    To everyone else - don't give up and dont be scared - it is easy!

    Just search the Terminal window, and copy paste directly after the first line.

     

    TerminalWindow.gif

     

    (and as you can see, I couldn't turn off the Ethernet - only the Wi-Fi)

     

    Works brilliantly!!! Thank youuuuuuuuuu!!!

     

  • Sajmani Level 1 Level 1 (0 points)

    Thanks!  Using the Airport Utility to set IPv6 to "Automatically" on my Airport Express fixed the issue.

  • Advocate DaveLs Level 1 Level 1 (0 points)

    Turning off the IPv6 in wifi really does work.  I've experienced the same problem on my MacBook and iPhone and iPad.  After typing in the command, it immediately started playing music on my Airport Express speakers.  Thank you for the tip!

  • Peter Knox Level 1 Level 1 (5 points)

    Yep, worked here as well. g version of the Express, latest version of Lion on an older 2006 intel iMac. Before turning IPv6 off through terminal on iMac, I tried connecting to the Exp from iTunes on a 2010 MBPro running the latest Mtn Lion and had no issues whatsoever.

     

    Thanks for the fix!

  • SammyFro Level 1 Level 1 (20 points)

    OK, this was confusing but I found the way to change iPv6 with an older airport express, to get Airplay to stream through itunes and to the Airport Express.

     

    My network is as follows:

    1. Airport Extreme Base Station.

    2. Airport Express (older version) 802.11g version 6.3.

     

    I had downloaded the older airport utility 5.6.1 (the new one doesn't work with the older Airport Express) and both the Airport Extreme and Airport Express had the green dot, showing both were working. I opened the Airport Express using "manual setup" on the bottom left.

     

    1.jpg

     

    But under advanced tab in the Airport Express did not find anything related to iPv6.

     

    2.jpg

     

     

    However, and this is the key, I switched to the Airport Extreme Base Station. Under the Advanced tab of the Airport Extreme, the third menu item is IPv6. I set this to "Host" and the configure dialogue box popped up as "automatically" so I left it. I pressed "update," the two modems reset within 2 minutes.

     

    3a.jpg

     

    I relaunched iTunes 11.0.2 and then clicked the network setting and checked my Airplay network.

     

    4a1.jpg

    And everything worked. LIstening to some nice Art Blakely & the Jazz Messengers through Airplay.

  • Chubbs4U Level 1 Level 1 (0 points)

    Robot dan that worked and I thank you.

  • ThommieG Level 1 Level 1 (0 points)

    I'm running OSX 10.6.8 on a MacBook Pro, iTunes 11.0.2, Airport Utility 5.6.1, and an Airport Express set at 802.11g with Version 6.3. Airplay was working fine for a week and then all of a sudden I was unable to connect to a set of Airplay speakers with the (-15006) error. Quit everything and launched Airport Utility and checked the Interference Robustness box and voila up and working again. Then the next day same problem so went back in and unchecked the Interference Robustness and guess what, it is working again. I know this is a simple fix, but it worked for me. If the problem continues and I have to keep going back in to check and uncheck the box or if after a while this simple fix doesn't work I will use the previous postings more complicated method.

  • skidemn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 23, 2014 11:05 PM (in response to SammyFro)

    Thanks SammyFro!  I have the same setup and this fixed my problem.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.