Skip navigation

Major UI Lag in Logic Pro 9.1.7 on OS 10.8?

65181 Views 888 Replies Latest reply: Mar 31, 2014 1:50 PM by The Art Of Sound RSS Branched to a new discussion.
  • Phee The Emcee Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 10, 2013 9:53 AM (in response to The Art Of Sound)

    are any of you running a cuda driver for your video card?

  • The Art Of Sound Level 5 Level 5 (5,670 points)
    Currently Being Moderated
    Apr 10, 2013 10:22 AM (in response to WindowsME)

    WindowsME..

     

    It could be that one of the delta updates did not install correctly or was missed during the update process.. or a different update version was applied somewhere in the past.... . Little things like that can and do change things dramatically...

     

    (Delta updates are updates that do not replace the entire app or routine that is being updated but only replaces a part of the app or routine... which decreases the total download size of the update)

     

    Apple switched to using Delta updates a while back and it seems sometimes different or incomplete or corrupted ones get installed which can cause issues down the road...

     

     

    Just for further info on these types of problems...

     

    Another example of this type of issue was the Prokit Issue a while back... when some people got one version of the Prokit installed and others got a different version installed and those that got the different version then had for example.. an issue saving in Logic... or Logic would crash unexpectedly when the user tried to save/load a project.... until they manually downloaded and installed a new replacement version of the Prokit that then fixed their issue. Using the automatic update feature in OS X did not fix the problem.. The User had to manually download and install a fresh copy of prokit to resolve the problem..Apple never truly explained how this could happen but happen it did and caused all kinds of problems that still go on today....

     

    Here is a link to a thread relating to the Prokit issue...

     

    https://discussions.apple.com/thread/3155576?start=0&tstart=0

     

    and here is a link to one of the reports on how to fix it..

     

    http://reviews.cnet.com/8301-13727_7-20096767-263/a-fix-for-logic-crashing-in-sn ow-leopard/

     

    Note: many people never had this issue... nor even heard about it because, as like the GUI Lag problem.. not everyone is affected... and so those not affected never had to go through this process to fix it... but for the group of people who did have this issue, it was a nightmare, similar to the one going on at the moment with the GUI lag..

     

    Finally,. here is the official Apple Support link for the Prokit fix...

     

    http://support.apple.com/kb/TS3968

  • Pancenter Level 5 Level 5 (7,505 points)
    Currently Being Moderated
    Apr 10, 2013 10:47 AM (in response to The Art Of Sound)

    While it may not be a hardware issue, I always thought the lag appeared after Retina support was added to the OS.

     

    At one point a third party plug-in manufacturer I know thought the lag could be traced to the version of firmware the machine in question was running.

  • fluffy Level 1 Level 1 (25 points)
    Currently Being Moderated
    Apr 10, 2013 10:55 AM (in response to Pancenter)

    Nope, for me anyway the lag appeared with OSX 10.7, both on my existing MacBook Pro and on my fresh install on my new Mac mini.

  • The Art Of Sound Level 5 Level 5 (5,670 points)
    Currently Being Moderated
    Apr 10, 2013 11:14 AM (in response to Pancenter)

    Pancenter...

     

    A couple of people reported on LPH that they had this issue over 3 years ago... prior to Retina... with 10.6.8 when it first was released... Read into that what you will....

     

    Personally I'm taking it with a pinch of salt myself because I have only seen it occuring with Lion and ML based systems...and not with any Mac running SL... but it is possible I guess... and the situation has affected more people since the various OS X upgrades have taken place...

     

    *shrug*

     

    It has always 'smelt' to me like a driver/library routine/OS X issue of some sorts much akin to the Prokit issue which is why I often compare the two events as to me they do have striking similarities... in how they seem to affect different though identically configured Macs seemingly at random and there is no clear explanation as to how this issue has come about in the first place...

  • Pancenter Level 5 Level 5 (7,505 points)
    Currently Being Moderated
    Apr 10, 2013 11:11 AM (in response to fluffy)

    fluffy wrote:

     

    Nope, for me anyway the lag appeared with OSX 10.7, both on my existing MacBook Pro and on my fresh install on my new Mac mini.

     

    Ummm 10.7.x supported Retina.

  • Pancenter Level 5 Level 5 (7,505 points)
    Currently Being Moderated
    Apr 10, 2013 11:14 AM (in response to The Art Of Sound)

    The Art Of Sound wrote:

     

    Pancenter...

     

    A couple of people reported on LPH that they had this issue over 3 years ago... prior to Retina... with 10.6.8 when it first was released... Read into that what you will....

     

    I always thought that was a different issue and related to the "losing focus" problem and not the type of lag that exists say when opening the channel eq in hi-res analyze.

  • fluffy Level 1 Level 1 (25 points)
    Currently Being Moderated
    Apr 10, 2013 11:15 AM (in response to Pancenter)

    Ummm not in August 2011 when it first came out, which was when I first started having this issue.

  • The Art Of Sound Level 5 Level 5 (5,670 points)
    Currently Being Moderated
    Apr 10, 2013 11:17 AM (in response to Pancenter)

    *nods* and thats another part of this.. I too, think there are two distinct issues which some people clump together as one big issue..... and call it GUI Lag.... which makes it hard for others to differentiate... between the two.

  • fluffy Level 1 Level 1 (25 points)
    Currently Being Moderated
    Apr 10, 2013 11:20 AM (in response to fluffy)

    Er, no, in July 2011. https://discussions.apple.com/thread/3226612?start=0&tstart=0

     

    And hey, look who was the very first person to reply back on that original thread!

     

    If you had a Retina Mac back then I'll be very impressed.

  • The Art Of Sound Level 5 Level 5 (5,670 points)
    Currently Being Moderated
    Apr 10, 2013 11:22 AM (in response to fluffy)

    I think what Pancenter is refering to (and if i am wrong then tell me to shut up Pan....) is that Lion from day one, had Retina code built into it.... even if it wasn't being used by the hardware....

  • Pancenter Level 5 Level 5 (7,505 points)
    Currently Being Moderated
    Apr 10, 2013 11:23 AM (in response to fluffy)

    fluffy wrote:

     

    Ummm not in August 2011 when it first came out, which was when I first started having this issue.

     

    We really don't know when "support" was added to the OS do we.

     

    The iPhone 4 w/Retina display was released on June 24, 2010, (iOS) and you can bet that development had been going on long before that including for OSX. Possibly as early as 10.6.x.

  • Pancenter Level 5 Level 5 (7,505 points)
    Currently Being Moderated
    Apr 10, 2013 11:24 AM (in response to The Art Of Sound)

    The Art Of Sound wrote:

     

    I think what Pancenter is refering to (and if i am wrong then tell me to shut up Pan....) is that Lion from day one, had Retina code built into it.... even if it wasn't being used by the hardware....

    Yes exactly and possibly even earlier.

  • The Art Of Sound Level 5 Level 5 (5,670 points)
    Currently Being Moderated
    Apr 10, 2013 11:37 AM (in response to Pancenter)

    One of the first reports as to Lion Betas supporting Retina display modes was published by Macrumors in Feb 2011

     

    http://www.macrumors.com/2011/02/24/mac-os-x-lion-building-in-support-for-super- high-resolution-retina-monitors/

     

    and that the built in OS X support for 'resolution independant' displays goes back several years before this.... A long time before the hardware itself was available...

  • Pancenter Level 5 Level 5 (7,505 points)
    Currently Being Moderated
    Apr 10, 2013 11:52 AM (in response to fluffy)

    All of the extra graphic layers, transparencies, independent display resolutions, Retina support, eye candy...etc, may come at a price.

     

    Anyway, it's all conjecture..  I had just noticed reports of the lag appearing very close to the release of Retina support.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (8)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.