Skip navigation

No FireWire on G5

327 Views 7 Replies Latest reply: Apr 11, 2013 11:49 AM by Raucousdog RSS
Raucousdog Calculating status...
Currently Being Moderated
Apr 11, 2013 8:38 AM

Hi, I have an early 2009 G5 that I have recently upgraded to OS X 10.8.3.  I have also installed an external eSATA drive.  Now, I can't get any of my FireWire devices to work.  They show up in the System Report under the FireWire Bus, but FCP and Garage Band do not recognize them.  I have restarted the computer many times, reset the PRAM, tried every port, switched cables.  Everything was working fine before the OS and eSATA upgrades.


Please, help!

Mac Pro (Early 2009), OS X Mountain Lion (10.8.3)


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.