6 Replies Latest reply: Apr 14, 2013 1:13 AM by léonie
cormacfromvic Level 1 Level 1 (0 points)

Hi All,

 

Ok, here's the scenario: Until a few days ago I was using an old MacBook (circa 2006, the black one) with Aperture 2 with a refernced library (about 400 gig in size), stored on a Lacie Rugged Safe drive.  Then, I bought a new MBP (15 inch, 2.7GHz, 512Gig SSD, 8G RAM, OSX 10.8.3) and installed latest Aperture. 

 

So, it's the dawn of a new era for me and Im excited to get off my antique machine....so,  I attached the library to the new machine, opened Aperture and received a dialogue box saying I need to 'upgrade' my library to work in the new version of Aperture (and that the upgraded library wont be able to be used on old Aperture). Fair enough, I click Ok, and it starts the process. It gets through 2% and then freezes(!) 

 

The only way I know of to un-freeze the situation is to force quit Aperture via finder and try it again.  This worries me as it could happen again and perhaps the library is being damaged in the process? Or perhaps is already damaged, which is why it's freezing?** Also, I dont want to keep going through this process as it is very time consuming (imagine next time it gets spends hours and gets through 85% of the library, then freezes).

 

**Note, I have not had any problems with the old set-up (can access, export, adjust etc all images from all projects), except that if I left Aperture unattended for even the shortest amount of time, it would freeze and I would always have to force quite and start again.

 

For the record, I updated a vault of the library onto a separate Lacie Rugged Safe Drive using the old version of Aperture and on my old Mac before attempting to open new Aperture on the new Mac and going through with the upgrade. And I made a copy of the library to another drive (just a straight copy using Finder, not a vault or carbon copy), so I have backup.

 

I am also concerned that if I had to (in the meantime) go back and use my old aperture/old mac set-up to get some work done while I sort this out, that the 2% that was upgraded will not be available (as per the warning message from Aperture that upgraded libraries will not work on old versions of aperture).

 

Should I just force quit and try again. And when I try again, does anyone have any advice for making sure the upgrade process goes smoothly?

 

Thanks so much!

 

Cormac


Aperture 3, OS X Mountain Lion (10.8.3), 15inch MBP, 2.7Ghz i7, 8GRAM, SSD
  • 1. Re: Upgrading & Updating library issue....
    léonie Level 9 Level 9 (51,720 points)

    Cormac,

    the upgrade may take a very long time, depending on the size of the library. For very large libraries it may take days.

     

    But if you can start over with a copy of your Aperture 2 library on your old system, I'd recommend to do that. If you can, repair your Aperture 2 library usind Aperture 2 before you try to upgrade to Aperture 3,

    see the "Note on Upgrading" the last paragraph in the Aperture 3 Release notes. http://support.apple.com/kb/TS2518

     

    It is essential that your Aperture 2 library is in top condition and does not have any problems before you do the upgrade.  If you can no longer do the "Repair" in Aperture 2, try to repair in Aperture 3, before you you do the upgrade. To repair a library, hold dow the Option-key and command key at the same time, while double-clicking the Aperture library.

     

    Regards

    Léonie

  • 2. Re: Upgrading & Updating library issue....
    cormacfromvic Level 1 Level 1 (0 points)

    Hi Leonie,

    Thanks for the advice...sounds like a good idea....just hope library works back on the old machine/aperture.

     

    Meanwhile, the attempted upgrade on the new machine has now crept along to 3% complete (yeah, somehow it's not frozen anymore - just moving at a glacial pace)...

     

    Still, I must decide whether to pull the pin on it, follow your advice and go back to Ap2 on the old machine and rebuild to debug....or let sleeping dogs lie and watch it creep along like a snail; 3% after around 6 hours...could be days, maybe weeks!  Given i work as a photographer, Im probably going to need to take action before then....but at the risk of hurting the library....not an easy decision.

     

    wish me luck!  Will let you know how it pans out.

     

    Best,

    Cormac

  • 3. Re: Upgrading & Updating library issue....
    léonie Level 9 Level 9 (51,720 points)

    creep along like a snail; 3% after around 6 hours...could be days

    The progress bar is not very reliable - as long as it is not frozen let it run. The percent numbers usually are totally wrong, and you cannot really predict the estimated time of completion from it.

     

    How large is your library?

  • 4. Re: Upgrading & Updating library issue....
    cormacfromvic Level 1 Level 1 (0 points)

    Hi Leonie,

    Ok, will let it run....probably for the best (now up to 8%, but as you say, who knows what that really means)...

     

    Not sure exactly how many images in the library, but it occupies about 350Gig, mostly RAW images from a NikonD700.

     

    Cheers!

    Cormac

  • 5. Re: Upgrading & Updating library issue....
    cormacfromvic Level 1 Level 1 (0 points)

    Hey Leonie,

     

    Just wanted to update you....

     

    Left it running over night again and everything seems OK now....was slow but got there in the end and my library is available and working (Phew!). Thanks for suggesting to just let it run, as I probably would have aborted during the inital 'freeze' period when the colour wheel just kept spinning...

     

    Do you have any advice for keeping the library as healthy as possible in the future? (Is there any risk when conducting a rebuild that the library will be damaged in the process?)...

     

    Thanks

    Cormac

  • 6. Re: Upgrading & Updating library issue....
    léonie Level 9 Level 9 (51,720 points)

    Great!

    Thanks for suggesting to just let it run, as I probably would have aborted during the inital 'freeze' period when the colour wheel just kept spinning...

    I learned that from Kirby Krieger. He has really gigantic libraries, and he reported, that one particular upgrade took more than one day.

     

    Do you have any advice for keeping the library as healthy as possible in the future?

    Here goes - some basic rules to keep Aperture 3 happy - they are the same as with Aperture 2.

    • Always make sure that the Aperture library is on locally connected drive formatted MacOS X Extended (Journaled). Don't move the library to a network volume (google store, dropBox).
    • Give Aperture time to properly close all database transactions; don't force quit Aperture. That may create inconsistent database entries, see:

                          If Aperture is unresponsive, how to avoid force quitting?

    • If Aperture crashed, use "Repair database" immediately.
    • Aperture is still a single user database. Don't access the Aperture Library from two machines at the same time or over a network.
    • Don't modify the original master image files using the Finder, even if they are referenced.
    • Don't import media, that Aperture cannot handle - image files larger than 1 GB, videos with unsupported codecs, image files with filenames that contain invisible characters,...
    • Keep backups of the library.

     

    (Is there any risk when conducting a rebuild that the library will be damaged in the process?)...

    If your library is in a good condition, no. Rebuilding is a major reconstruction, just like upgrading, but still, it is a routine measure. But we all agree, that you should never try a rebuild, before making a backup first or updating your existing backup.

     

     

    Good Luck with Aperture 3!

     

    Léonie