Skip navigation

Attachments sent from Mail do not show up in Outlook

62781 Views 91 Replies Latest reply: Dec 30, 2013 10:52 AM by Jhornby RSS
  • Neville Hillyer Level 4 Level 4 (1,845 points)
    Currently Being Moderated
    Oct 22, 2012 3:50 AM (in response to bill170)

    This is not the place to report bugs to Apple.

     

    I have done a few more tests with Mail 3.6 on Leopard.

     

    My Mail previously ignored some  preferences. Deselecting and reselecting Edit/Attachments/Always Send Windows-Friendly Attachments and Edit/Attachments/Always Insert Attachments at End of Message changed behaviour. It now 'attaches' after  body text but only if body text already exists - clearly a glitch. I have never been able to attach anything without the existence of body text - another glitch. It is still possible to type after the attachment - another glitch.

     

    A further glitch is that these attachments are still sent as 'Content-Disposition: inline' rather than 'Content-Disposition: attachment'. I suspect it is this which causes some Windows mail clients difficulties.

  • ParksCreative Level 1 Level 1 (0 points)

    SOLUTION: I am a commercial photographer and had this problem. Solution: Mail-Preferences-Composing-Message Format-Plain Text  (and don't use colored text in copy or signature)

     

    The images are getting embedded because Apple Mail is turning the email into “Rich Text” (= HTML email). So when you attach a JPG, Mail generates a tag for that image, thus embedding it into the email itself. Applications other than AppleMail object to this. This can happen if a signature has colors in it. You can avoid this easily by just using Plain Text emails. (Apple needs to remedy this long-standing and common Mail issue.)

     

    Note: if you were to attemp to BOLD text in your email, it will ask you to "convert to Rich Text", to which you must say NO, or again JPGs embedd.

  • Neville Hillyer Level 4 Level 4 (1,845 points)

    With my Mail 3.6 set to Plain Text I have been unable to send images other than inline. Perhaps this has been corrected in later versions of Mail.

     

    It would be useful to see the received source (see my earlier posts) originating from any version of Mail which attaches rather than embeds image attachments.

  • Nickiwi Level 1 Level 1 (15 points)
    Currently Being Moderated
    Apr 10, 2013 11:07 AM (in response to jk10003)

    Yes it happens with Outlook Express, with NO Exchange server in the way, just a "normal" ISP, the same one as I use on my Mac with Mail under Mountain Lion.

  • Nickiwi Level 1 Level 1 (15 points)
    Currently Being Moderated
    Apr 10, 2013 4:54 PM (in response to Nickiwi)

    Take a look at thread https://discussions.apple.com/thread/4077348?start=15&tstart=0

    for some reasons and solutions.

     

    Many thanks indeed to Neville Hillyer for your detective work as to what is causing this problem.

    It seems that Apple expects that all other mail clients out there will automatically comply with what is probably in the standards somewhere and gives no option to make things easier for people on other systems with perhaps older software.

    At least Thunderbird seems to work, in that Thunderbird on my Mac machine can attach a picture that will be correctly opened by Outlook Express but it is no more able than Outlook Express to open a picture attached to an Apple Mail message.

     

    Enclosing images in a folder and attaching that; compressing the picture; and ending the message with an empty folder all work. Probably the last method is the least bothersome to use, though I have yet to test "Attachment Tamer" and "Zip Files for PC" for ease of use.

     

    Also, in my case, rich or plain text seems irrelevant.

     

    Lastly I join my voice to those who are screaming for a solution from Apple - this business is driving my wife nuts, as she is constantly exchanging pictures with PC users, and all she wants is easy-to-use efficacity which we all thought Apple stood for.

  • elbacutting Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 11, 2013 7:03 PM (in response to mrh_ucd)

    What did you do to send an attachment from a mac to a PC??

     

    Thanks

  • Nickiwi Level 1 Level 1 (15 points)

    When drafting a message in Apple Mail, I click on the "attach" icon at the top of the message window, which opens a Finder window for me to choose the file(s) I want to send. Then I send the message to my correspondent. But if they are on a PC, or even using Thunderbird on a Mac, they only see a distorted version of the attachment embedded in the message, and it is not possible to click on it and save it - sometimes it just doesn't seem to be there at all.

     

    However zipping the file(s) or including them in a folder before attaching (which forces compression of the contents) or adding an empty folder at the end all cause the files to be transmitted correctly and visible on a PC.

     

    An easier way is to buy the excellent "Attachment Tamer" plug-in for Apple Mail. It works and since I have installed it my correspondents with PCs have had no problem opening and saving what I send them.

  • cartog Level 1 Level 1 (0 points)

    Hello Neville

    Rertired yet? Been 9 years for me now.

     

    I had trouble a while ago seeing attached both sent and received attachments in Mail. Maybe the below solution remedies them showing up in Outlook?

     

    John

     

    1 - Create a rule in the Mail Preferences pane

    2 - Call it "Get My Paperclip Icons Back!"

    3 - Set conditions as below :

    A - If ALL of the following conditions are met :

    B - From Ends With [Your email address here]   (you can do this for multiple too]

    C - Any Attachment Name Contain "."  [with the quotations around the dot]

    Perform the following  actions :

    D - Mark as Read  [which really makes no impact on how its viewed]

     

    Click Ok.  When message "Do you want to apply your rules to messages in selected mailboxes?" I chose "Dont Apply".  [But you can click "Apply" if you are in the "Sent Folder"

     

    Then go to your sent folder, Select your messages [recent/all], and right click "Apply Rules" or from the menu Message -> Apply Rules.

     

    Voilla!  Paperclip icons are back.  Plus "Mark as Read" did no harm to your already colored/flagged sent emails.

     

    Hope this helps!

  • jcapps0 Level 1 Level 1 (10 points)

    I think Apple needs to come to terms with the fact that Microsoft and Adobe exist and will continue to until **** freezes over.  So get this email and video crap fixed in all Apple products.  I recently changed completely to Apple and with stupidity like this I feel like dumping $7000+ of Apple equipment on the front counter of an Apple store and demanding my money back. 

     

    This is stupid!  Get over it.  Apple is not going to take over the world.

  • stevefromgladstone Level 1 Level 1 (0 points)

    Klaus, can I have some of what you are smokin?

     

    It is an APPLE MAIL PROBLEM.

  • stevefromgladstone Level 1 Level 1 (0 points)

    Thanks Apple,  you've forced me to work with Outlook.  It is YOUR FAULT.  I'm tired of updating a third party software, just to work with your software.

     

    I bet Lokiware's Attachment Tamer hopes you don't change things with your mail program, because he'd be out of business.

     

    Shame on you Apple.  PC's dominate the world for OS.  Until you overtake that, comply.  Just like the way you force people to comply with your ways.

  • Tournesol66 Level 1 Level 1 (0 points)

    Hi Steve,

     

    I have now up-graded to OS-X Maverick, and all these problem which earlier was in the Mail Client seam to be solved.

     

    Try and up-grade - and you will find your mails behave "normal" with the attachments

  • Sazzarocksdahouse Level 1 Level 1 (0 points)

    I'm on a new Macbook and have just upgraded  to Mavericks but I'm having the problem that .jpg files that I'm sending as attachments can't be saved by the Outlook user I'm sending them to, even though he can see the images in the email.

     

    As a relatively new Mac user it seems silly that such a basic thing should be a problem.

  • cartog Level 1 Level 1 (0 points)

    Have you tried ctrl click on the image and making it an icon before sending?

     

    John

  • eyehop Level 1 Level 1 (20 points)

    I am very familiar with this issue and the history of it. It is only corrected by getting Attachment Tamer Pro (http://lokiware.info/Attachment-Tamer). It does not depend on plain text vs rich text, jpg vs png, 'windows friendly attachments' being checked, etc., etc. So don't waste your time like I did trying to find rational causes and effective work-arounds. The cause is Apple's unwillingness to do something about it, probably due to a puritanical standards-based attitude, rather than helping their own customers who have to deal with the drugery of working with Windows users on a daily basis. Here is the feedback page for Mail: http://www.apple.com/feedback/mail.html

1 ... 3 4 5 6 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.