Skip navigation

2012 iMac OS 10.8.3 Wifi dropping

3875 Views 15 Replies Latest reply: Aug 19, 2013 1:18 AM by SleeveMonkey RSS
1 2 Previous Next
Mr G Almighty Calculating status...
Currently Being Moderated
Mar 30, 2013 6:29 AM

Hey all,

 

I've been having this problem for a few days now and it's becoming more and more frequent so now I'm really struggling to find help anywhere.

 

Basically after a while for no apparent reason my WiFi will stop working with the error message "DNS Server not responding" or something like that, and all my internet activity ceases. Turning off and turning back on the WiFi solves the problem temporarily but doesn't fix it completly. I'm using a Belkin N+ Wireless Router and a Virgin Superhub in Modem mode.

 

When my internet connection drops I cannot ping my router and I cannot ping google.com.

 

Here's what I have tried so far:

Renew DHCP Lease

Rebooting Router

SMC Reset

Rebooting computer

Virus Scan (Don't ask why)

Uninstall Hamachi

Replace Mackeeper with Avast

Software Updates

Jigging the network settings (proper service list order, adding a new location all that stuff)

 

A couple of ideas I'd like to try but I'm not sure about:

Changing the DNS on my iMac

Changing the DNS on my router

Seeing if the connection works on my Bootcamp partition.

 

That's really everything I know, I know that when this happens no-one else on the network experiences any problem at all. Up until this started happening this had never happened before, I hadn't installed any new software and I didn't do any updates when this started happening everything installed and uninstalled happened after this started happening

 

This is really frustrating and it's making my work alot harder any help would be appreciated

 

Thanks,

- Mr G

iMac (21.5-inch Mid 2011), OS X Mountain Lion (10.8.3)
  • Ralph Landry1 Level 7 Level 7 (28,815 points)
    Currently Being Moderated
    Mar 30, 2013 6:40 AM (in response to Mr G Almighty)

    First problem is use of anything such as MacKeeper or Avast...there have been regular problems reported on here with that kind of software...and MacKeeper is very hard to remove, it places files in hidden locations that are not removed by the uninstaller.  You need to thoroughly cleanse the system of MacKeeper and Avast.

     

    Second, when you say you did a router reboot did you disconnect the power to the router?  The DHCP daemon has to completely stop and many routers do not power down on the power button but go to standby.  The DHCP daemon does not restart properly under those conditions.

     

    Power down all devices and disconnect power to the router.  Wait ten minutes or so and then restart the router and give it a few minutes to capture the initial IP address and stabilize.  Then startup the connected devices one at a time giving each a few minutes to establish their IP address and stabilize.

  • Ralph Landry1 Level 7 Level 7 (28,815 points)
    Currently Being Moderated
    Mar 30, 2013 6:51 AM (in response to Mr G Almighty)

    Take a look at Klaus's user tip on MacKeeper, he refers to the sure way to remove it once installed.

  • Ralph Landry1 Level 7 Level 7 (28,815 points)
    Currently Being Moderated
    Mar 30, 2013 7:28 AM (in response to Mr G Almighty)

    Off hand for now just see if the system is stable.

     

    Have you checked to see if there are firmware up dates for the router?  You need to login to the router to do that, but that is all that comes to mind right now.

     

    Good that you did Phil's MacKeeper cleanup, should be ok in that area.

  • Ralph Landry1 Level 7 Level 7 (28,815 points)
    Currently Being Moderated
    Mar 30, 2013 1:04 PM (in response to Mr G Almighty)

    There have been other users who found moving to a higher channel helped their stability issues so give Channel 11 a try.

  • sekiisaac Calculating status...
    Currently Being Moderated
    Apr 8, 2013 11:31 PM (in response to Mr G Almighty)

    I'm having the same problem, and i think it all started when i updated to 10.8.3.  This happened to me last year on my imac and it was so annoying. it seems like everytime apple releases a new update there are bugs that cause my wifi to drop.

  • Helpstonharv Calculating status...
    Currently Being Moderated
    Apr 9, 2013 2:02 AM (in response to Mr G Almighty)

    I have had this problem for months and have been forced to use an ethernet cable until this week when I have resolved my problem. I change the channel on my router from auto to manual and set it on 9 and applied it. Since then no problems. I believe it was interference from my house phone system so by changing the channel to 2 nopw operate on difference frequencies.

     

    hope you get it fixed

  • dreve Calculating status...
    Currently Being Moderated
    Apr 11, 2013 6:41 AM (in response to Mr G Almighty)

    I have the same problem

    After the 10.8.3 update, my modem wi-fi network has stopped working for me. I tried diagnostics but 2 wi-fi channel still doesn't work.

    I need to plug in a router (I use with hotel travelling for ethernet sharing) and that works

    Mobile broadband and tethering also works

     

    so it is very specific to which wi-fi connection the laptop will work now

     

    Tried everything as the original poster said, nothing works, I really need this working again

  • iankh Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 11, 2013 8:29 PM (in response to dreve)

    I have the same problem. My iMac is on 10.8.3 and it disconnects from wifi after sleep. I have to search for my network and reconnect. I have an Airport Extreme.

     

    I've had both the Airport Extreme the iMac for quite a while This only started to occur with the latest OS X update to 10.8.3

  • ssls6 Level 4 Level 4 (2,415 points)
    Currently Being Moderated
    Apr 11, 2013 8:34 PM (in response to Mr G Almighty)

    I hate to say this but your router "Belkin N+ Wireless Router" is not dual band.  When you have a mixed network of B, G, & N (like an iphone, mac, other stuff), your router switches bands leaving some of your stuff confused.  It happens more than you think.

     

    Try setting your router to B/G only and see if this fixes the problem.  If it does then you know what you need to do.  Get a decent dual band router.  I think the AEBS (airport extreme base station) is outstanding.

  • Nbod702 Level 1 Level 1 (25 points)
    Currently Being Moderated
    May 4, 2013 11:11 AM (in response to Mr G Almighty)

    Mr. G,

     

    I have been having this problem with just one of our iMacs in our house.  I went through Apple support and navigated through all the twists and turns they suggested to try to get the problem solved.  NOTHING WORKED.  THEY DON"T KNOW HOW TO FIX THIS PROBLEM.  BUT I DO!  Unfortunately it involves buying a $30 wireless ethernet adapter (I got an IOGEAR, and I have no connection to their company.  Probably any wireless ethernet adapter will work).  I turned off the internal airport wireless device and through the network settings in the system preferences connected to my CISCO LYNKSYS ROUTER (which has been bashed left and right in the forums here).  THE PROBLEM IS SOLVED!!!!!   NO RESTARTING!!!  NO DROPPED CONNECTIONS!!!!

     

    So the problem isn't with the router, its with the airport wireless adapter in the iMac.  It ***** to have to spend more money after you lay out so much for an apple product, but it sure beats restarting the computer over and over every day.

     

    Hope this helps my friends out there.  I can now allow my hair to repopulate my head since I've been pulling it out over this issue for months.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.