Skip navigation

iCal server - running but not running

1137 Views 5 Replies Latest reply: Apr 12, 2013 3:42 AM by Guido Eijrond RSS
JeffSchlabach Level 1 Level 1 (0 points)
Currently Being Moderated
Apr 4, 2012 10:22 AM

When I try to start up our iCal server Lion Server, it shows as running in Server, but I can't connect to it with a client. Also, if I run a port scan on the server, the port the iCal client is trying to connect to (8008) isn't open. I checked the error logs on the server, and this is what it's showing. I don't know too much about decifering error logs, but it seems as if a python script is giving an error somehow. This just started recently, I didn't notice it until today, but it could have been happening the last few days already. Something with the server locked up a few days ago and we had to do a hard restart, so that might be part of the problem, I suppose. Does anyone have any ideas or fixes for this? Thanks!

 

 

 

 

 

 

 

 

 

2012-04-04 12:28:05-0400 [-] twistd 11.0.0 (/System/Library/Frameworks/Python.framework/Versions/2.7/Resources/Python.app/ Contents/MacOS/Python 2.7.1) starting up.

2012-04-04 12:28:05-0400 [-] reactor class: twext.internet.kqreactor.KQueueReactor.

2012-04-04 12:28:05-0400 [-] calendarserver.accesslog.AMPLoggingFactory starting on "'/var/run/caldavd/caldavd.sock'"

2012-04-04 12:28:05-0400 [-] calendarserver.tap.caldav.CalDAVStatisticsServer starting on "'/var/run/caldavd-stats.sock'"

2012-04-04 12:28:05-0400 [-] [txdav.common.datastore.util.UpgradeDatabaseSchemaService#warn] Beginning database schema check.

2012-04-04 12:28:05-0400 [-] [txdav.common.datastore.util.UpgradeDatabaseSchemaService#warn] Required schema version: 6.

2012-04-04 12:28:05-0400 [-] [txdav.common.datastore.util.UpgradeDatabaseSchemaService#warn] Actual schema version: 6.

2012-04-04 12:28:05-0400 [-] [txdav.common.datastore.util.UpgradeDatabaseSchemaService#warn] Schema version check complete: no upgrade needed.

2012-04-04 12:28:05-0400 [-] [txdav.common.datastore.util.UpgradeDatabaseSchemaService#warn] Database schema check complete, launching database service.

2012-04-04 12:28:06-0400 [PooledMemCacheProtocol,client] Unhandled error in Deferred:

2012-04-04 12:28:06-0400 [PooledMemCacheProtocol,client] Unhandled Error

          Traceback (most recent call last):

            File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/twi sted/internet/defer.py", line 388, in errback

              self._startRunCallbacks(fail)

            File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/twi sted/internet/defer.py", line 455, in _startRunCallbacks

              self._runCallbacks()

            File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/twi sted/internet/defer.py", line 542, in _runCallbacks

              current.result = callback(current.result, *args, **kw)

            File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/twi sted/internet/defer.py", line 1076, in gotResult

              _inlineCallbacks(r, g, deferred)

          --- <exception caught here> ---

            File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/twi sted/internet/defer.py", line 1018, in _inlineCallbacks

              result = result.throwExceptionIntoGenerator(g)

            File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/twi sted/python/failure.py", line 350, in throwExceptionIntoGenerator

              return g.throw(self.type, self.value, self.tb)

            File "/usr/share/caldavd/lib/python/twistedcaldav/upgrade.py", line 984, in startService

              yield updater.updateCache(fast=True)

            File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/twi sted/internet/defer.py", line 1020, in _inlineCallbacks

              result = g.send(result)

            File "/usr/share/caldavd/lib/python/twistedcaldav/directory/directory.py", line 656, in updateCache

              members = pickle.loads(snapshotFile.getContent())

          exceptions.EOFError:

Xserve, Mac OS X (10.7.3)
  • brentcrilly05 Calculating status...
    Currently Being Moderated
    Sep 2, 2012 10:11 AM (in response to JeffSchlabach)

    Any update on this? I have a very similar issue, ports 8008 8443 just dont seem to open - log full of puthon errors upon startup

  • cashgrow Calculating status...
    Currently Being Moderated
    Nov 21, 2012 1:23 PM (in response to JeffSchlabach)

    Also have this problem after upgrading to 10.8,  with the (members = pickle.loads(snapshotFile.getContent) error , and the ports does not seem to be open... any solution to this?

  • ts-macademy Calculating status...
    Currently Being Moderated
    Dec 10, 2012 9:54 AM (in response to JeffSchlabach)

    Hi, I got the same error messages on 10.8 ML Server. All appeared after a hard shutdown/reboot.

     

    Here is my solution:

    Stop "Calender Server" in Server App.

    Open Terminal and enter the following command:

         sudo rm /Library/Server/Calendar\ and\ Contacts/Data/memberships_cache

    Start "Calender Server" again

    View Error Log of Calender Server. It should contain this line:

         Starting group membership cacher service

    Use Network Utility from Utilities folder and run a port scan on 127.0.0.1.

    Open Ports 8008, 8800, 8443 and 8843 should appear.

     

    Hope this will help you.

  • frederickfromwesley Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 12, 2013 12:29 PM (in response to ts-macademy)

    Thank you ts-macademy!!!  Your a life saver.  I spent 6+ hours looking for the answer. 

    Had a power failure and  ical and contacts wouldn't connect upon restart.  Deleting the cache solved the problem.

  • Guido Eijrond Calculating status...
    Currently Being Moderated
    Apr 12, 2013 3:42 AM (in response to ts-macademy)

    Thanks you ts-macademy, you saved us a lot of hassle too!

     

    I believe our problems with the Python libraries started after the server ran out of HD space.

     

    After restoring the /Library/Server/Calender\ and\ Contacts/Data folder using timemachine and deleting the 'memberships_cache' everything runs fine again.

     

     

    We did:

    - Stop iCal services from Server app

     

    - In terminal:

    $ sudo cd /Library/Server/Calender\ and\ Contacts/

    $ sudo open .

    (a finder window opens)

     

    - Use the Timemachine interface to restore the Data folder

     

    - Back in terminal:

    $ sudo rm Data/memberships_cache

     

    - Start iCal services

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.