Skip navigation

How do I fix status of "screensharing available" in ARD admin console?

1956 Views 13 Replies Latest reply: Jul 9, 2013 8:58 AM by lmadden RSS
lmadden Level 1 Level 1 (0 points)
Currently Being Moderated
Apr 11, 2013 8:15 AM

I am running running ARD 3.6.1 admin and connect to several macs remotely to send commands, deploy software, control/observe the machines, etc.


Most show up fine in my ARD console.  However, I have a few that show up with status 'Screensharing Available.'


I can observe and control, but nothing else.


I have deleted the object out of ARD and readded both via DNS name (short name and FQDN) and IP, same result.


Firewall is set to allow Remote Management in.


Remote Management is set with a local account and all the check boxes are checked.


Screen Sharing is not enabled.


The client is running Remote Desktop 3.6.2.


As far as I can find there is NO admin 3.6.2 available.



Any help is appreciated as this is extremely annoying.





Mac Pro, OS X Mountain Lion (10.8.3)
  • varjak paw Level 10 Level 10 (167,195 points)

    You've confirmed on the problem clients that Remote Management is turned on in the Sharing system preferences and that the appropriate computer settings have been made?

  • varjak paw Level 10 Level 10 (167,195 points)

    Are the problem machines on the same subnet as the ones that work? If not, check the router/firewall to make sure that port 3283 is open to the appropriate subnet. It could be that 5900, the port used for control, is open but 3283 is not.


    Hope this helps.

  • varjak paw Level 10 Level 10 (167,195 points)

    Is the firewall active on that Mac? If so, try turning it off. If it claims it's off but the port still reports as blocked then there's probably a glitch (likely anyway if activating Remote Management and the appropriate settings doesn't open the port) that's keeping it running regardless. You may be able to get help for that problem in the appropriate Mac OS X forum.



  • TeenTitan Level 4 Level 4 (2,410 points)

    Do you have remote login enabled on one of the effected clients?


    if so ahve you tried ssh into the client and jump start ARD?



    1. open terminal
    2. ssh username@computerIP
    3. login
    4. send the command sudo /System/Library/CoreServices/RemoteManagement/ ickstart -restart -agent


    if still not working you could try:

    sudo /System/Library/CoreServices/RemoteManagement/ ickstart -activate -configure -access -off


    fallowed by:

    sudo /System/Library/CoreServices/RemoteManagement/ ickstart -activate -configure -access -on -restart -agent -privs -all

  • nomad_nyc Level 1 Level 1 (0 points)

    It would be nice if Apple resolved this issue. I have 600+ Macs and oftentimes I will see this on 30-40 machines at a time. The next day it'll be a different set of stations. As much as TeenTitan's method might work, it is not really an option to ssh to a large number of stations.

  • TeenTitan Level 4 Level 4 (2,410 points)

    If turning ARD off and back on fixes the issue perminantly for a client.

    you could in thory deploy the setting through ARD in mass.

  • nomad_nyc Level 1 Level 1 (0 points)

    "In theory" but in practice I would have to restart ARD and then send your command multiple times every day just to retain access to all my clients. This means that something is broken and I would bet it is the interaction of different versions of client and server.

  • TonyPlack Calculating status...

    I tried the restart first, but was getting a Bind(): Address in Use.  This occurs because the user has a Thunderbolt display with an ethernet jack.  I don't get this message with the user when they are on WiFi because that is the address it was binding.


    It does seem as if ARD has a problem with machines which connect physically and wirelessly and the transistion between the two.


    One updated to this fix by TeanTitan.  The first command should be deactivate.  Like this:



    sudo /System/Library/CoreServices/RemoteManagement/ ickstart -deactivate -configure -access -off



    Then run the activate and it cleared the bind issue for me. 



    sudo /System/Library/CoreServices/RemoteManagement/ ickstart -activate -configure -access -on -restart -agent -privs -all


    Thank you for the post.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.