10 Replies Latest reply: Apr 14, 2013 10:00 AM by MegMonday
MegMonday Level 1 Level 1 (0 points)

I'm running 10.8.3 OS, Aperture 3.4.3, and Raw Compatibility 4.04. Downloaded and updated ALL today to get RAW compatibility with Nikon D600. No dice.

I deleted files imported with older version of Aperture and reimported. (Though I had to import via transfering NEF files to harddrive b/c Aperture is now not recodnizing images on the SD card, and after new import I still get the dreaded blue triangle. I have the most current versions of software now. Anyone know what's up?


Aperture, OS X Mountain Lion (10.8.3), RAW 4.04
  • 1. Re: D600, false "unsupported image format" icon
    MegMonday Level 1 Level 1 (0 points)

    ps. I tried to install ComboUpdater for 10.8.3 as suggested here, but I'm not allowed b/c I have a more current version?

    My download is as of 04.11.2013

  • 2. Re: D600, false "unsupported image format" icon
    Ernie Stamper Level 8 Level 8 (37,475 points)

    Hi,

     

    Were all NEF files imported from the SD card in a card reader, or while still in the camera?

     

    Your report is different from the prior referenced topic in that you have the latest Camera RAW.

     

    You should perhaps create a New User on your Mac (or maybe use the Guest User) and as that user launch Aperture to create its new first time Library, and try to import your D600 images there.

     

    Ernie

  • 3. Re: D600, false "unsupported image format" icon
    ButchM Level 1 Level 1 (45 points)

    Did you perchance use Nikon Transfer in your process?  If you are not using the latest version of NT, it can change the info in the header file for your images that cause problems for third party apps like Aperture.

     

    Best thing to do is if you are going to use Aperture, don't use NT.

  • 4. Re: D600, false "unsupported image format" icon
    MegMonday Level 1 Level 1 (0 points)

    Ernie! Thanks! This worked! It is, at least, the first step.

     

    Making a brand new Aperture library worked in my Guest user account, so I went back into my regular user account and after upgrading all my other libraries (I have 5 heavily populated libraries, the "Aperture Libraries" all run on the native HD, but all store Master files on external drives)- and now all work with RAW, EXCEPT for the first library I had the original problem with. It is 3.4.3 like all the rest, but is still not recodnizing D600 raw.

    Seems like maybe I should make a new library and import all my images from this library to the new one? Do I loose edits, etc. this way?

     

    I always transfer images from the SD slot in the computer, not in camera or plugged in card reader. Is this the best way?

     

    @ButchM, thanks for your response too. I downloaded the Nikon ViewNX2 (if that's where the NT comes from?) but only used it to confirm that the RAW read issue wasn't coming from my camera and the original file writing. Otherwise I just use Aperture. 

  • 5. Re: D600, false "unsupported image format" icon
    Ernie Stamper Level 8 Level 8 (37,475 points)

    Megan,

     

    SD slot in computer should be fine.  Just not from the camera.

     

    Where are the first library Referenced Originals?  If on a different external, how is that external drive formated?

     

    I would not yet give up hope on the first library, until we have thought about it more.

     

    Ernie

  • 6. Re: D600, false "unsupported image format" icon
    MegMonday Level 1 Level 1 (0 points)

    My Referenced Files are on an external drive- same drive as all the other libraries ref files.  That drive is formatted Mac OS extended (journaled).

  • 7. Re: D600, false "unsupported image format" icon
    Ernie Stamper Level 8 Level 8 (37,475 points)

    With that Library open, click on File/Show in Finder.  Does that work to show the location as expected of these referenced originals?  If so, right click on one or more of them, and choose Open With and start with Preview.  Can Preview open them?

     

    This might be a permissions issue, but not at all certain of that.

     

    Ernie

  • 8. Re: D600, false "unsupported image format" icon
    MegMonday Level 1 Level 1 (0 points)

    The files are in the expected place (extrernal drive), and preview does open them...

  • 9. Re: D600, false "unsupported image format" icon
    Ernie Stamper Level 8 Level 8 (37,475 points)

    Preview uses the same Camera RAW converter as Aperture.  This test proves the files are combatible, therefore, as they exist there.

     

    Create a New Library, and with that Library open, try to Import this one stubborn Library into the new one.  You may have to allow the originals to also be imported, not sure.

     

    Ernie

  • 10. Re: D600, false "unsupported image format" icon
    MegMonday Level 1 Level 1 (0 points)

    So far, so good! The new library recodnizes the D600 RAW format.

    THANK YOU ERNIE!

    -M