2 Replies Latest reply: Apr 13, 2013 8:33 AM by Allan Jones
bobbymacbean Level 1 Level 1 (10 points)

I need recommendations for an emac 1.42 and ibook 1.33, OS 10.3 - 10.5 compatible external superdrive ?


eMac 1.42, Mac OS X (10.4.11), iBook g4 1.33 10.3.9