Skip navigation

Suddenly yahoo mail not working on mail app

90257 Views 61 Replies Latest reply: Mar 30, 2014 12:48 PM by Koho22 RSS
  • K I M B A K A T Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 6, 2013 10:06 AM (in response to Dotar Sojat)

    As a 2013 update...you can use Outgoing Yahoo Server for Apple Mail as:

     

    apple.smtp.mail.yahoo.com

  • andypanda1234 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 8, 2013 7:16 PM (in response to bishlawy)

    Go to Safari preferences>General>Default Web Browser>Select Safari

  • K I M B A K A T Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 14, 2013 1:32 PM (in response to andypanda1234)

    HUH? What does the default web browser have to do with my mail settings???

     

    I use Firefox anyway...so how does that affect my YAHOO MAIL SETTINGS in a Applictions called "MAIL?"

  • madbioskillz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 11, 2013 8:30 AM (in response to K I M B A K A T)

    This solved it for me. Thanks!

  • Dale Weisshaar Level 6 Level 6 (15,855 points)
    Currently Being Moderated
    Apr 11, 2013 1:09 PM (in response to madbioskillz)

    madbioskillz wrote:

     

    This solved it for me. Thanks!

    For the benefit of others, what actually solved your issue please?

  • 1207brits Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 14, 2013 6:47 PM (in response to bishlawy)

    I have had an on and off nightmare with this issue too - hours on the phone to AT&T etc.  I tried deleting all my email accounts and reinstalling them but they all re-set with "offline" outgoing mail servers.  This is what FINALLY fixed it for me today (my idea, not theirs!).  First of all, under Mail Preferences I clicked on one of my mail accounts to access the list of available outgoing mail servers.  Then I deleted ALL the existing outgoing mail server options, so there were none left to choose from.  Then I deleted and reinstalled all of my email accounts and they all now work perfectly, all outgoing servers online - deep joy.  Hoping this may help someone else:)

  • easymodeuser Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 25, 2013 5:54 PM (in response to bishlawy)

    I've had this problem too for the last two weeks.  Suddenly Mail can't connect and keeps asking me for my yahoo password over and over again.  I had the same problem two years ago and created a new account using IMAP instead of POP.  So I still have the old POP account but have it offline.  So now that I'm having problems with the IMAP setup, I went on-line with the POP account.  And it works!  I'm just going to use the POP account and turn off the IMAP until the POP stops working.  By then, maybe the IMAP account will work.

  • LowLuster Level 6 Level 6 (11,765 points)
    Currently Being Moderated
    May 25, 2013 7:10 PM (in response to easymodeuser)

    If you want to fix this problem for good and never have it again stop using the built in mail program and use any other mail program available for os x.

     

    This problem is posted so much it is ridiculous. It is not yahoo or gmail. It is the built in mail program in os x.

    Some never have a problem with it. Other always have problems with it.

    easymodeuser wrote:

     

    I've had this problem too for the last two weeks.  Suddenly Mail can't connect and keeps asking me for my yahoo password over and over again.  I had the same problem two years ago and created a new account using IMAP instead of POP.  So I still have the old POP account but have it offline.  So now that I'm having problems with the IMAP setup, I went on-line with the POP account.  And it works!  I'm just going to use the POP account and turn off the IMAP until the POP stops working.  By then, maybe the IMAP account will work.

  • easymodeuser Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 26, 2013 5:47 PM (in response to LowLuster)

    Ok.  Installed Thunderbird and it seems to work pretty good.  Thanks alot, LowLuster.

  • LowLuster Level 6 Level 6 (11,765 points)
    Currently Being Moderated
    May 26, 2013 5:54 PM (in response to easymodeuser)

    You are very welcome. From what others tell me about thunderbird, I use outlook, there are a ton of add-ons for many different things.

  • Ruliyah Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 28, 2013 10:45 PM (in response to LowLuster)

    Lowluster, I have the problem too since four weeks with my yahoo email. It is indeed ridiculous to have it and I don't understand that Apple doesn't fix it! My IMac 27 inch is three months old.

     

    Would you please so kind to tell how to stop the built in mail program and properly get my yahoo email again without interfering with my hotmail which is working fine. I am now 3 months on IMac/Apple so brand new.

     

    Thanks and kind regards

  • igirl1 Level 1 Level 1 (25 points)
    Currently Being Moderated
    Jul 31, 2013 10:09 AM (in response to Ruliyah)

    Yahoo Mail + Apple Mail in OSX has given me fits off and on for years.

     

    This time it wasn't updating "new mail" in a timely fashion - or not at all in some cases!  I finally figured out that QUITTING MAIL and waiting until it was 100% cold dead, then starting it up again seemed to work for me.

     

    Taking it "offline", waiting, and then putting it back "online" didn't work for this no new mail issue.  (MenuBar/Mailbox/TakeAccountsOffline)

     

    I've also had the zillions of popups problems - never been solved - it just goes away eventually.

     

    Thunderbird is a good free alternative though I would love to find something more refined.  Sparrow used to be it - but that's been crushed by Google.

  • arabinow Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 17, 2013 2:03 PM (in response to Dale Weisshaar)

     

     

    madbioskillz wrote:

     

    This solved it for me. Thanks!

    For the benefit of others, what actually solved your issue please?

     

     

     

     

    He was referring to the post two above him

     

    Adding apple infront of the incoming mail server

     

    apple.smtp.mail.yahoo.com

     

    That seemed to work for me as of now.

  • Bananasplit1970 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 28, 2013 2:12 AM (in response to 1207brits)

    This worked for me perfectly!

    Delete the SMTP's in mail, then delete mail accounts from "Internet Accounts" in "System Preferences", then add your mail accounts back in.

  • SkeeterOz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 12, 2013 5:03 AM (in response to bishlawy)

    Hello everyone. This is my first time here, and it's been a great help. My mail refused to work (yahoo) on the macair after having worked just fine for over a year. But it was still working on BB and iPad. I tried changing the settings and solved it by deleting the account (which I didn't realise whacked all my inbox as well), and then set it up again using the same passwords etc. works fine now.

    I was relieved to find so many others with the same issue and also some solutions. All good now.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.