Skip navigation

iTunes Sign in Not Working

281 Views 2 Replies Latest reply: Apr 14, 2013 10:53 PM by JVXB RSS
JVXB Level 1 Level 1 (50 points)
Currently Being Moderated
Apr 12, 2013 5:41 AM

Scenario: Upgraded to iTunes 11.00.02, at long last (first mistake: I hate the interface), and subsequently could not log onto the App Store, etc. After scouring the forums, I happened to find one thread which said in Parental Controls, to disable iTunes Store, and tick the box next to iTunes U, as counterintuitive as that sounds.

 

Well, I got back the App Store, but I had been signed out of my account. I am currently unable to connect to sign-in.

 

On running diagnostics, it gives me the dread "Secure Link to iTunes Store failed" message. I've had this problem before, so I can the command prompt, entered "netsh winsock reset" and rebooted. I have done so several times, now, without any luck.

 

I recall I had a similar problem some years before, and solved by uninstalling ALLLL the programmes, in a specific sequence, but I'm hoping you guys may help me with specific info as to what could be going on.

 

(I know my way around computers and routers, and have checked all the likely culprits, like Windows Firewall, disabling my A/V, power cycling my router, etc)

 

THANKS IN ADVANCE!

Dell, Windows XP

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.