Skip navigation

iphone calendar not syncing to icloud (works the other way)

332 Views 6 Replies Latest reply: Apr 17, 2013 12:03 AM by rasd70 RSS
beckynbart Calculating status...
Currently Being Moderated
Mar 11, 2013 9:24 PM

I've had my new iphone 5 for about a month.  I have been adding events to my calendar on my iphone.  These do not sync to the calendar on my icloud.  If I add an event to my icloud calendar, it does appear on my phone. 

 

What could I be doing wrong?  Thanks in advance.

iPhone 5, iOS 6.1.2
  • cheonweb Level 4 Level 4 (3,440 points)

    Settings>Mail, Contacts, Calendars>Calendars>Default Calendar>iCloud.

  • dopieopie78 Calculating status...

    I have the same problem. I have my iPhone default calender the iCloud calender and events i add on my phone do not update to iClound... to me this would be the most useful feature of iCloud calender so i can add events via my phone then access them when at my desk. I've tried re-installing iCloud on my iPhone and a few other online suggestions but still no luck.

  • randers4 Level 9 Level 9 (53,115 points)

    beckynbart wrote:

     

    I'm still having the same problem.  I've not found a solution yet.

     

    If your default calendar is set to iCloud and new events still aren't syncing, go to icloud.com on your computer and add any events from your phone that are not on your calendar on icloud.com.  Once the calendar on icloud.com is up to date, on your phone go to Settings>iCloud, turn Calendars to Off, choose Delete from My iPhone when prompted, then after a minute or so turn Calendars back to On to sync your iCloud calendar back to your phone.  Then add a new calendar event on your phone and see if it syncs now.

  • rasd70 Calculating status...

    This has been happening to me too.  None of the changes I would make in my calendar would reflect in icloud and on my son's and wife's calendars that use the same icloud account.  However, changes I made on their devices would sync (but not with me).  Turning off calendars in icloud and deleting the events from my phone and then re-enabling calendars only brought some of the events back but not all of them.

     

    I finally found a solution!  I went into Settings > Mail, Contacts, and Calendars then scrolled to the bottom and under Calendars, clicked on Sync.  I changed this from All Events to "Events 6 months back."  This finally got the phone to sync more events in the calendar.  I went out to calendar to check this.  Then I went back in and changed Sync to "All Events" and finally I got everything back and now I am syncing with icloud and across all our devices.  Try it and see if it works for you.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.