4 Replies Latest reply: Apr 17, 2013 9:58 PM by James Thomson
James Thomson Level 1 Level 1 (85 points)

I'm brand new to Logic Pro but am jumping right in.  I am trying to tranpose an audio file in Time/Pitch Machine under Samples/Factory/.

 

I clicked on "Classic" because I interpreted instructions under "Help" that "Classic" would force the Tempo parameters to adjust to keep the original tempo.

 

It is not working out. The piece is in the correctted pitch I want, but is still much slower when both "prelistening" and "process and pasting." 

 

I'm half way there, pitch is correct.  How do I get the tempo correct?  (I also tried moving the numbers in the tempo section up and down in Universal Mode and it just stayed at the same slow tempo.) 

Thanks:  James


iMac, OS X Mountain Lion (10.8.3)
  • 1. Re: pitch changes but not tempo, used Classic
    kcstudio Level 4 Level 4 (1,625 points)

    Try to read once more:

     

    Classic: In Classic mode, pitch and tempo are linked, so transposing a selected region also affects its tempo. The resulting effect simulates the sound of changing tape speed. The pitch increases as the tape speeds up, and it decreases as the tape slows down.

     

    Instead use:

     

    Free: In Free mode (the more common mode setting), you can make all pitch and tempo adjustments independently of one another.

     

    What are you trying to achieve exactly?

     

    Cheers!

  • 2. Re: pitch changes but not tempo, used Classic
    James Thomson Level 1 Level 1 (85 points)

    I'm moving a premade accompaniment to a place where the vocal range will be appropriate for my 3rd graders who will sing with it in a choral concert.  I actually did it at first in Free Mode, and the tempo went slow... so I naturally started changing the parameters in the boxes in the tempo area and it seemed like no matter which boxes I changed way up or way down, wouldn't change the tempo. and the boxes were all linked and changed together when I changed any of them.  But I just couldn't get change in the tempo when I played with the numbers in Tempo.   I have to go back and revisit this tonight when I get back from work.

    (thanks!!)

  • 3. Re: pitch changes but not tempo, used Classic
    kcstudio Level 4 Level 4 (1,625 points)

    Try Free Mode to adjust the key and afterwards fix the tempo in cooperation with VariSpeed.

     

    Have a nice day!

  • 4. Re: pitch changes but not tempo, used Classic
    James Thomson Level 1 Level 1 (85 points)

    Wow.  Okay.  I have a lot to learn and figure out with Logic Pro.  Tonight, the audio file DID come out at the same/correct tempo after processing and pasting the pitch change.  Last night I thought that it did not, don't know why.  Regardless, I didn't have to use the VariSpeed option.  But wow.  After successfully changing pitch without tempo, I thought, well I'll import the same audio track and bump up the same amount I bumped the last one down and get an octave  higher which I can use to brighten the sound of the first track I lowered.  That turned out to be a long comedy of errors that seemed more complicated than I expected.  I know to a large extent I have to figure this out on my own, or take a class in real time where I can talk in real time with someone.  But I never was able to duplicate a track and make it an octave higher as even though I was choosing just the new track for the Pitch/Tempo machine in Factory it changed BOTH tracks.  And even so, the new imported track that I wanted to make an octave higher imported ALREADY made to the new correct pitch that I had applied to the first track.  I was expecting the second identical track imported to be just like the original, in the wrong key, but it imported to the new changed pitch and then when I tried to change it anyway an octave higher, BOTH tracks moved up an octave.  Then I tried start from scratch and when I would import the audio file in a new project it STILL came in altered to the an octave too high from my previous fiddling to get just one of the tracks on the abandoned track to be an octave higher, it was as though the parameters set in Pitch Machine were automatically applying to a newly imported track on a new project which was quite frustrating.  Then somehow after a few attempts, I got a new project (with the same name -  I kept over writing with same name because I didn't want the old file there that was failed but with the name I wanted for a new correct file).....after a few attempts I DID get a new file to import the audio virgin and I successfully pitch machine transposed it to where I wanted it and SAVED it!  It's still be neat to make a second track an octave higher, to brighten it up but I'll try that with a new file so I don't mess up what I already have done correctly and at least sufficiently for my needs.

     

    I've thrown at lot at you in this narrative and I don't expect you to pull it apart and respond to all the points and misconceptions I have.  But I can see I will have to really play with Logic Pro all along the way for a good while.  It feels like it did when I first started using GarageBand five years ago.