Skip navigation

"Reply All" re-sends to me! So annoying!

63114 Views 42 Replies Latest reply: Nov 18, 2013 10:50 AM by Nick Johnson7 RSS
  • polky78 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 29, 2013 6:08 AM (in response to pieceolease)

    I had a completely different solution to the problem of "reply to all" including me.  After months of perturbance, trying all the things I could find on message boards, it turned out to be quite simple.  All I had to do was:

     

    1. Open the Contacts Application.

    2. Find the card that represented myself and confirm that my email was correct.

    3. With my card selected, go to the drop down menu and choose "Card" --> "Make this My Card".

     

    That's it.  It solved the annoying "reply to all" problem as well as other issues, including the fact that no one ever received my responses to calendar events.  For me, I think this was rooted in a complicated migration from my old Mac.

  • Andy Guss Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 29, 2013 6:15 PM (in response to polky78)

    Nope. "My Card" has been set since day one (with the affected email address). Still experiencing the problem.

  • CyclingMac Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 15, 2013 6:52 PM (in response to pieceolease)

    I have been experiencing the same issue. It is absolutely repeatable and I have been unable to cure it with any of the suggestions I've found in this or any other thread/discussion. Here is what I've found thus far:

     

    1. My bug is not Exchange related. I do not use Outlook, interface with an Exchange server, or work in a corporate environment. This is just me, my MacBook Retina, Apple Mail and OS 10.8.3 in a home environment.

     

    2. The problem does NOT occur when I Reply All to an email that is in an IMAP hosted mailbox, be it my inbox, the Trash hosted on the server, or any folder stored in "the cloud" (iCloud or a different IMAP account I have at a different hosting site).

     

    3. The problem DOES occur (and only seems to occur) when I Reply All to an email that has been moved (manually or by a rule) to an On My Mac local mailbox ( and thus has been removed from the IMAP servers).

     

    I can replicate this reliably with an individual email. Place the email in an iCloud folder and Reply All works as expected. Place the same email in an On My Mac folder and Reply All includes me in the reply. Move the email back to an iCloud folder and all is well again with Reply All - no copy to me.

     

    I've also replicated this behavior using my iCloud email account on a separate Mac Mini I use as a home server. It has minimal additional login or launch daemon items and uses no mail plug-ins or bundles. Lastly, I've replicated this behavior on my wife's Macbook Retina running 10.8.3 using her iCloud email account. As I mentioned, I've also replicated it using Apple Mail on my laptop to access a 3rd party non iCloud IMAP account.

     

    Rick

  • Mike Jasinski Level 1 Level 1 (5 points)
    Currently Being Moderated
    Apr 17, 2013 12:04 PM (in response to CyclingMac)

    I have the same issue as "CyclingMac". While it is on the server (imap inbox) it replys correctly - without my name in the CC. Once i move it to one of the "ON MY MAC" folders, it CC's me. very bad. nothing extra is installed. 10.8.3

  • crowfeather Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 24, 2013 5:54 PM (in response to pieceolease)

    I have my username exactly the same as my email address, on Mountain Lion Mail.app and it's still including me in the reply to all. Very frustrating.

  • Dukat Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 26, 2013 7:42 PM (in response to CyclingMac)

    Thanks CyclingMac; this is the only part of this discussion that seems to apply to me.  If I reply to an email that is still on an IMAP server everything works.  If it's been moved to somewhere "On My Mac" I get included in the reply.  I used to use Outlook 2011 at a previous job and never had the issue.  My email addresses all match in my Mail Accounts settings, and my card is set to "me" in Contacts.

  • CyclingMac Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 1, 2013 6:01 AM (in response to pieceolease)

    I sent my observations to Apple via their feedback website, but it's anyone's guess whether that will make any difference or not.

  • fronesis Level 1 Level 1 (10 points)
    Currently Being Moderated
    May 8, 2013 9:02 AM (in response to Dukat)

    Dukat wrote:

     

    Thanks CyclingMac; this is the only part of this discussion that seems to apply to me.  If I reply to an email that is still on an IMAP server everything works.  If it's been moved to somewhere "On My Mac" I get included in the reply.  I used to use Outlook 2011 at a previous job and never had the issue.  My email addresses all match in my Mail Accounts settings, and my card is set to "me" in Contacts.

     

    I can confirm exactly the same as Dukat writes above. I'm using Mail on ML, all address match, and my contact card is correct; the problem occurs when I reply to a message that is not on the original account's IMAP server.

     

    In my case it's a big problem because I have all my mail forwarded to icloud (for push), but I want to reply to messages sent to my non-icloud account using that same (non-icloud) account. Every time I do it replies to me.

  • honeybadger99 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 13, 2013 5:17 PM (in response to pieceolease)

    I had the cc to myself even though I had the cc myself button turned off on my iPhone 5.  I have a gmail, yahoo and exchange account.  It only did it on the exchange account.  I have an iPad also, but it only occured on my iPhone.  I deleted my exchange account on my iPhone and re-entered it and the problem went away.  Not sure if it work for you on your device but it is a pretty easy fix.

  • robertfromadelphi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 5, 2013 6:29 AM (in response to bacole)

    This was also exactly my problem and your suggestion fixed it. Thank you!

  • Holmbaeck Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 27, 2013 2:06 PM (in response to Beavis2084)

    I had this problem beacuse my company have two domains (two companies merged into one), and they switched the exchange server to use the new one, and since mail was configured with the old, it could not recognize is as my email and added it in the reply-all.

     

    So if anyone have email forwarding (or otherreasons the account email does not match the 'your email' in recipients), that might be why.

     

    Swicting to the new email address in accounts fixed it.

  • KailasR Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 28, 2013 11:20 PM (in response to jarrob)

    Thanks. It worked for me.

  • Nick Johnson7 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Nov 18, 2013 10:50 AM (in response to CarltonBanks)

    This worked for me

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.