Skip navigation

Mail app shows 3 unread emails when there isn't.

197508 Views 101 Replies Latest reply: Apr 2, 2014 9:50 AM by jalley1987 RSS
  • stewartSC3 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 25, 2013 11:25 AM (in response to atyree)

    I fixed my 6 false unread emails on the mail badge with a combination of suggestions from this thread. If you have this problem try this: go into settings/mail, contacts, calendars/(account that's messed up)/mail days to snyc. Change it to "no limit" and let it load for a awhile. I got up to 1800 unread emails or so and started to get worried, but them I changed that setting back to one "one week" and the mail badge was clear.

  • Duecelo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 26, 2013 3:38 PM (in response to bd1212)

    This one was killing me! My iPhone5 exchange account was showing 6 unread for about a month. Work email too so unread mail is generally pretty important. I'd tried everything here, cleaned out my outlook inbox and read every **** email again. Tried what you (bd1212) suggested and couldnt mark all. I just marked the top 10(ish) as unread and then held the mark button. Nothing happened but when I tapped mark as read, the little 6 FINALLY disappeared.

    No idea what exactly it acheived but it was obviously a glitch. Fixed now thanks for your help, everybody!

  • claudefromallenpark Level 1 Level 1 (0 points)

    This helped me isolate the problem and get it solved. It is a very annoying little glitch. Thanks for the help. FYI, I am an iPhone 4s user running iOS 6.

  • Wizard Fingers Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 6, 2013 1:28 AM (in response to atyree)

    I had this exact same problem - but found a solution! I deadtivated the emails for the account I was having problems with (ie leave calendar etc switched on), turned the phone off and on again, reactivated the account, and hey-presto - phantom emails all gone! Happy Days!

  • glend0508 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 18, 2013 7:11 AM (in response to shaarp)

    Thanks for the Tip.  Worked!

  • ksd2012 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 21, 2013 12:58 PM (in response to Daan Swakman)

    go to settings, then to "Mail, Contat, Calendar" option

    Select the acount you are having issues with

     

    Change the "Mail Days to Sync" to "1 DAY"

    Now go to to Mail app and sync your account again. Unread option should go away

    Now go back change the "Mail Days to Sync" and change the option back to what it was.

     

    This should fix this issue. This has worked for me.

  • Corinne104 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 21, 2013 6:03 PM (in response to atyree)

    I have been driven mad by 1 unread message in my hotmail inbox ... !  I checked absolutely everywhere umpteen times!  I tried to get 1000 emails, but none would load, so I was left with just the 7 that I wanted to keep.  None had extra emails attached.

     

    Eventually, I was driven to deleting the account and re adding it.

     

    YIPPEE!!  It's GONE!! 

     

    And so have 6 of the 7 messages that I wanted to keep ... !

     

    All or nothing, eh??

     

    Oh well ...

     

    There's a lot to be said for a pen and a piece of paper!

  • Ahmedmuh Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 29, 2013 1:03 AM (in response to atyree)

    Hi,

     

    I was stuck with Exchange emails, it started with 2, and after a year it reached 18 unread email, while my inbox was empty.

     

    I did two things,

    1. I did was was said in the first comment of this thread, I selected all the messages, then market them as read.

    2. I went to settings, turned off the [Mail] part of my account, then waited few seconds, and checked that my email app is without the exchange account, then I turned it back on.

     

    the crazy part is that nothing happened right away, and I was surprised after 6 hours, my problem was fixed, and the number of unread emails in the Mail App Badge matched the actual unread emails.

     

    Problem Solved!

  • Wekepepew Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 6, 2013 12:35 AM (in response to atyree)

    What worked for me is going in to the iphone settings and turn of the email part of my exchange account. And then turned it back on.

     

    I was going to delete my exchange account entirely and remake it, but saw this option and it worked.

  • JagAC Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 6, 2013 9:18 AM (in response to Duecelo)

    Like Duecelo, I tried all of the "solutions" listed on this thread.  None of them worked, except:

     

    Mark top 10 or so mails as "unread"

    Then re-mark them as "read"

  • cphansonWU Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 16, 2013 8:21 AM (in response to gotoEngland)

    THANK YOU gotoEngland for posting this solution!  I have had this issue with my Exchange account on my iphone for the past year at least.  At one point I deleted my whole account and reconfigured it, which worked for a while.  I had searched these forums pretty exhaustively sometime last year with no help.  The solution to mark one as unread and then read again cleared the extra phantom unread count. So quick and easy! Brilliant! THANK YOU!! 

  • hawkchev Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 27, 2013 2:20 PM (in response to atyree)

    This happens to me frequently...on my iPhone and iPad.  Just got a new Mac Book Pro and it showed one unread email.  I tried the "turning off" the email, but didn't work.  So I did what always works...I deleted the Exchange account and re-added it.  FYI...

  • LarryCFL Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 5, 2013 3:50 AM (in response to atyree)

    FInd the video on LifeHacker's blog and it shows you how to clear these in 30 seconds!!!!  Terrific.

  • JagAC Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 5, 2013 4:47 AM (in response to LarryCFL)

    @LarryCFL - Link please... or at least the search terms to find it directly!

  • PBICS Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 17, 2013 1:45 PM (in response to atyree)

    I just encountered this issue with my new iPhone 5

     

    Here's what I did to resolve it:

     

    Settings -> Mail Contacts Calenders -> Show Option -> Set it to "1000 Recent Messages"  (If you have more than 1000 messages in your inbox this may not work) -> Mail App -> Inbox -> Scroll to the bottom until all the messages are loaded -> Edit Button -> Select a message ->Select and hold your finger on the "Mark" button and then de-select the previously selected message (so no messages are now selected) -> Release  your finger from the "Mark" button ->Select "Mark as Unread".  This worked for me.  The issue was that my inbox held more messages than the app was downloading from the server.

1 ... 3 4 5 6 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.