Skip navigation

What's the Successful Way of Taking Out Java Out Of Safari ?

832 Views 2 Replies Latest reply: Apr 18, 2013 1:24 PM by OSX128bit RSS
OSX128bit Level 1 Level 1 (0 points)
Currently Being Moderated
Apr 12, 2013 4:51 PM


Disabled Java in Safari Preferences .

 

 

 

Heck , Disabled Javascript too .

 


Disabled Plugins .

 

 

 

Disabled Extensions .

 

 

 

 

i still get :

 

 

 

Macintosh HD  >  Library  >  Java  >  Extensions  >  ( unable to view , it's only viewable with a System Administrator ( ie root ) that i don't have the username and/or password for )

 

 

 


Macintosh HD  >  Library  >  Java  >  JavaVirtualMachines  >   ( unable to view , it's only viewable with a System Administrator ( ie root ) that i don't have the username and/or password for )

 

 

Macintosh HD  >  Library  >  Internet Plug-Ins  >  JavaAppletPlugin.plugin

 

 

 

I have downloaded and updated OS X 10.8.3 Combo .

 

 


Java isn't listed anywhere in Systems Preferences .  But if i click on the .jar 's and other Java .app 's , i can get the consoles to launch .  I haven't tested if i can work it .  I don't want to .  I don't want it .  I didn't download it .  I didn't launch the .app either . 

 


Apple logo  >  System Preferences...  >  ( No Java icon ) .

 

 

 


In Safari , it doesn't matter if i config the Preferences a hundred times .  Safari after 5 to 10 seconds will load up the Reader in Blue highlight at the top right , which means some type of Adobe Reader is running in the background , which i haven't downloaded and installed and launched , also if i click it , it copies the webpage to a pdf look a like , which is pointless , and then i go back to the Internet Plug-ins and the Extensions in the Safari Preferences and it switches back in front of my eyes to what i set the configuration for .  Like a real-time config edit on the fly .  What is happening ? 

 

 

 


As i write this Discussion Question , i am constantly being jumped around to write , as if ( if you have ever tested or used remote login and remote access ) there's a slight delay between you computer entry , and the result of the computer entry on the computer you're logged in to and remote accessing .  Strange .  Weird  .  Whatever you wanna call it  .  I got it  .  Very odd computer device behaviour .

 

 

 

Terminal and Terminal sudo su : 

 

 

 

java -version

 

1.6 build

Java 6

 

 

 

i have already gone thru both scenarios of :

 


Downloading the Apple Approved Java 2013-002 scenario .  Downloading , installing , launching , and then ultimately once i got it , Disabling it .  It shows up in System Preferences Other with the Java icon .  Also i have downloaded and installed the Java 7 latest Apple Approved Java , and Disabled it .

 

 

 

Java still persists .

 

 

 

And then if i Delete the Java .app 's and plugin 's , etc , etc , etc , what happens is ultimately i get the infamous Apple Windmill for about 5 seconds , and then asks , you are attempting to make changes , so Enter in your Administrator username and password , and i do , and the System Administrator ( ie root ) user that has this access , i do not know , so i am essentially stuck with a OS X with missing Software that can't be unistalled / reinstalled / repaired , and then i must Clean Install OS X in Recovery since it's inoperable .

MacBook Pro, OS X Mountain Lion (10.8.3)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.