1 2 3 Previous Next 37 Replies Latest reply: Jun 8, 2014 11:24 PM by lydcarol Go to original post
  • 15. Re: My iPod 7th gen has no sound
    anhng1227 Level 1 Level 1 (0 points)

    I have the same problem, I can't plug them in completely

  • 16. Re: My iPod 7th gen has no sound
    bongzki_02 Level 3 Level 3 (615 points)

    If that is the case, returning it sounds to be a good option. But make sure to check, when I said fully inserted, that the insulation of the headset plug is touching the body of the ipod (flushed). Hope the third one works. Cheers!

  • 17. Re: My iPod 7th gen has no sound
    jft91 Level 1 Level 1 (0 points)

    Did you update your ipod software? My new ipod sometimes didn't have sound when i play my music though the radio worked fine, so i plugged it back on to my computer and saw that it needed updating. Now it works fine.

  • 18. Re: My iPod 7th gen has no sound
    llminmi Level 1 Level 1 (0 points)

    I just had the same problem of no sound, which is why I was looking for info on this problem.  I knew it wasn't recognizing the earphones when I switched it to the radio function and it told me that I had to have the earphones plugged in.  I felt really stupid when I pushed really hard on the earphones and they then clicked into place!  I thought I was going to break it but figured it was broken already so what could it hurt.  It is really hard to click them in for the first time but I have sound now!!  Just stupid person error trying to be too careful!

  • 19. Re: My iPod 7th gen has no sound
    scott88008 Level 1 Level 1 (0 points)

    I just bought a second 7th generation iPod for my wife and headphone jack went out the first day.  Mine lasted a few months before it went out but I thought it was a fluke so I just listened with bluetooth as I mainly listen to audiobooks so don't need headphones. There's definitely a quality control problem as the chances of buying two with the same problem are small.

  • 20. Re: My iPod 7th gen has no sound
    MiamiBelle Level 1 Level 1 (0 points)

    Push it all the way in, this works

  • 21. Re: My iPod 7th gen has no sound
    scott88008 Level 1 Level 1 (0 points)

    This may work on some, put I've tried multiple headphones on both devices to the point of breaking (my hands are quite strong) and no go. I'm returning them this week (one is eligible for Best Buy return, the other I'll have to send to Apple. I guess I'm forced to by the extended warranty in the future on Apple products.

  • 22. Re: My iPod 7th gen has no sound
    janisutx Level 1 Level 1 (0 points)

    Thanks,   I couldn't believe how hard I had to push to insert the ear pods.  The white plastic should be flush against the metal.

  • 23. Re: My iPod 7th gen has no sound
    Rappy46 Level 1 Level 1 (0 points)

    I was about to return mine after trying everything to no avail... then read on this thread how you have to push until you think it will break.. I had another set of headphones here that I used to use on my old iPOD and decided to try them and with one last hard push after they stopped, I pushed down even harder and they snapped the rest of the way in and finally SOUND!  I then retried all my other previously failed cords (car, dock, etc.), and they all have sound now... it is no joke that you really have to push the plug wayyyyyyy in before you have sound.

  • 24. Re: My iPod 7th gen has no sound
    aoenen Level 1 Level 1 (0 points)

    Here's how I solved the same problem.

     

    When I inspected the input, i realized that rather than traditional input rings, there are 3 little "innovative" pins to connect to headphone jack, and naturally some dust inside. I thought that the pins might have some dust on them, so I dipped my headphone jack into alcohol (you can try with no-sugar booze with high alcohol in it - dry whisky vodka etc.) and plugged it into my ipod - I rolled it inside few times for some cleaning action. Then I unplugged the jack to let the alcohol evaporate. I turned on the device and plugged the phones. After some buzzing it came back to normal.

     

    Hope this helps

  • 25. Re: My iPod 7th gen has no sound
    llamaPOW Level 1 Level 1 (0 points)

    Seriously though, those headphones!! I just bought one this morning and had the same problem (hence I'm here). REALLY try to cram the headphone jack in, the whole way, so none of it is exposed. I thought it couldn't go any further but it could and that did the trick, it's got to be super snug!

  • 26. Re: My iPod 7th gen has no sound
    seanp78 Level 1 Level 1 (0 points)

    aoenen - THANK YOU!   I tried the pushing the headphones in on the radio setting to no avail, but your alcohol method worked fine.     I used vodka, FYI.    Thanks again.

  • 27. Re: My iPod 7th gen has no sound
    User122 Level 1 Level 1 (0 points)

    Thank you Illimini!  That was the problem with mine too.  I just had to really push the headphones in.  I'm feeling a bit dim right now.  Not sure I would have figured that out on my own!

  • 28. Re: My iPod 7th gen has no sound
    nermalsom Level 1 Level 1 (0 points)

    Thank you, thank you, thank you!  I thought I was losing it and didn't want to break it but you really have to push it hard so it works.  I just needed to know that I wasn't going to break something!

  • 29. Re: My iPod 7th gen has no sound
    Rhys2505 Level 1 Level 1 (0 points)

    From what I hear a lot of people are having problems with their iPod Nano 7s. I had just got a new one, it was working for a while and then it just wouldn't play any sound. I went to numerous other websites, they told me to restore it, retry everything. But one thing someone else said before. Hold down the on/off buttons to restore and then even though I had tried millions of times I jammed the Headphones as hard as I could into the jack and then... It worked.

     

    KEEP JAMMING THE HEADPHONES IN THE JACK UNTIL YOU HEAR STUFF!!!!!!!!!!!!!!