Skip navigation

HT1338: OS X: Updating OS X and Mac App Store apps

Learn about OS X: Updating OS X and Mac App Store apps

HT1338 upgraded to mountain lion and wifi keeps dropping

54639 Views 235 Replies Latest reply: Jul 25, 2013 1:42 AM by stevefromorpington RSS
  • mikewest Level 1 Level 1 (0 points)

    I've read and tried all the options (except for trying a new router, which I'll do tonight).  I've contacted Apple.  Some quick googling yeilds hundreds of pages of forums posts on this topic.  It's not solved. 

  • Mick_M Level 1 Level 1 (0 points)

    Have you confirmed that turing off all nearby 2.4GHz stuff (including BlueTooth devices) makes your WiFi connection reliable? The easiest way is to disable Bluetooth on your Mac and turn off nearby interfering devices e.g. that iPhone in your pocket or that 2.4GHz cordless phone on your desk. Sadly, I can't confirm that this is a Mountain Lion issue - I purchased a MacBook Pro Retina that came with Mountain Lion and I only started seeing the problem when I put that combination on my desk at work. My previous MacBook Pro running snow leopard on that very same desk connected to the corporate WiFi like a champ.

     

    I'm still working around the problem by connecting via ethernet and not using WiFi - I need my bluetooth trackpad and can't work without it. With every OS X upgrade I check if this is fixed, but it hasn't happened so far :-(. I also have that horrible screen ghosting/persistence problem on my new MacBook Pro Retina as well. This machine is just flawed...

  • mikewest Level 1 Level 1 (0 points)

    New router had no effect.  Wifi dropped in less than an hour.  I've removed all 2.4GHz equipment from the house. I afraid the notion of tethering a laptop to Ethernet is a bit nonsensical in my book. At the point, you should really get a higher performance desktop system of some kind.  I own 13" MBP's specifically for portability.

  • barcapat Level 1 Level 1 (0 points)

    As this thread is still ever growing with people encountering the Mountain Lion update/wifi dropping issue, I thought I'd add another reply on here to outline how I fixed the problem - at least for my own particular circumstances.

     

    I found that the only reliable way to fix the issue was to follow Apple's recommended wifi settings for iOS and OSX with the main change to my setup being to use WPA2 security. Until I made that change, things were dropping out sporadically since update to Mountain Lion on my iMac.

     

    I've also updated my own website's blog (blog.patwalsh.co.uk) with this info - and also info on some wifi troubleshooting software that may be very useful in solving wifi problems. 

  • gsspike Level 1 Level 1 (0 points)

    Anyone who thinks that just because some people have had some luck resolving the issue on their Mac's means that the problem is fixed are mistaken.  I for one have tried just about every fix posted and even replaced hardware.  Many of those test were done with Apple engineers on the phone with me.  I have two Macs running the same stuff, set up the same way.  One has never ever acted up and the other one has acted up since Lion.   I've reformatted and reinstalled ML  with the same exact results. Yes for a while I had mine acting up only every 3 days or so.  I didn't mind that to bad but as of a month ago I'm back to every few minutes having to reboot.

     

    Do you think the thread would keep growing if it did?  Don't you think Apple would have posted a bulletin about the fix or even better put a fix in an update? 

     

    If I'm wrong fine.  Send me the fix.  Don't tell us to go back search the threads.  Post the exact link for everyone.  But if the fix is out there, why isn't plastered out there in plain sight anyway?  Why, because there is no one fix for everyone.  There are just a bunch of different settings or changes that worked for some machines and not most others.

  • mikewest Level 1 Level 1 (0 points)

    I'm thinking about making a simple checklist.  People seem to make arbitrary changes and then claim victory when the issue doens't show up for a little while.  The to person who claims WPA2 magically solved the issue; I've been using WPA2 exclusively for years, yet we see the problem.  I own 3 13" MBP's.  The newer ones work well with ML, but the mid-2009 clearly has an issue that requires rebooting now and then.   The only solution seems to be putting up with it or buying a new machine.  If/when I replace that laptop, it will certainly not be with another Apple product.

     

    What I've tried:

    - replace kext's with ones from SL

    - full re-install (3x)

    - disable Bluetooth

    - remove all 2.4GHz equip from area/house

    - various forms of deleting all network configs and starting from scratch

    - MTU and other silly changes to network config

    - new router (in all modes)

    - Only S/W installed is Aperture and iMovie.  The rest is bone stock

    - 8GB RAM

  • RoxyAngel7 Level 1 Level 1 (10 points)

    I had the same problems with my iMac after upgrading to Mountain Lion. But I can promise you after purchasing the Apple Airport Express my issues with losing Internet connection were resolved. I haven't had any problems for more than 6 months.

    Now my question to you is, which router did you purchase? If it wasn't an Apple router then you'll continue to have issues. Also, did you go to your local Apple store and talk to someone in Genius Bar about your issue? And how many devices can your current router hold? Sometimes that may be the issue.

  • RoxyAngel7 Level 1 Level 1 (10 points)

    What type of router are you using?

  • mikewest Level 1 Level 1 (0 points)

    I've tried Netgear, DLINK, and Actiontec routers.  I have tested with only the single MBP connected.  Wifi (802.11) is a standard. The notion of having to use an Apple branded product is absurd.  

  • este.el.paz Level 1 Level 1 (90 points)

    Spike:

     

    Indeed, the problem doesn't seem to be going away for those that have the problem . . . I've offered my solution to the problem, downgrade to SL or turn to Linux, as my solutions--what I've done to "solve" the issue until such time as Apple comes up with an answer that seems to actually do something besides try to sell more Apple products . . . and I've posted several times in this thread basically saying the same thing.  Mr West says he can't take those options, that is his choice--but I agree with him that we shouldn't have to buy an Apple router to deal with the problem. 

     

    Yelling at each other isn't going to solve your problem, and Apple doesn't seem to want to "man-up" on this one . . . so you have to take action.  Nobody from Apple is going to post here, so there isn't any point to expecting that they will.  I don't have time to search google to answer your problem, as you suggest they could be multiple issues . . . .  But, as a long time Apple user I am concerned about how long this issue has remained largely unaddressed, especially for people who have computers that aren't that old, but, if you have a PPC computer that isn't news either.

     

    You asked for a link, I sent this to myself back in Feb as a possible option to try out, perhaps you've already tried it, perhaps not--it offers a couple things to try.

     

    http://www.applefansite.com/2012/07/how-to-fix-os-x-mountain-lions-wifi-issues/

     

    e.e.p.

     

    Edit: I just saw from the other "exclamation" thread that you might have tried these options . . . anyway, they might help somebody else.

  • Robert Lane AZ Level 1 Level 1 (135 points)

    Has anyone upgraded to 10.8.3 and noticed any change in behavior?

  • gsspike Level 1 Level 1 (0 points)

    Worse!

  • gsspike Level 1 Level 1 (0 points)

    Yep tried that at least 3x. Thanks for the link though.

     

    Apple does follow these threads.  It was my earlier post either in this thread or one of the others on the same subject that prompted Apple engineers call me multiple times. 

    How they can be dropping the ball this badly for so long just amazes me.  Two major operating system upgrades with the same issue.  That's why I gave up on Windows.

     

    I really believe Apple has given up on the Mac line as a market leader.  Macs are 2nd maybe 3rd class.

    My feelings based on what I see, Apple only cares about the "iPad".  Have you noticed all the newest and best Apps are for iPads and maybe a few include the iPhone. 

     

    Like I said I needed to vent.  

     

    Apple I know you're reading this. What are you doing?  Why can I go back to Snow Leopord and never drop wi-fi?

     

     

  • mikewest Level 1 Level 1 (0 points)

    10.8.3 has the same (or worse) behavior as 10.8.2.  I wonder if we should start a database of wireless cards?  Perhaps the issue is more easily resolved for certain cards.  The behaviors I'm seeing aren't at the IP/DNS layer - they seem to be driver/card related.  That's just a gut feeling at this point, though.

     

    My mid-2009 mbp has:

    Card Type:                  AirPort Extreme  (0x14E4, 0x8D)

    Firmware Version:        Broadcom BCM43xx 1.0 (5.106.98.100.16)

    OS X 10.8.3.

  • mikewest Level 1 Level 1 (0 points)

    How is it my choice to not downgrade to SL?  I paid for Aperture, and it requires ML.  Apple made this choice for me.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.